#1 2017-05-09 15:28:45

Alain-81
Membre
Merville (31)
2007-09-28
64

Site KO suite migration V2.9

Bonjour,

J'ai cliqué rapidement pour installer la nouvelle version proposée (2.9), et le site n'est plus accessible.
Évidemment je n'ai pas sauvegardé la BdD.

Voilà le joli message que j'obtiens :

Warning:  [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '23,21)
    AND (
      ic.category_id != i.storage_category_id
      OR i.storag' at line 5

SELECT
    DISTINCT(category_id) AS id
  FROM piwigo_image_category AS ic
    JOIN piwigo_images AS i ON i.id = ic.image_id
  WHERE ic.image_id IN (812,793,792,791,790,789,788,787,786,785,784,783,782,781,780,779,778,794,795,811,810,809,808,807,806,805,804,803,802,801,800,799,798,797,796,777,776,775,756,755,754,753,752,751,750,749,748,747,746,745,744,743,742,741,757,758,774,773,772,771,770,769,768,767,766,765,764,763,762,761,760,759,740,885,866,865,864,863,862,861,860,859,858,857,856,855,854,853,852,851,867,868,884,883,882,881,880,879,878,877,876,875,874,873,872,871,870,869,850,849,848,829,828,827,826,825,824,823,822,821,820,819,818,817,816,815,814,830,831,847,846,845,844,843,842,841,840,839,838,837,836,835,834,833,832,813,666,647,646,645,644,643,642,641,640,639,638,6 in /home/capucinej/piwi/include/dblayer/functions_mysqli.inc.php on line 845


Fatal error: Uncaught Error: Call to a member function fetch_assoc() on boolean in /home/capucinej/piwi/include/dblayer/functions_mysqli.inc.php:893 Stack trace: #0 /home/capucinej/piwi/admin/batch_manager_global.php(561): query2array('\nSELECT\n DIS...', 'id', 'id') #1 /home/capucinej/piwi/admin/batch_manager.php(780): include('/home/capucinej...') #2 /home/capucinej/piwi/admin.php(302): include('/home/capucinej...') #3 {main} thrown in /home/capucinej/piwi/include/dblayer/functions_mysqli.inc.php on line 893

Version de Piwigo:
Version de PHP: 7.0.15
Version de MySQL: 4.4.15.7
URL Piwigo: http://piwi.capucinet.fr/


Piwigo 2.8.6

Hors ligne

#2 2017-05-09 17:02:44

Alain-81
Membre
Merville (31)
2007-09-28
64

Re: Site KO suite migration V2.9

Bon j'ai downgradé en version 2.8.6 et j'ai retrouvé mon Piwigo.
Si je vais sur la mise à jour Piwigo dans l'administration et clique sur "Sauvegarder la BdD" j'ai un message d'erreur :

Fatal error: Uncaught Error: Call to undefined function mysql_select_db() in /home/capucinej/piwi/admin/include/mysqldump.php:75 Stack trace: #0 /home/capucinej/piwi/admin/include/mysqldump.php(66): MySQLDump->setDatabase('capucinejcapu') #1 /home/capucinej/piwi/admin/include/updates.class.php(314): MySQLDump->__construct('capucinejcapu', '/home/capucinej...', false, false) #2 /home/capucinej/piwi/admin/updates_pwg.php(134): updates::dump_database(false) #3 /home/capucinej/piwi/admin/updates.php(43): include('/home/capucinej...') #4 /home/capucinej/piwi/admin.php(301): include('/home/capucinej...') #5 {main} thrown in /home/capucinej/piwi/admin/include/mysqldump.php on line 75

Je pense qu'il vaut mieux ne pas relancer la migration vers la 2.9 !

Dernière modification par Alain-81 (2017-05-09 17:03:02)


Piwigo 2.8.6

Hors ligne

#3 2017-05-12 10:38:47

slr56
Membre
2017-05-05
7

Re: Site KO suite migration V2.9

Bonjour Alain-81,

La première chose que je remarque dans les informations que vous donnez, c'est la version de MySQL que vous indiquez : 4.4.15.7 C'est une très vieille version. Or pour faire fonctionner Piwigo, il faut une version 5.X et actuellement les serveurs utilisent les versions 5.5 à 5.7.

Si vous avez vraiment la 4.4.15.7 (ce qui est surprenant avec toutes les failles de sécurité...), il faut voir pour mettre à jour MySQL.  En plus des failles de sécurité, il y a des fonctionnalités nouvelles et des fonctions qui n'existent plus.

Cdt,

slr56

Dernière modification par slr56 (2017-05-12 10:40:36)

Hors ligne

#4 2017-05-12 11:16:24

Alain-81
Membre
Merville (31)
2007-09-28
64

Re: Site KO suite migration V2.9

Bjr slr56

Oh désolé en fait j'ai bêtement copié la version de l'aide de Mysql. Je suis réellement en version 5.5.55.

Merci de l’intérêt porté à mon souci.

Alain


Piwigo 2.8.6

Hors ligne

#5 2017-05-14 22:16:37

flop25
Équipe Piwigo
2006-07-06
6378

Re: Site KO suite migration V2.9

bonjour [Github] Piwigo issue #663
envoyez votre base de données à plg /at/ piwigo.org

Hors ligne

Pied de page des forums

Propulsé par FluxBB