•  » Utilisation
  •  » [Résolu] Erreur suite à installation plugin UserCustomFields

#1 2017-04-02 18:00:49

diaph
Membre
Provence
2017-03-19
55

[Résolu] Erreur suite à installation plugin UserCustomFields

Bonjour/Bonsoir,

J'ai installé le plugin UserCustomFields
J'ai maintenant ce message :

Fatal error: Uncaught --> Smarty: unable to write file /htdocs/_data/templates_c/wrt58e11d322ed346_94207320 <-- thrown in /htdocs/include/smarty/libs/sysplugins/smarty_internal_runtime_writefile.php on line 48

Du coup, je n'ai plus accès au site...

Si quelqu'un peut m'aider...

Version de Piwigo: 2.8.6
Version de PHP: 5.4
Version de MySQL:
URL Piwigo: http://


Versio Piwigo : 2.9.4
Version de PHP 7.1.21
Version de MySQL 5.5.5-10.1.34-MariaDB-1~jessie
Hébergement : LWS - Mutualisé Linux

Hors ligne

#2 2017-04-02 18:28:37

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14241

Re: [Résolu] Erreur suite à installation plugin UserCustomFields

Bonjour,

par FTP vérifier le droit en écriture de _data/templates_c
je suis pas sur que ce soit lié au plugin la le message d'erreur donne une erreur de permission en écriture


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2017-04-02 18:46:06

diaph
Membre
Provence
2017-03-19
55

Re: [Résolu] Erreur suite à installation plugin UserCustomFields

Bonsoir ddtddt,

Merci pour ta réponse, mais ce n'est pas un problème de permissions tout est à 755.
Cela dit, j'ai restaurer la base de donnée à hier, et j'ai supprimer par ftp le plugin concerné + d'autres plugins que j'avais installé ce matin.
Maintenant, le message à disparu et le site refonctionne !
Je vais retenter de réinstaller (avec précaution les fameux plugins).
Il est possible qu'il y ai eu un bug car j'avais des inscriptions (fictives pour test) et le fait d'ajouter des champs pour les nouvelles inscriptions ; ça à dû cafouiller ! J'ai supprimer ces inscriptions : je vais bien voir...


Versio Piwigo : 2.9.4
Version de PHP 7.1.21
Version de MySQL 5.5.5-10.1.34-MariaDB-1~jessie
Hébergement : LWS - Mutualisé Linux

Hors ligne

#4 2017-04-02 19:49:20

diaph
Membre
Provence
2017-03-19
55

Re: [Résolu] Erreur suite à installation plugin UserCustomFields

Le site à retrouvé ses fonctions, reste à mettre à jour...

SAUF ! que le plugin UserCustomFields ne fonctionne pas : les champs supplémentaires s'affichent bien sur la page, mais pas le Capcha ! D'autre part quand je confirme l'inscription, j'ai un message d'erreur insertion dans la base...
Solution(s)?
Merci


Versio Piwigo : 2.9.4
Version de PHP 7.1.21
Version de MySQL 5.5.5-10.1.34-MariaDB-1~jessie
Hébergement : LWS - Mutualisé Linux

Hors ligne

#5 2017-04-02 19:55:57

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14241

Re: [Résolu] Erreur suite à installation plugin UserCustomFields

re

tu as quoi comme message d'erreur ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#6 2017-04-02 20:20:08

diaph
Membre
Provence
2017-03-19
55

Re: [Résolu] Erreur suite à installation plugin UserCustomFields

J'ai désinstallé le plugin puis réinstallé, je n'ai plus de message d'erreur, mais je ne comprend pas le but de ce plugin : après l'inscription du visiteur, aucun champs supplémentaires n'apparaissent dans l'admin : je n'ai donc aucune information supplémentaire...


Versio Piwigo : 2.9.4
Version de PHP 7.1.21
Version de MySQL 5.5.5-10.1.34-MariaDB-1~jessie
Hébergement : LWS - Mutualisé Linux

Hors ligne

#7 2017-04-03 06:32:20

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14241

Re: [Résolu] Erreur suite à installation plugin UserCustomFields

Bonjour,

Dans Administration > Plugins > 'Gérer les propriété des utilisateurs'

est ce que tu as ajouté des propriétés ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#8 2017-04-03 12:06:08

diaph
Membre
Provence
2017-03-19
55

Re: [Résolu] Erreur suite à installation plugin UserCustomFields

Bonjour,
Je n'avais pas installé le plugin UserAdvManager, peut-être pour ça que cela ne fonctionne pas.
Par contre, lorsque j'ai voulu installé UserAdvManager, J'ai un message : "

    Une erreur est survenue pendant l'extraction des fichiers (write_error).
    Vérifiez les permissions du dossier "plugins" et de ses sous-dossiers (CHMOD).

". Alors j'ai mis tout les dossiers et fichiers "plugins" en 777 : mais rien n'y fait !

Dernière modification par diaph (2017-04-03 12:37:53)


Versio Piwigo : 2.9.4
Version de PHP 7.1.21
Version de MySQL 5.5.5-10.1.34-MariaDB-1~jessie
Hébergement : LWS - Mutualisé Linux

Hors ligne

#9 2017-04-03 13:08:47

diaph
Membre
Provence
2017-03-19
55

Re: [Résolu] Erreur suite à installation plugin UserCustomFields

J'ai supprimer tout les inscrits (inscrits test) les pluging "User Collections", qui était actif, et "User Custom Fields". Du coup, j'ai pu installer "UserAdvManager".
Dois-je remettre mes dossiers en 755 et fichiers en 644 ? parce qu'apparemment ça n'a rien à voir !
Il y a des bugs qui se font, mais où ?!
Enfin je vais essayé de tout remettre à plat : mais je ne voudrais pas planter la galerie : j'ai déjà 12000 photos HD dessus !
Merci à toi ddtddt pour tes réponses.
J'attends un peu avant de fermer le sujet...


Versio Piwigo : 2.9.4
Version de PHP 7.1.21
Version de MySQL 5.5.5-10.1.34-MariaDB-1~jessie
Hébergement : LWS - Mutualisé Linux

Hors ligne

#10 2017-04-03 14:00:59

diaph
Membre
Provence
2017-03-19
55

Re: [Résolu] Erreur suite à installation plugin UserCustomFields

Bon ! C'est reparti pour les bugs !
J'ai réinstallé User Custom Fields, j'ai créer des champs supplémentaires, et Zou ! re message :

Fatal error: Uncaught --> Smarty: unable to write file /htdocs/_data/templates_c/wsvs72e11d884ed346_94207437 <-- thrown in /htdocs/include/smarty/libs/sysplugins/smarty_internal_runtime_writefile.php on line 48

Tout se bloque et je suis obliger de supprimer le plugin par ftp !

Pour l'instant, j'ai laissé UserAdvManager par défaut, mais je ne peux plus y accéder (toujours même message), ni gérer Utilisateurs... La galerie n'est plus accessible !!!!

J'ai encore accès aux plugins.

Je ne comprends pas ce qui se passe.

Voilà les plugins qui sont installés :

    Additional Pages
    Admin Tools
    Advanced Menu Manager
    Batch Downloader
    Contact Form
    Grum Plugin Classes
    Header Manager
    Image Preview
    LocalFiles Editor
    Perso Footer
    PWG Stuffs
    Social Buttons
    Take a Tour
    Thumbnail Tooltip
    UserAdvManager

Dernière modification par diaph (2017-04-03 14:06:19)


Versio Piwigo : 2.9.4
Version de PHP 7.1.21
Version de MySQL 5.5.5-10.1.34-MariaDB-1~jessie
Hébergement : LWS - Mutualisé Linux

Hors ligne

#11 2017-04-03 20:07:18

diaph
Membre
Provence
2017-03-19
55

Re: [Résolu] Erreur suite à installation plugin UserCustomFields

Bonsoir,

Voilà ce que j'ai sur le fichier "smarty_internal_runtime_writefile.php" :

public function writeFile($_filepath, $_contents, Smarty $smarty)
    {
        $_error_reporting = error_reporting();
        error_reporting($_error_reporting & ~E_NOTICE & ~E_WARNING);
        $_file_perms = property_exists($smarty, '_file_perms') ? $smarty->_file_perms : 0644;
        $_dir_perms = property_exists($smarty, '_dir_perms') ? (isset($smarty->_dir_perms) ? $smarty->_dir_perms : 0777)  : 0771;
        if ($_file_perms !== null) {
            $old_umask = umask(0);
        }

        $_dirpath = dirname($_filepath);
        // if subdirs, create dir structure
        if ($_dirpath !== '.' && !file_exists($_dirpath)) {
            mkdir($_dirpath, $_dir_perms, true);
        }

        // write to tmp file, then move to overt file lock race condition
        $_tmp_file = $_dirpath . DS . str_replace(array('.', ','), '_', uniqid('wrt', true));
        if (!file_put_contents($_tmp_file, $_contents)) {
            error_reporting($_error_reporting);
            throw new SmartyException("unable to write file {$_tmp_file}");
       }

J'ai désactivé tous les plugins qui me posaient soucis, et j'ai toujours le message cité précédemment.

Si quelqu'un à une idée...


Versio Piwigo : 2.9.4
Version de PHP 7.1.21
Version de MySQL 5.5.5-10.1.34-MariaDB-1~jessie
Hébergement : LWS - Mutualisé Linux

Hors ligne

#12 2017-04-04 00:29:39

k5
Membre
lieu
2014-01-26
278

Re: [Résolu] Erreur suite à installation plugin UserCustomFields

Bonjour diaph, Un quota dépassé ?

Cordialement
k5


Ayez comme premier réflexe de faire les mises à jours piwigo et extensions. merci

Hors ligne

#13 2017-04-04 03:04:30

diaph
Membre
Provence
2017-03-19
55

Re: [Résolu] Erreur suite à installation plugin UserCustomFields

Bonjour,

k5 a écrit:

Un quota dépassé ?

Je ne sais pas : quel quota ?


Versio Piwigo : 2.9.4
Version de PHP 7.1.21
Version de MySQL 5.5.5-10.1.34-MariaDB-1~jessie
Hébergement : LWS - Mutualisé Linux

Hors ligne

#14 2017-04-04 06:48:29

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14241

Re: [Résolu] Erreur suite à installation plugin UserCustomFields

Bonjour

et en désactivant UserAdvManager ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#15 2017-04-04 08:03:43

diaph
Membre
Provence
2017-03-19
55

Re: [Résolu] Erreur suite à installation plugin UserCustomFields

Bonjour,

ddtddt a écrit:

et en désactivant UserAdvManager ?

J'ai essayé, mais ça ne fonctionne pas non plus. En revanche j'ai supprimer plein de plugins inutiles : et là!, j'ai retrouvé les fonctions normales... Je croise les doigts !

A part les incompatibilités potentielles, y a t'il une limite dans le nombre de plugins installés ?


Versio Piwigo : 2.9.4
Version de PHP 7.1.21
Version de MySQL 5.5.5-10.1.34-MariaDB-1~jessie
Hébergement : LWS - Mutualisé Linux

Hors ligne

  •  » Utilisation
  •  » [Résolu] Erreur suite à installation plugin UserCustomFields

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2018 · Contact