Annonce

  •  » Utilisation
  •  » Erreur dans l'affichage de diapo.php...

#1 2002-04-20 09:53:47

Fiflo
Membre
Toulouse
2002-04-17
3

Erreur dans l'affichage de diapo.php...

Salut z0rglub,

J'ai uploadé la nouvelle version sur mon serveur (sans nouvelle install) et à la demande de "diapo.php", j'ai une erreur :

Warning: Supplied argument is not a valid MySQL result resource in diapo.php on line 348  8O 

J'ai regardé le code, je ne vois pas l'erreur...


Fiflo.

Hors ligne

#2 2002-04-20 10:18:10

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12364

Re: Erreur dans l'affichage de diapo.php...

c complètement normal, j'ai pas sorti le patch pour mettre à jour. En effet, le schéma de la base de données est modifié.
voici le patch :

Code:

 
<?php 
  include("../include_phpwebgallery/mysql.inc.php"); 
  mysql_connect($cfgHote, $cfgUser, $cfgPassword) or die ("erreur de connexion au serveur"); 
  mysql_select_db($cfgBase) or die ("erreur de connexion a la base de donnees"); 
   
  $query = " 
  alter table $prefixeTable"."images 
  add tn_ext char(3) NOT NULL default 'jpg'"; 
  mysql_query($query); 
   
  $query = " 
  alter table $prefixeTable"."images 
  add intitule varchar(100)"; 
  mysql_query($query); 
  echo"mise à jour effectuée"; 
?> 

tu colles ça dans un fichier patch.php tu le mets dans le rep de base et tu le lances. ça doit marcher (j'ai testé plusieurs fois).
Donnes moi des nouvelles.


Dernier billet du blog Piwigo.com (18 mars 2020) Covid19 : allongement de la période d’essai pour les entreprises

Hors ligne

#3 2002-04-20 10:54:46

Fiflo
Membre
Toulouse
2002-04-17
3

Re: Erreur dans l'affichage de diapo.php...

Autant pour moi, j'aurais dû me douter qu'il y avait eu de smodifs dans les tables.

J'ai supprimé l'ancienne table "images" et je l'ai recrée à l'aide du nouveau "creationDB.php". ;) 

Ca marche. :D 

L'apport du titre, du commentaire est super !  A mon avis cela amène un plus incontestable...

Deux suggestions pour l'avenir :

- l'affichage de flèches de navigation au dessous du cadre image (précédente - suivante).

- personnalisation des couleurs dans l'admin pour mettre l'album aux couleurs de son site. En l'état actuel des choses, vu comment tu as créé les tableaux (gif d'encadrement), je ne vois pas trop comment faire...

Peut être saisir la couleur du fond à part (sous la forme #FFFFFF par exemple). Pour les cadres, je ne vois pas...

Merci pour ton support et ta disponibilité. :D 

A +


Fiflo.

Hors ligne

#4 2002-04-20 11:06:57

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12364

Re: Erreur dans l'affichage de diapo.php...

bon, t'as pas de bol, parce que je mets en ligne la version 1.0.2... elle gère les permissions des utilisateurs à certaines rubriques... Je vais aussi mettre le patch pour le passage de la 1.0.1 à la 1.0.2...


Dernier billet du blog Piwigo.com (18 mars 2020) Covid19 : allongement de la période d’essai pour les entreprises

Hors ligne

  •  » Utilisation
  •  » Erreur dans l'affichage de diapo.php...

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact