#1 2016-08-04 09:47:13

Ibanez
Invité

Bug dans category_cats.inc.php

Bonjour/Bonsoir,

J'ai un léger bug qui survient ces derniers temps, qui est lié à la ligne 298 du fichier category_cats.inc.php, et donc à la variable $infos_of_image[ $category['representative_picture_id'] ].

En effet, lorsque j'ajoute une photo via community , et que je me rend sur le site, un message d'erreur apparait (capture : http://img4.hostingpics.net/pics/408031 … 093315.png). Ensuite, quand j'actualise la page, cela re-fonctionne. J'ai également eu un autre problème lié à cette variable : La catégorie dans la quelle était située la photo ajoutée n'était plus accessible (même message d'erreur), et j'ai du supprimer la photo pour pouvoir y accéder.

Je suppose que c'est lié à la photo représentative d'un album qui ne doit pas être bien définie lorsque j'ajoute une photo via community ?


Version de Piwigo:
Version de PHP:
Version de MySQL:
URL Piwigo: http://

#2 2016-08-04 10:21:07

Ibanez
Invité

Re: Bug dans category_cats.inc.php

En regardant de plus près le fichier category_cats.inc.php, je m'aperçois que le problème vient du fait que piwigo cherche à générer une image représentative pour les catégories de manière aléatoire, ceci explique pourquoi le bug n'intervient pas tout le temps après un upload. Mais pourquoi les images que j'uploade posent problème pour représenter une catégorie ?

#3 2016-08-04 10:28:55

Ibanez
Invité

Re: Bug dans category_cats.inc.php

J'ai refait le test en ajoutant une photo via community en tant qu'admin : Après envoi et retour sur la page d'accueil :

Notice: Undefined offset: 0 in /var/www/public_html/piwigo_dump0208/include/category_cats.inc.php on line 298

Catchable fatal error: Argument 2 passed to DerivativeImage::__construct() must be an instance of SrcImage, null given, called in /var/www/public_html/piwigo_dump0208/include/template.class.php on line 1275 and defined in /var/www/public_html/piwigo_dump0208/include/derivative.inc.php on line 194

Après avoir actualisé la page 6 ou 7 fois, cela fonctionne !

#4 2016-08-09 19:23:39

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12256

Re: Bug dans category_cats.inc.php

Ibanez a écrit:

En regardant de plus près le fichier category_cats.inc.php, je m'aperçois que le problème vient du fait que piwigo cherche à générer une image représentative pour les catégories de manière aléatoire, ceci explique pourquoi le bug n'intervient pas tout le temps après un upload. Mais pourquoi les images que j'uploade posent problème pour représenter une catégorie ?

Je dirais que Piwigo essaie d'afficher comme miniature d'album une photo à laquelle l'utilisateur n'a pas accès. Mais normalement ça devrait marcher :-/


Dernier billet du blog Piwigo.com (3 mai 2018) Nouveau formulaire d'abonnement

Hors ligne

Pied de page des forums

Propulsé par FluxBB