•  » Installation
  •  » Problème de maj en 2.8 sur ma gallerie

#1 2016-03-09 18:43:12

jacklege
Membre
2006-04-15
14

Problème de maj en 2.8 sur ma gallerie

Bonsoir,
Ma galerie est hébergée chez free et j'ai voulu la  passer de 2.7.4 en 2.8 . La mise a jour automatique me retournait une erreur (erreur survenue) et je l'ai fait en manuel en suivant la procédure .
à présent j'obtiens une petite barre d'attente lorsque ej vais sur le site http://jacklege.free.fr/galerie

et si j'affiche le code source de la page :

<div class="loader"><img src="themes/default/images/ajax_loader.gif"></div>
<ul class="thumbnailCategories">


  <li class="even">
        <div class="thumbnailCategory">
            <div class="illustration">
            <a href="index.php?/category/237">
                <img src="themes/default/icon/img_small.png" data-src="i.php?/upload/2013/12/03/20131203231219-b79e865a-th.jpg" alt="un piano pour romane" title="<br />
<b>Fatal error</b>:  Call to undefined function mb_split() in <b>/var/www/sda/4/1/jacklege/galerie/include/smarty/libs/plugins/shared.mb_str_replace.php</b> on line <b>48</b><br />

je vois bien fatal error et l'appel à une fonction mb_split() qui pose problème , je ne crois pourtant pas avoir oublie de fichier dans le transfert.

si vous avez une idée  ? Merci !



Version de Piwigo: 2.8
Version de PHP:
Version de MySQL: 5.08.3
URL Piwigo: http://

Hors ligne

#2 2016-03-10 09:55:54

flop25
Équipe Piwigo
2006-07-06
6466

Hors ligne

#3 2016-03-10 09:58:07

flop25
Équipe Piwigo
2006-07-06
6466

Re: Problème de maj en 2.8 sur ma gallerie

ha page picture aussi
Call to undefined function mb_split() in ...

Hors ligne

#4 2016-03-10 10:03:05

flop25
Équipe Piwigo
2006-07-06
6466

Re: Problème de maj en 2.8 sur ma gallerie

Avez vous un .htaccess ? si oui quel est le contenu svp ?

Hors ligne

#5 2016-03-10 11:57:12

jacklege
Membre
2006-04-15
14

Re: Problème de maj en 2.8 sur ma gallerie

bonjour flop25,

oui j'ai mis un fichier htaccess à la racine :

voici le contenu :

<IfDefine Free>
    php56 1
</IfDefine>

deny from     188.143.234.155   
deny from     193.201
deny from     188.143.232

Hors ligne

#6 2016-03-11 12:40:53

marcophilie56
Membre
2007-01-22
169

Re: Problème de maj en 2.8 sur ma gallerie

J'ai la même erreur
Je peux me connecter à l'admin et visualiser l'album public ainsi que ces images
mais les albums privés

Hors ligne

#7 2016-03-11 16:36:15

flop25
Équipe Piwigo
2006-07-06
6466

Re: Problème de maj en 2.8 sur ma gallerie

je pense qu'il faudrait aller interpeller les admin Free dans leur newsgroup J'ai vu des messages archivés à ce sujet en aout 2015

Hors ligne

#8 2016-03-11 19:31:20

JAG
Membre
1970-01-01
9

Re: Problème de maj en 2.8 sur ma gallerie

bonsoir à tous,

j'ai le même problème si quelqu'un a la solution
merci par avance

Hors ligne

#9 2016-03-11 22:32:11

Duthilleul
Invité

Re: Problème de maj en 2.8 sur ma gallerie

Bonsoir,

J'avais le même soucis
Call to undefined function mb_split() in /var/www/sda/2/5/x.duthilleul/include/smarty/libs/plugins/shared.mb_str_replace.php on line 48

En fouillant sur le net, j'ai vu que quelqu'un avait remplacé la fonction mb_string par preg_split.

j'ai donc changé le ligne 48 du fichier include/smarty/libs/plugins/shared.mb_str_replace.php
       $parts = preg_split(preg_quote($search), $subject);

et ca fonctionne, mon site est a nouveau accessible
http://x.duthilleul.free.fr

#10 2016-03-12 00:21:15

Duthilleul
Invité

Re: Problème de maj en 2.8 sur ma gallerie

petite mise à jour
la syntaxe pour la ligne 48 est
      $parts = preg_split('~preg_quote($search)~', $subject);
sinon il y a des warnings qui s'affichent quand on passe la souris sur un dossier de photos

#11 2016-03-12 08:58:00

JAG
Membre
1970-01-01
9

Re: Problème de maj en 2.8 sur ma gallerie

Bonjour,

merci pour la réponse,

je confirme cela fonctionne

bonne journée à tous

Hors ligne

#12 2016-03-12 09:44:29

jacklege
Membre
2006-04-15
14

Re: Problème de maj en 2.8 sur ma gallerie

bonjour,

je viens de faire la modification également et cela fonctionne bien également .Merci à Duthilleul d'avoir donné cette solution qu'il faut garder en mémoire pour les futures mises à jour.

Par contre le plug-in  Image-preview ne marche plus, bien qu'il soit noté comme compatible avec cette nouvelle version.

J'ai l'impression que le soft "smarty" a quelque problème de compatibilité avec la version php car il y a encore une information "Fatal error: Call to undefined method Template::get_debug_vars() in /var/www/sda/4/1/jacklege/galerie/include/smarty/libs/sysplugins/smarty_internal_debug.php on line 235"
si l'on affiche le debug templates .

Mais la galerie fonctionne et c'est le principal.

merci à l’équipe de piwigo pour cette nouvelle version !

Hors ligne

#13 2016-03-12 23:14:45

jacklege
Membre
2006-04-15
14

Re: Problème de maj en 2.8 sur ma gallerie

Grâce à la mise a jour d’aujourd’hui "Image preview" fonctionne bien . Merci à Flop 25 !

Hors ligne

  •  » Installation
  •  » Problème de maj en 2.8 sur ma gallerie

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact