Annonce

  •  » Plugins
  •  » [Résolu] Ma favivon n'apparaît que dans les pages d'administration

#1 2016-03-08 12:30:32

fabrigo
Membre
2013-09-25
19

[Résolu] Ma favivon n'apparaît que dans les pages d'administration

Bonjour à tous

J'utilise le plug-in persofavicon. Ma favicon pèse moins de 2ko et est au format.ico. Je pense que tout fonctionne bien à part une bizarrerie : la favicon n'apparaît que dans les pages d'administration de piwigo.

Version de Piwigo: 2.7.4
Version de PHP: 5.6.17
Version de MySQL: 5.5.46-0+deb7u1-log
URL Piwigo: http://www.guingamproller.fr/piwigo/
Version de mon navigateur (je n'ai pas d'autres ordis ou navigateurs sous la main): Firefox 44.0.2, Midori 0.4.3 (WebKitGTK+    1.10.1 (2.4.8))
Version de PersoFavicon: 2.7.a
Hébergeur: OVH


Merci pour vos éclairages

fabrigo

Hors ligne

#2 2016-03-08 13:06:42

flop25
Équipe Piwigo
2006-07-06
6477

Re: [Résolu] Ma favivon n'apparaît que dans les pages d'administration

bonjour

et avec un thème normal (Elegant par ex) cela se reproduit ?

Hors ligne

#3 2016-03-09 11:40:28

fabrigo
Membre
2013-09-25
19

Re: [Résolu] Ma favivon n'apparaît que dans les pages d'administration

Tout marche bien avec le thème elegant

Hors ligne

#4 2016-03-09 11:56:27

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14909

Re: [Résolu] Ma favivon n'apparaît que dans les pages d'administration

fabrigo a écrit:

Tout marche bien avec le thème elegant

je dirais que tu as tellement (ou celui qui a fait ton thème) modifié le code de piwigo que le préfiltre ne fonctionne plus

Tu utilises quoi comme thème ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#5 2016-03-09 15:38:47

flop25
Équipe Piwigo
2006-07-06
6477

Re: [Résolu] Ma favivon n'apparaît que dans les pages d'administration

ddtddt a écrit:

fabrigo a écrit:

Tout marche bien avec le thème elegant

je dirais que tu as tellement (ou celui qui a fait ton thème) modifié le code de piwigo que le préfiltre ne fonctionne plus

Tu utilises quoi comme thème ?

je te conseillerais de faire un check pour voir si le preg trouve qqchose et si non, alors populer $head_elements

Hors ligne

#6 2016-03-09 17:59:24

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14909

Re: [Résolu] Ma favivon n'apparaît que dans les pages d'administration

Bonjour,

Franchement vu ce que je filtre, si le pré filtre ne le trouve pas c'est que le concepteur du thème ne veux pas de favicon !


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#7 2016-03-10 22:29:06

fabrigo
Membre
2013-09-25
19

Re: [Résolu] Ma favivon n'apparaît que dans les pages d'administration

ddtddt a écrit:

je dirais que tu as tellement (ou celui qui a fait ton thème) modifié le code de piwigo que le préfiltre ne fonctionne plus

Tu utilises quoi comme thème ?

J'utilise modus et je n'ai modifié que le css grâce au plug-in localfiles editor.

J'ai essayé de bidouiller le fichier header.tpl mais sans succès. Du coup, j'ai envoyé un mail au créateur du thème ... À suivre. Je vous tiendrais au courant.

Merci pour votre temps et vos réponses.

fabrigo

Hors ligne

#8 2016-03-11 05:58:19

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14909

Re: [Résolu] Ma favivon n'apparaît que dans les pages d'administration

Bonjour,

Pour modus cela a été corrigé le 7 mais 2015 tu utilise quelle version de Piwigo et du thème ?

essais de prendre ce fichier

[Github] piwigo-modus file template/header.tpl

de le mettre sur ton site

de purger les templates compilés

de forcer le renouvellement du cache de ton navigateur


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#9 2016-03-16 11:07:07

fabrigo
Membre
2013-09-25
19

Re: [Résolu] Ma favivon n'apparaît que dans les pages d'administration

Bonjour

J'utilise piwigo 2.8.0 (mauvaise manip en FTP donc réinstallation le week-end dernier) et le thème modus 2.7.e (piwigo m'indique que tous les thèmes sont à jour).

J'ai comparé le fichier header.tpl du thème et celui que tu me propose -> ils sont identiques.

J'ai fait tout ce que tu m'as demandé (sauf purger les templates compilés : qu'entends-tu par là ?), mais rien de mieux. C'est même pire : je n'ai même plus de favicon sur les pages d'administration. J'ai réessayé le thème elegant : plus de favicon ! (alors que ça fonctionnait très bien avec ce thème).

La seule différence avec la semaine dernière est le passage de piwigo 2.7.4 à 2.8.0.
Est-ce de là que provient le soucis ?

Hors ligne

#10 2016-03-16 11:09:05

flop25
Équipe Piwigo
2006-07-06
6477

Re: [Résolu] Ma favivon n'apparaît que dans les pages d'administration

pb de cache navigateur Pb souvent rencontré pour les favicon Moi j'ai votre favicon actuellemnt

Hors ligne

#11 2016-03-16 11:41:24

fabrigo
Membre
2013-09-25
19

Re: [Résolu] Ma favivon n'apparaît que dans les pages d'administration

Merci beaucoup, c'est OK pour moi aussi
Par contre, même en vidant le cache, ça n'apparaissait pas, il a fallu que je relance mon navigateur (firefox)

Hors ligne

#12 2019-08-16 14:25:49

Katryne
Membre
Provence
2016-12-03
537

Re: [Résolu] Ma favivon n'apparaît que dans les pages d'administration

Hello Hello !
Ce post a 3 ans, mais j'ai le même problème, et depuis plus d'un an sur l'un des sites. Entre temps, j'ai changé de navigateur, d'ordinateur, de lunettes, de ...
Cela le faisait dans Piwigo 2.8, 2.9x, 2.10 beta et pour les thèmes Clear et Bootstrap Darkroom. Le favicon orange de Piwigo est vraiment très collant.
Mais si je veux le remplacer méchamment par FTP, où est-ce que je le trouve ce petit appareil photo orange ?


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.10.2 -  Système d'exploitation: Linux - Hébergeur 1&1-Ionos
PHP: 7.3.15 - MySQL: 5.7.28-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

#13 2019-08-16 15:15:13

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14909

Re: [Résolu] Ma favivon n'apparaît que dans les pages d'administration

Bonjour

dans les page d'administration il n'y a que toi qui les vois ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#14 2019-08-16 17:42:21

Katryne
Membre
Provence
2016-12-03
537

Re: [Résolu] Ma favivon n'apparaît que dans les pages d'administration

Moi, je vois le nouveau favicon en admin et seulement en admin sous plusieurs navigateurs.
Il faut que je demande à mes 3 administrateurs ce qu'ils voient.


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.10.2 -  Système d'exploitation: Linux - Hébergeur 1&1-Ionos
PHP: 7.3.15 - MySQL: 5.7.28-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

#15 2019-08-16 17:46:45

Katryne
Membre
Provence
2016-12-03
537

Re: [Résolu] Ma favivon n'apparaît que dans les pages d'administration

Rectification : le favicon modifié est bien visible sur le site avec le thème Clear.
Il ne l'est qu'en admin sur les 2 sites avec le thème Bootstrap Darkroom. Et sur ces 2 sites, je suis seule admin.


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.10.2 -  Système d'exploitation: Linux - Hébergeur 1&1-Ionos
PHP: 7.3.15 - MySQL: 5.7.28-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

  •  » Plugins
  •  » [Résolu] Ma favivon n'apparaît que dans les pages d'administration

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact