•  » Installation
  •  » [Résolu] [[2.7.4][Free][AUTORESOLU] - Installation et détection de PHP5

#1 2015-08-27 21:58:55

Aimede
Membre
2015-08-27
1

[Résolu] [[2.7.4][Free][AUTORESOLU] - Installation et détection de PHP5

Bonsoir à toutes et à tous,

Je me présente comme un énième illuminé qui tente d'installer Piwigo sur un espace free (pour l'instant, je n'ai que ça sous la main) à des fins de tests.

Je me heurte au message d'erreur classique

PHP 5 est requis

Apparemment, la version PHP de votre hébergeur est PHP 5.1.3RC4-dev.

J'ai essayé plusieurs fois de modifier le .htaccess, de forcer l'envoi des fichiers en binaire via mon FTP et d'essayer la dernière possibilité, activer PHP 5.6.8, ce qui semble correspondre avec le phpinfo accessible à cet emplacement :

http://photos.astro.free.fr/phpinfo.php

Mon htaccess contient uniquement ça :

<IfDefine Free>
    php56 1
</IfDefine>

J'ai déjà déployé sur cet hébergeur du dotclear et du wordpress et pour le moment je me heurte à un mur.

La seule chose que je vois, c'est ça (quand je transfère mon .htaccess) :

Statut :    Le serveur ne supporte pas les caractères non-ASCII.

Je suis preneur de pistes que je n'aurais pas encore exploré :)
Merci d'avance

Edit 30 secondes après avoir réfléchi :

Ok, en fait, je modifiais mon .htaccess à la racine du serveur, comme je supposais que ce soit le cas.

Mon piwigo est hébergé à la racine (/piwigo/) et je viens de découvrir qu'il avait son propre .htaccess à l'intérieur de ce dossier avec le contenu suivant :

php 1
php 1
php 1
php 1
php 1

Correspondant au nombre de fois où j'ai cliqué sur le bouton pour éditer le fichier .htaccess par l'installeur.

Je viens de coller la valeur pour le passer en php 5.6 et c'est bon !

Dernière modification par Aimede (2015-08-27 22:04:03)

Hors ligne

#2 2015-10-21 16:57:28

weblord
Membre
2009-05-12
37

Re: [Résolu] [[2.7.4][Free][AUTORESOLU] - Installation et détection de PHP5

Hello,

Moi je ne comprends pas, j'ai fait comme toi, j'ai modifier mon .htaccess pour passer sur le nouveau php et j'ai une belle erreur 500 maintenant, j'ai plus accès à rien. Comprends po. Ma galerie par contre est pas migrée en 2.7 c'est quand même pas ça ?

Merci.

Hors ligne

#3 2015-10-21 17:31:28

k5
Membre
lieu
2014-01-26
237

Re: [Résolu] [[2.7.4][Free][AUTORESOLU] - Installation et détection de PHP5

bonjour à tous,
Aimede est passé en piwigo 2.7 avec 5.6 donc .htaccess php56 1 donc c'est bon.
weblord est avec piwigo <2.7 avec php 5.6, marche pas, normal

@Aimede, @weblord un peu de lecture :
http://fr.piwigo.org/doc/doku.php?id=ut … fai_freefr

Cordialement
k5


Utilisateur de Piwigo - Beta testeur disponible - développeur - hébergement multiple... (free, webhost,hosting,ex2,ovh,hostinger,kalanda,local,serveur,githubfree,BSD,cloud...)
Ayez comme premier réflexe de faire les mises à jours piwigo et extensions. merci

Hors ligne

#4 2015-10-21 17:33:06

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] [[2.7.4][Free][AUTORESOLU] - Installation et détection de PHP5

Soit vous avez une erreur de syntaxe dans votre fichier .htaccess (espace avant et/ou après la dernière ligne), soit vous l'avez édité avec un editeur de texte inadapté type Notepad. Il est recommandé d'utiliser un éditeur de scripts type Notepad++.

Hors ligne

#5 2015-10-21 17:36:31

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] [[2.7.4][Free][AUTORESOLU] - Installation et détection de PHP5

k5 a écrit:

weblord est avec piwigo <2.7 avec php 5.6, marche pas, normal

Non. Les versions Piwigo <2.7 n'imposent pas de versions "plafond" de php. Seulement un plancher qui est 5.2, si mes souvenirs sont correctes.

weblord a une erreur 500 après modification de son htaccess. Donc c'est une erreur de config serveur et pas de Piwigo.

Hors ligne

#6 2015-10-21 17:52:52

k5
Membre
lieu
2014-01-26
237

Re: [Résolu] [[2.7.4][Free][AUTORESOLU] - Installation et détection de PHP5

il faudrait que weblord nous dise quelle version php installée ? et s'il y a d'autre cms ou autre ?


Utilisateur de Piwigo - Beta testeur disponible - développeur - hébergement multiple... (free, webhost,hosting,ex2,ovh,hostinger,kalanda,local,serveur,githubfree,BSD,cloud...)
Ayez comme premier réflexe de faire les mises à jours piwigo et extensions. merci

Hors ligne

#7 2015-10-21 17:54:04

k5
Membre
lieu
2014-01-26
237

Re: [Résolu] [[2.7.4][Free][AUTORESOLU] - Installation et détection de PHP5

quel piwigo installé ... ?


Utilisateur de Piwigo - Beta testeur disponible - développeur - hébergement multiple... (free, webhost,hosting,ex2,ovh,hostinger,kalanda,local,serveur,githubfree,BSD,cloud...)
Ayez comme premier réflexe de faire les mises à jours piwigo et extensions. merci

Hors ligne

#8 2015-10-22 10:27:58

weblord
Membre
2009-05-12
37

Re: [Résolu] [[2.7.4][Free][AUTORESOLU] - Installation et détection de PHP5

Bonjour,

Et bien j'ai la 2.5.4 de piwigo.
Quant à ma version de php c'est 5.1.3RC4-dev.
J'ai essayer d'éditer le .htaccess avec notepad++ en mettant ce qu'il faut, et ben pas mieux. et je n'ai rien d'autres d'installé que piwigo.

Merci.

Dernière modification par weblord (2015-10-22 10:39:20)

Hors ligne

#9 2015-10-22 12:46:59

k5
Membre
lieu
2014-01-26
237

Re: [Résolu] [[2.7.4][Free][AUTORESOLU] - Installation et détection de PHP5

bonjour,
l'explication de l'erreur 500 est : la concordance entre le fichier 135.database.php... et le serveur de base de donnée
la solution est de mettre toute la base de donnée manuellement de la 2.5.4 à la 2.7.4
ou refaire une nouvelle installation.
Et la vous pourrez activer le php 5.6.x de free.

Cordialement
k5

Dernière modification par k5 (2015-10-22 18:49:19)


Utilisateur de Piwigo - Beta testeur disponible - développeur - hébergement multiple... (free, webhost,hosting,ex2,ovh,hostinger,kalanda,local,serveur,githubfree,BSD,cloud...)
Ayez comme premier réflexe de faire les mises à jours piwigo et extensions. merci

Hors ligne

#10 2015-10-22 13:00:07

k5
Membre
lieu
2014-01-26
237

Re: [Résolu] [[2.7.4][Free][AUTORESOLU] - Installation et détection de PHP5

Si vous voulez, on le fait ensemble ?


Utilisateur de Piwigo - Beta testeur disponible - développeur - hébergement multiple... (free, webhost,hosting,ex2,ovh,hostinger,kalanda,local,serveur,githubfree,BSD,cloud...)
Ayez comme premier réflexe de faire les mises à jours piwigo et extensions. merci

Hors ligne

#11 2015-10-22 18:52:27

weblord
Membre
2009-05-12
37

Re: [Résolu] [[2.7.4][Free][AUTORESOLU] - Installation et détection de PHP5

Merci k5 pour la proposition c'est hyper sympa, mais ça y est j'ai trouvé d'où venait le souci !! Mon .htaccess était corrompu je l'ai entièrement refait comme Eric le suggérait avec notepad++ et ça marche le passage au php 5.6.8 est fait et ma galerie refonctionne !
Du coup je me demandais, avec ce qu'autorise de nouveau free sur ses serveurs, le plugin mail supervisor est toujours nécessaire pour piwigo 2.7.4 pour l'envoi des mails via la galerie ? Non parce que s'il est nécessaire j'ai vu que le plugin était pas encore compatible, alors j’hésite...

Hors ligne

#12 2015-10-23 13:59:22

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] [[2.7.4][Free][AUTORESOLU] - Installation et détection de PHP5

weblord a écrit:

Du coup je me demandais, avec ce qu'autorise de nouveau free sur ses serveurs, le plugin mail supervisor est toujours nécessaire pour piwigo 2.7.4 pour l'envoi des mails via la galerie ?

Alors...
Selon mes tests récents depuis une galerie 2.7.4, sans mail_supervisor, hébergée chez Free (php 5.6), l'envoi de mails depuis la galerie ne semble pas poser les mêmes problèmes que précédemment. Je n'ai pas eu de blocage de la fonction mail() mais il faut rester prudent et, surtout, "humble" lors de l'envoi de mails depuis sa galerie ;-)

Le truc c'est de ne pas abuser du système. Envoyer une rafale de 100 mails à 100 destinataires différents en une fois peut-être considéré comme une action de spam par Free. Faire la même chose en échelonnant les envois par paquets de 5 à 10 destinataires serait mieux accepté. Mais ceci n'est possible que pour la notification par mail de Piwigo. L'envoi d'une notification à 100 utilisateurs membres d'un groupe à partir d'un album, par exemple, risque de ne pas passer.

Evidemment, l'idéal serait de pouvoir s'appuyer sur le plugin mail_supervisor. Essayez de contacter le développeur. Peut-être pourra-t-il le rendre compatible avec la dernière version de Piwigo.

Hors ligne

#13 2015-10-23 16:57:07

weblord
Membre
2009-05-12
37

Re: [Résolu] [[2.7.4][Free][AUTORESOLU] - Installation et détection de PHP5

Ok Eric merci de ces précisions. Du coup j'ai migré vers la version 2.7.4, ça a l'air de bien marcher tout ça:-)
Par contre j'avais trouvé dans la doc comment regénérer des miniatures, ça tombait bien j'ais 2/3 albums qui déconnent, mais je trouves plus l'action dans le traitement par lot ? Cette fonctionnalité a disparu ou a changé d'endroit dans la version 2.7.4 ?
http://fr.piwigo.org/doc/doku.php?id=pw … miniatures

Merci !

Hors ligne

#14 2015-10-23 18:56:39

BrandonCougar
Membre
Lille
2013-05-04
162

Re: [Résolu] [[2.7.4][Free][AUTORESOLU] - Installation et détection de PHP5

oui en 2.7.4 tu l'as toujours via la gestion par lot (enfin si c'est bien ça que tu cherches)



http://fr.piwigo.org/forum/showimage.php?pid=216313&amp;filename=GenererTaillesMultiples.jpg


Images attachées

Dernière modification par BrandonCougar (2015-10-23 19:02:49)

Hors ligne

#15 2015-10-28 10:05:30

weblord
Membre
2009-05-12
37

Re: [Résolu] [[2.7.4][Free][AUTORESOLU] - Installation et détection de PHP5

Merci BrandonCougar ça a bien l'air d'être ça. Je l'avais vu mais j'avias comme ainsi dire pas percuté.
Bon mon souci c'est qu'y veut pas me les régénérer :-(
Il me dit 51 photos ne peuvent pas être régénérées, sans plus d'explications...
Faut que j'en choisisse moins ?

Merci.

Hors ligne

  •  » Installation
  •  » [Résolu] [[2.7.4][Free][AUTORESOLU] - Installation et détection de PHP5

Pied de page des forums

Propulsé par FluxBB