#16 2014-11-23 21:48:32

thomorph
Membre
Mulhouse
2010-01-02
318

Re: [Résolu] Erreur MAJ en 2.5.5 Free

ça permet de faire les maj notamment sont qui chez free peuvent plus faire de l'automatique sans renvoyer le tout.

OK j'envoi le package 2.5.5 avec tout

Hors ligne

#17 2014-11-23 23:07:53

thomorph
Membre
Mulhouse
2010-01-02
318

Re: [Résolu] Erreur MAJ en 2.5.5 Free

Après l'upload du package complet, toujours des warning mais on avance:

Code:

Warning: Template::include() [function.Template-include]: open_basedir restriction in effect. File(/themeconf.inc.php) is not within the allowed path(s): (/mnt/113/sdb/a/4/achr68) in /mnt/113/sdb/a/4/achr68/piwigo/include/template.class.php on line 871

Warning: Template::include(/themeconf.inc.php) [function.Template-include]: failed to open stream: Operation not permitted in /mnt/113/sdb/a/4/achr68/piwigo/include/template.class.php on line 871

Warning: Template::include() [function.include]: Failed opening '/themeconf.inc.php' for inclusion (include_path='/mnt/113/sdb/a/4/achr68/include:.:/usr/php5/lib/php') in /mnt/113/sdb/a/4/achr68/piwigo/include/template.class.php on line 871

Warning: Cannot modify header information - headers already sent by (output started at /mnt/113/sdb/a/4/achr68/piwigo/include/template.class.php:871) in /mnt/113/sdb/a/4/achr68/piwigo/include/page_header.php on line 101

Warning: Smarty error: unable to read resource: "header.tpl" in /mnt/113/sdb/a/4/achr68/piwigo/include/smarty/libs/Smarty.class.php on line 1093

Warning: Smarty error: unable to read resource: "index.tpl" in /mnt/113/sdb/a/4/achr68/piwigo/include/smarty/libs/Smarty.class.php on line 1093

Warning: Smarty error: unable to read resource: "footer.tpl" in /mnt/113/sdb/a/4/achr68/piwigo/include/smarty/libs/Smarty.class.php on line 1093

Hors ligne

#18 2014-11-23 23:20:24

flop25
Équipe Piwigo
2006-07-06
6382

Re: [Résolu] Erreur MAJ en 2.5.5 Free

thomorph a écrit:

Après l'upload du package complet, toujours des warning mais on avance:

Code:

Warning: Template::include() [function.Template-include]: open_basedir restriction in effect. File(/themeconf.inc.php) is not within the allowed path(s):

Free >_<*
(╯°□°)╯︵ ┻━┻

Hors ligne

#19 2014-11-23 23:40:53

thomorph
Membre
Mulhouse
2010-01-02
318

Re: [Résolu] Erreur MAJ en 2.5.5 Free

y a moyen d'améliorer ça?

Hors ligne

#20 2014-11-24 07:50:11

flop25
Équipe Piwigo
2006-07-06
6382

Re: [Résolu] Erreur MAJ en 2.5.5 Free

À ma connaissance aucune si tu n'es pas le sysadmin
et ce qui est complètement foireux c'est qu'il n'y a aucune raison que cela fasse ça maintenant ! Entre 2.5.4 et .5 il n'y a que une ligne de code qui change
Donc c'est le fait de re-upload les fichiers qui engendré ça... C'est à s'en taper la tête sur les murs ! A part gueuler dans le newsgroup Free je ne vois pas

Hors ligne

#21 2014-11-24 10:12:48

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12255

Re: [Résolu] Erreur MAJ en 2.5.5 Free

Je viens de regarder et tout me semble "normal" dans 2.5.x_to_2.5.5.zip : s'il n'y a pas un fichier comme include/functions_plugins.inc.php c'est tout simplement parce que ce fichier n'a pas changé entre la 2.5.0 et la 2.5.5.

En uploadant simplement cette liste de fichiers, normalement aucun fichier ne disparaît côté serveur ! Comment le fichier include/functions_plugins.inc.php peut-il alors avoir disparu ?

Attention flop25, il y a un tas de fichiers dans 2.5.x_to_2.5.5.zip, c'est dans 2.5.4_to_2.5.5.zip qu'il n'y a que très peu de fichiers (2 pour être précis).


Dernier billet du blog Piwigo.com (3 mai 2018) Nouveau formulaire d'abonnement

Hors ligne

#22 2014-11-24 10:27:33

thomorph
Membre
Mulhouse
2010-01-02
318

Re: [Résolu] Erreur MAJ en 2.5.5 Free

Donc on part du principe que ma galerie FRee est morte?
Ceci peut-il être corrigé en transférant la galerie sur un autre hébergeur?

PS: je sais pas si j'ai bien compris la question de Plg mais normalement pour faire la maj sur le ftp en manuel il faut supprimer le dossier include d'après la procédure.

Dernière modification par thomorph (2014-11-24 10:29:50)

Hors ligne

#23 2014-11-24 10:36:44

flop25
Équipe Piwigo
2006-07-06
6382

Re: [Résolu] Erreur MAJ en 2.5.5 Free

ha oui mais la procédure ne dit pas de prendre les zip partiaux mais de "•Téléchargez la dernière version de l'archive Piwigo"

Hors ligne

#24 2014-11-24 10:38:12

flop25
Équipe Piwigo
2006-07-06
6382

Re: [Résolu] Erreur MAJ en 2.5.5 Free

et concernant la migration, oui c'est très facile de changer d'hébergeur : export/import base de donnée, dowload/upload fichiers

Hors ligne

#25 2014-11-24 10:40:35

thomorph
Membre
Mulhouse
2010-01-02
318

Re: [Résolu] Erreur MAJ en 2.5.5 Free

flop25 a écrit:

ha oui mais la procédure ne dit pas de prendre les zip partiaux mais de "•Téléchargez la dernière version de l'archive Piwigo"

... Bon bin j'ai vu ou était mon problème je devais pas avoir les yeux à la bonne place hier soir et hop j'ai enlevé les dossiesr mais envoyé que le pack de maj la 1ère fois.

Mais ça ne devrait pas impacter la galerie si ensuite j'envoi de nouveau le pack original en écrasant les fichiers non?

Hors ligne

#26 2014-11-24 11:05:44

flop25
Équipe Piwigo
2006-07-06
6382

Re: [Résolu] Erreur MAJ en 2.5.5 Free

non

Hors ligne

#27 2014-11-24 11:41:17

thomorph
Membre
Mulhouse
2010-01-02
318

Re: [Résolu] Erreur MAJ en 2.5.5 Free

J'ai corrigé le problème en retrouvant un de mes anciens post avec la même erreur, c'était le theme stripped qui était manquant donc il semble que j'ai de nouveau une galerie fonctionnelle.
Merci a vous.

Je pense que je vais transferer ou dupliquer (en gardant l'ancienne en réserve) ma galerie vers hostinger.
Y a t-il des difficultés à prévoir avec Free ou en passant d'une 2.5.5 actuelle à la 2.7.X qui est chez le nouvel hébergeur?

Hors ligne

#28 2014-11-24 11:42:45

flop25
Équipe Piwigo
2006-07-06
6382

Re: [Résolu] Erreur MAJ en 2.5.5 Free

surtout une impossibilité du à la version de php

Hors ligne

#29 2014-11-24 11:44:44

thomorph
Membre
Mulhouse
2010-01-02
318

Re: [Résolu] Erreur MAJ en 2.5.5 Free

Y a moyens d'avoir plus de détails?
Justement je veux migrer a cause de Free bloqué en php 5.1RC...

Hors ligne

#30 2014-11-24 11:48:57

flop25
Équipe Piwigo
2006-07-06
6382

Re: [Résolu] Erreur MAJ en 2.5.5 Free

pardon Décidemment pas réveillé ce matin ;
alors pour la migration, migrer les fichiers que vous avez sur votre Free, exporter/importer la base de donnée, puis faites la maj vers 2.7
les pré-requis, c'est  http://fr.piwigo.org/basics/requirements donc PHP 5.2 (qui est un pb chez free mais pas forcément ailleurs

Hors ligne

Pied de page des forums

Propulsé par FluxBB