#1 2014-11-22 20:54:58

thomorph
Membre
Mulhouse
2010-01-02
318

[Résolu] Erreur MAJ en 2.5.5 Free

Bonsoir,

Je voulais mettre a jour ma galerie en 2.5.4 vers la dernière suite à l'alerte de sécurité.
Cependant j'ai des warning après avoir fait la MAJ via FtP:

Code:

 Warning: include_once() [function.include-once]: Unable to access ./include/functions_plugins.inc.php in /mnt/113/sdb/a/4/achr68/piwigo/include/functions.inc.php on line 24

Warning: include_once(./include/functions_plugins.inc.php) [function.include-once]: failed to open stream: No such file or directory in /mnt/113/sdb/a/4/achr68/piwigo/include/functions.inc.php on line 24

Warning: include_once() [function.include]: Failed opening './include/functions_plugins.inc.php' for inclusion (include_path='/mnt/113/sdb/a/4/achr68/include:.:/usr/php5/lib/php') in /mnt/113/sdb/a/4/achr68/piwigo/include/functions.inc.php on line 24

Fatal error: Call to undefined function add_event_handler() in /mnt/113/sdb/a/4/achr68/piwigo/include/functions_user.inc.php on line 1225

Auriez vous une idée pour corriger cela?

Merci

Version de Piwigo: 2.5.4-->2.5.5
Version de PHP: 5.1

Dernière modification par thomorph (2014-11-23 18:21:26)

Hors ligne

#2 2014-11-22 21:34:46

flop25
Équipe Piwigo
2006-07-06
6408

Re: [Résolu] Erreur MAJ en 2.5.5 Free

Bonjour
lors de l'upload Ftp les droits sur les fichiers écrasé  ont changé je pense. Vérifiez chmod et owner,  même si on est sous Free ici, des fichiers mentionnés si ils eexistent

Hors ligne

#3 2014-11-22 22:17:22

thomorph
Membre
Mulhouse
2010-01-02
318

Re: [Résolu] Erreur MAJ en 2.5.5 Free

le fonctions_plugins je l'ai pas sur le serveur.
Le fonction.inc et user sont en 644

Dernière modification par thomorph (2014-11-22 22:17:34)

Hors ligne

#4 2014-11-22 23:34:42

flop25
Équipe Piwigo
2006-07-06
6408

Re: [Résolu] Erreur MAJ en 2.5.5 Free

Réuploadez en écrasant les fichiers existant

Hors ligne

#5 2014-11-23 00:00:25

thomorph
Membre
Mulhouse
2010-01-02
318

Re: [Résolu] Erreur MAJ en 2.5.5 Free

pas de changement en ayant retéléchargé et réuploadé (avec fireftp)
Je devrais essayer avec filezilla?

Hors ligne

#6 2014-11-23 19:04:17

thomorph
Membre
Mulhouse
2010-01-02
318

Re: [Résolu] Erreur MAJ en 2.5.5 Free

Nouveau PC, nouveau téléchargement, nouvel upload avec filezilla cette fois ci. En ayant pris soins de laisser seulement les dossiers décrits dans la MAJ manuelle de piwigo.
Mais toujours les mêmes erreurs....

Hors ligne

#7 2014-11-23 19:16:32

flop25
Équipe Piwigo
2006-07-06
6408

Re: [Résolu] Erreur MAJ en 2.5.5 Free

/include/functions_plugins.inc.php existe bel et bien dans la 2.5.5 !
et réécraser sans suivre la maj manuelle

Hors ligne

#8 2014-11-23 19:31:15

thomorph
Membre
Mulhouse
2010-01-02
318

Re: [Résolu] Erreur MAJ en 2.5.5 Free

as tu téléchargé le package de MAJ pour voir car dans le miens il y est pas

Hors ligne

#9 2014-11-23 19:35:27

flop25
Équipe Piwigo
2006-07-06
6408

Re: [Résolu] Erreur MAJ en 2.5.5 Free

oui je l'ai fait justement http://fr.piwigo.org/releases/2.5.5

Hors ligne

#10 2014-11-23 19:42:54

thomorph
Membre
Mulhouse
2010-01-02
318

Re: [Résolu] Erreur MAJ en 2.5.5 Free

Ok la on est d'accord, il est absent de la MAJ mais pas du package original.
J'ai donc pris le dossier include du package 2.5.5 et envoyé en mettant bien écraser.

Maintenant j'ai d'autres warning:

Code:

 Warning: include() [function.include]: Unable to access ./admin/include/functions_metadata.php in /mnt/113/sdb/a/4/achr68/piwigo/admin/include/functions.php on line 24

Warning: include(./admin/include/functions_metadata.php) [function.include]: failed to open stream: No such file or directory in /mnt/113/sdb/a/4/achr68/piwigo/admin/include/functions.php on line 24

Warning: include() [function.include]: Failed opening './admin/include/functions_metadata.php' for inclusion (include_path='/mnt/113/sdb/a/4/achr68/include:.:/usr/php5/lib/php') in /mnt/113/sdb/a/4/achr68/piwigo/admin/include/functions.php on line 24

Warning: include() [function.include]: Unable to access ./admin/include/languages.class.php in /mnt/113/sdb/a/4/achr68/piwigo/upgrade.php on line 139

Warning: include(./admin/include/languages.class.php) [function.include]: failed to open stream: No such file or directory in /mnt/113/sdb/a/4/achr68/piwigo/upgrade.php on line 139

Warning: include() [function.include]: Failed opening './admin/include/languages.class.php' for inclusion (include_path='/mnt/113/sdb/a/4/achr68/include:.:/usr/php5/lib/php') in /mnt/113/sdb/a/4/achr68/piwigo/upgrade.php on line 139

Fatal error: Class 'languages' not found in /mnt/113/sdb/a/4/achr68/piwigo/upgrade.php on line 140

Hors ligne

#11 2014-11-23 19:49:20

flop25
Équipe Piwigo
2006-07-06
6408

Re: [Résolu] Erreur MAJ en 2.5.5 Free

vous aviez fait une maj auto sous Free? ha oui faut y croire! ^^

éccoutez, même réponse qu'avant

Hors ligne

#12 2014-11-23 21:03:04

thomorph
Membre
Mulhouse
2010-01-02
318

Re: [Résolu] Erreur MAJ en 2.5.5 Free

Euh les MAJ auto ne marchent plus depuis des plobes sous free non?!
Donc je prend le package d'install 2.5.5 (non la maj) et j'envoi tout sur le ftp c'est ça?

Hors ligne

#13 2014-11-23 21:35:06

flop25
Équipe Piwigo
2006-07-06
6408

Re: [Résolu] Erreur MAJ en 2.5.5 Free

c'est quoi "la maj" pour vous? vous envoyiez quoi par ftp?

Hors ligne

#14 2014-11-23 21:45:31

thomorph
Membre
Mulhouse
2010-01-02
318

Re: [Résolu] Erreur MAJ en 2.5.5 Free

ce que j'appel la MAJ c'est le dossier 2.5.x vers 2.5.5 dispo sur le site piwigo. J'extrait les dossiers et j'envoi le tout par ftp.
Le package de base pour moi c'est le package 2.5.5 qui permet de faire une nouvelle installation

Hors ligne

#15 2014-11-23 21:47:12

flop25
Équipe Piwigo
2006-07-06
6408

Re: [Résolu] Erreur MAJ en 2.5.5 Free

jamais vu que ça existait ^^
elle doit être foireuse alors ; je notifie plg et écraser depuis la version complète

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2018 · Contact