Annonce

#1 2014-11-18 17:12:08

Ducale
Membre
2014-09-24
34

Menu personnalisé ???

Bonsoir,

J'ai crée un menu personnalisé que j'ai intitulé "Allers vers ...", il comprend deux liens vers des pages web.
Mon souci est qu'il n'apparaît pas quand je ne suis pas connecté, il n'est donc pas visible par tout le monde.
J'ai bien vérifié que l'accessibilité était possible pour tout le monde
J'ai dû oublié de cocher quelque chose.
Merci de votre aide.

Version de Piwigo: 2.7.1
Système d'exploitation: Linux
PHP: 5.3.29 (Montrer les informations) [2014-11-18 17:10:11]
MySQL: 5.5.40-36.1 [2014-11-18 17:10:11]
Bibliothèque graphique: ImageMagick 6.8.8-7
URL Piwigo:La Galerie


Le Non Dupe Erre

Hors ligne

#2 2014-11-22 00:04:07

oliverfr
Membre
2013-04-27
158

Re: Menu personnalisé ???

Serait-ce via Advanced Menu Manager ? Bon sang, je n'ai pas de piwigo en VF sous la main (sale habitude, tout prendre en anglais, tout installer en anglais), j'ai un doute.

Si c'est le cas (sinon... désolé, hein), dans admin.php?page=plugin-AMenuManager il faut bien vérifier que les menus de ton choix ont "guest" de coché.
Tu cliques sur les petites flèches bleues pointant vers le bas, et ça te montre la liste des profils d'usagers pouvant les voir ou ne pas les voir.

Hors ligne

#3 2014-11-22 10:13:49

Ducale
Membre
2014-09-24
34

Re: Menu personnalisé ???

Bonjour oliverfr

Merci pour cette réponse mais je sui passé par le menu "lien".
Bonne journée


Le Non Dupe Erre

Hors ligne

#4 2014-11-22 11:21:58

oliverfr
Membre
2013-04-27
158

Re: Menu personnalisé ???

Ah, désolé alors, je ne connais aucune autre façon de créer des menus personnalisés, j'ai trop hâtivement cru que tu avais dû employer la même méthode, au temps pour moi :)

(simple suggestion, que tu mentionnes plus précisément par quel moyen dans piwigo tu as procédé, alors, par exemple avec ce qu'il y a dans ta barre d'adresse web au moment où tu crées ces menus personnalisés)

Hors ligne

#5 2014-11-22 11:39:00

Ducale
Membre
2014-09-24
34

Re: Menu personnalisé ???

oliverfr a écrit:

(simple suggestion, que tu mentionnes plus précisément par quel moyen dans piwigo tu as procédé, alors, par exemple avec ce qu'il y a dans ta barre d'adresse web au moment où tu crées ces menus personnalisés)

Bonjour
En fait une fois sur le plugin Advanced Menu Manager (http://..../admin.php?page=plugin-AMenuManager) tu cliques sur l'onglet lien (http://..../admin.php?page=plugin-AMenuManager-links) et tu ajoutes les liens que tu souhaites puis dans l'onglet "Configuration des liens" (http://...../admin.php?page=plugin-AMenuManager-links/config), tu mets le titre que tu souhaites et coches ou non pour avoir l'icône.

J'espère avoir répondu à ta question.
Ceci dit si tu sais comment rendre visible le menu personnalisé par tout le monde, je suis preneur.


Le Non Dupe Erre

Hors ligne

#6 2014-11-22 15:24:20

oliverfr
Membre
2013-04-27
158

Re: Menu personnalisé ???

Ah, donc c'est bien ce plugin :D

J'ai testé sur mon piwigo de test, et de mon côté je n'ai pas ce bug.

Pas Link Settings, just Links, puis Add A Link :

http://i.imgur.com/RNVZjrW.jpg

Avec toutes les autorisations (guest, generic, surtout) un menu est visible par tout le monde.

En revanche, sur la même page, je me suis dit que j'allais éditer ce nouvellement créé menu, et j'ai cliqué, sur sa ligne, sur la petite icône à gauche de la corbeille, celle nommée g_002edit quand on laisse sa souris au-dessus, et là j'ai eu un écran grisé avec chargement sans fin, avec au milieu l'espèce de petit dessin tournant pour dire "loading...".

Peut-être en supprimant ton menu et en en crééant un nouveau ?

Hors ligne

#7 2014-11-22 15:42:23

Ducale
Membre
2014-09-24
34

Re: Menu personnalisé ???

oliverfr a écrit:

Avec toutes les autorisations (guest, generic, surtout) un menu est visible par tout le monde.

Idem quand je fais un menu lien avec cette page, pas de souci il apparaît pour tout le monde. mais c'est en créant un menu personnalisé
http://www.lenondupe-erre.fr/images/Externes/menuforum.jpg
qu'il n'apparaît pas pour tout le monde. Le menu personnalisé est "Galerie"
http://www.lenondupe-erre.fr/images/Externes/connectmenu.jpghttp://www.lenondupe-erre.fr/images/Externes/deconnectmenu.jpg

oliverfr a écrit:

En revanche, sur la même page, je me suis dit que j'allais éditer ce nouvellement créé menu, et j'ai cliqué, sur sa ligne, sur la petite icône à gauche de la corbeille, celle nommée g_002edit quand on laisse sa souris au-dessus, et là j'ai eu un écran grisé avec chargement sans fin, avec au milieu l'espèce de petit dessin tournant pour dire "loading...".

Cela me le fait aussi, je l'ai signalé dans le forum mais paseu de réponses et la nouvelle mise à jour n'a pas résolu ce bug.

oliverfr a écrit:

Peut-être en supprimant ton menu et en en crééant un nouveau ?.

C'est ce que je fais quand je veux en modifier un.
Bonne soirée


Le Non Dupe Erre

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact