•  » Utilisation
  •  » 2.7 - Pb d'affichage des photos dans la NBM

#1 2014-10-05 12:29:21

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

2.7 - Pb d'affichage des photos dans la NBM

Bonjour à tous,

J'ai dû prendre un peu de champ par rapport à Piwigo des derniers mois mais pas trop pour suivre les nouveautés de la version 2.7 qui me semble superbe !

Mais avant de migrer mes galeries 2.6 vers 2.7 (des plugins compatibles sont manquants), je suis confronté à un problème avec la notification par mail. J'explique :

* D'abord, le contexte :
Soit un nouvel album créé dans la galerie, cet album est privé et des photos y sont ajoutées avec la permission "tout le monde peut les voir". Cet album privé n'est autorisé que pour un groupe d'utilisateurs spécifique. Ceux parmi ces utilisateurs qui sont abonnés à la NBM se retrouvent donc dans la liste des "notifiables" après la création de l'album et les réglages décrits précédemment.

* Le problème :
A la réception des notifications par mail, les preview des photos ne sont pas visibles dans le mail (voir capture). J'ai fait le test avec différents clients de messagerie (webmail et client lourd) avec le même résultat.

Il semblerait que le problème vienne du fait que les photos concernées soient dans un album privé. L'utilisateur recevant le mail étant un guest par défaut -> Pas d'affichage des photos.

De ce que j'ai vu de la 2.7, il se pourrait bien que le problème y soit identique... Une solution est-elle envisageable ?

Version de Piwigo: 2.7.1
Version de PHP: 5.4.24
Version de MySQL: 5.5.37


Images attachées

Dernière modification par Eric (2014-11-07 21:43:02)

Hors ligne

#2 2014-11-07 21:51:08

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: 2.7 - Pb d'affichage des photos dans la NBM

Bonsoir,

Petit relance sur ce sujet et correction de mes propos précédents :

1/ J'ai migré mes galeries en 2.7 et le problème d'affichage est toujours présent sur une seule des 2 galeries !

1.1/ La première galerie est entièrement privée. Il faut donc s'identifier pour consulter quoi que ce soit. Pourtant, à la réception de la NBM, les miniatures s'affichent correctement. Si je clique sur les liens de ces miniatures, le navigateur affiche la page "vous n'êtes pas autorisé...".

1.2/ La seconde galerie est semi-publique. Si j'envoie une notification depuis un album public, les miniatures ne s'affichent pas dans le mail reçu. Mais si je clique sur le lien, le navigateur affiche bien la page picture.php de la photo !


C'est pas un truc de dingue çà ?...

Hors ligne

  •  » Utilisation
  •  » 2.7 - Pb d'affichage des photos dans la NBM

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact