•  » Outils
  •  » IO Error & transfert partiel

#1 2014-02-22 20:25:17

laurentb
Membre
2014-02-22
10

IO Error & transfert partiel

Bonjour,

Depuis la version 2.5.3, j'ai des problèmes lors de l'upload des photos avec le formulaire Flash: il y a systèmatiquement ~10% des photos avec «IO ERror» ou  «Le fichier n'a été que partiellement transféré»
En 2.5.2, tout allait bien, même su des transferts durant plusieurs heures.

Il n'y a pas de problème particulier de connectivité, le client et le serveur sont tous les deux chez Free, et d'autres connexions restent bien ouvertes. Le débit est constant. La configuration du serveur web n'a pas changé entre les versions.

Je n'ai pas trouvé de message dans les logs du système. Une idée?

Merci d'avance,

Laurent

Version de Piwigo: 2.6.1
Version de PHP: 5.4.19
Version de MySQL: 5.5.36

Hors ligne

#2 2014-02-22 20:32:59

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14235

Re: IO Error & transfert partiel

Bonjour,

Quel est la Taille des photos que tu essais d'envoyer ?
Quels sont des réglage dans le php.ini ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2014-02-22 21:44:04

k5
Membre
lieu
2014-01-26
277

Re: IO Error & transfert partiel

bonjour,
io error, erreur 2038 ?

Cordialement
k5


Ayez comme premier réflexe de faire les mises à jours piwigo et extensions. merci

Hors ligne

#4 2014-02-22 21:46:31

laurentb
Membre
2014-02-22
10

Re: IO Error & transfert partiel

Les photos font entre 5 et 10 MO en général. Je n'ai pas l'impression que ce soit lié à la taille, j'ai quelques panoramas à 20-30, qui n'ont pas fait plus de difficulté.

Le php.ini:

Code:

memory_limit        = 512M
log_errors          = on
error_log           = syslog
expose_php          = Off
display_errors      = Off

date.timezone       = "Europe/Paris"

iconv.output_encoding   = "UTF-8"
iconv.internal_encoding = "UTF-8"
iconv.input_encoding    = "UTF-8"

Et également dans la config Apache:

Code:

    php_admin_value post_max_size       500M
    php_admin_value upload_max_filesize 90M

Laurent

Hors ligne

#5 2014-02-22 21:48:19

laurentb
Membre
2014-02-22
10

Re: IO Error & transfert partiel

k5 a écrit:

bonjour,
io error, erreur 2038 ?

Où est-ce que je peux le vérifier? Il y avait juste «IO Error» affiché lors du dernier échec.

Laurent

Hors ligne

#6 2014-02-22 21:55:34

k5
Membre
lieu
2014-01-26
277

Re: IO Error & transfert partiel

bonjour,
piwigo est installé sur quel support ? local ? hebergement ? serveur ? nas ? box ? ... svp merci
l'erreur 2038 c'est une erreur sur le ssl
Cordialement
k5


Ayez comme premier réflexe de faire les mises à jours piwigo et extensions. merci

Hors ligne

#7 2014-02-22 22:19:30

laurentb
Membre
2014-02-22
10

Re: IO Error & transfert partiel

C'est un serveur personnel distant sous Solaris 10, sur de l'ADSL normal.
Est-ce qu'il y a des logs où voir les détails de ces erreurs? Je n'ai trouvé que le log des connexions.
Il n'y a rien dans les logs Apache ou PHP.

Cordialement,

Laurent

Hors ligne

#8 2014-02-23 07:28:58

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14235

Re: IO Error & transfert partiel

Bonjour,

Pour reformuler la question de k5 sur ton serveur perso est ce que tu as installer un Certificat SSL

j'ai ce même problème avec FF si je ne mets pas de certificat SSL
par contre IE est plus permissive et cela fonctionne


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#9 2014-02-23 15:32:28

laurentb
Membre
2014-02-22
10

Re: IO Error & transfert partiel

Bonjour,

Oui, il y a un certificat SSL valide, pas de problème de ce côté.

Cordialement,

Laurent

Hors ligne

#10 2014-02-23 16:07:26

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14235

Re: IO Error & transfert partiel

re,

Ton lien est en https ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#11 2014-02-23 17:01:00

laurentb
Membre
2014-02-22
10

Re: IO Error & transfert partiel

Tout à fait.

Laurent

Hors ligne

  •  » Outils
  •  » IO Error & transfert partiel

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2018 · Contact