•  » Utilisation
  •  » [Résolu] Accès aux album disparu- Erreur 404 page not found

#1 2014-02-21 08:23:35

jmezes
Membre
2014-02-21
5

[Résolu] Accès aux album disparu- Erreur 404 page not found

Bonjour,

Je viens de faire la mise à jour de Piwigo en 2.6.1 en espérant résoudre le problème apparu déjà avant la mise à jour, en vain.

Sans qu'il y ait (a priori) de modification de ma part sur mon site Piwigo, d'un coup l'accès aux différents albums du site est devenu impossible.
Les photos sont bien là. Je peux administrer le site et les albums, sous-albums, etc. mais lorsqu'on quite l'interface d'administration et que l'on passe en mode visualisation (visiteur ou membre du site) le résultat est le même : Page not found (erreur 404).
Par ailleurs, le site semble devenu particulièrement lent mais je ne peut dire si c'est du à l'hébergeur ou à un défaut de Piwigo. J'aurais un petit faible pour la deuxième raison en liaison avec le problème qui m'occupe.


Version de Piwigo: 2.6.1
Version de PHP: PHP: 5.3.28
Version de MySQL: MySQL: 5.1.69 [2014-02-21 02:22:04]
URL Piwigo: http://jmezes.com ou http://www.jmezes.com

Dernière modification par jmezes (2014-02-21 08:24:03)

Hors ligne

#2 2014-02-21 09:22:15

oliverfr
Membre
2013-04-27
158

Re: [Résolu] Accès aux album disparu- Erreur 404 page not found

Simple remarque, si ça peut aider, ce ne sont pas que les albums/catégories. D'autres liens générés sont cassés.
http://jmezes.com/photos/index/search/1 : pareil, j'ai cherché "jpg", hop, 404.

Tu n'as pas accès aux error_log apache de ton hébergement ?

Dernière modification par oliverfr (2014-02-21 09:23:31)

Hors ligne

#3 2014-02-21 10:15:57

flop25
Équipe Piwigo
2006-07-06
6466

Re: [Résolu] Accès aux album disparu- Erreur 404 page not found

Bonjour

oliverfr a écrit:

Tu n'as pas accès aux error_log apache de ton hébergement ?

en effet. A savoir que des fichiers error_log peuvent être générés à coté des fichier sayant créé l'erreur, donc vérifiez aussi au sein du répertoire de votre piwigo

Hors ligne

#4 2014-02-21 12:16:38

rvelices
Équipe Piwigo
2005-12-29
1417

Re: [Résolu] Accès aux album disparu- Erreur 404 page not found

vous avez activé question_mark_in_urls = false et php_extension_in_url = false
mais il faut s'assurer que la config de votre serveur web l'accepte ...

Hors ligne

#5 2014-02-23 23:20:35

jmezes
Membre
2014-02-21
5

Re: [Résolu] Accès aux album disparu- Erreur 404 page not found

Bonjour
Merci pour vos réponses.
Je manque un peu de temps mais je vais contrôler ces points et je reviens vers vous.
Mon hébergement est pour l'instant un hébergement gratuit chez hostinger.

A bientot.

Hors ligne

#6 2014-02-23 23:32:55

jmezes
Membre
2014-02-21
5

Re: [Résolu] Accès aux album disparu- Erreur 404 page not found

@rvelice : je ne suis pas développeur et je n'ai pas bien compris la remarque.
Où vais je trouver ces infos ? est dans le code de Piwigo ? y a t il des cases a cocher qq part ?

Le problème est arrivé d'un coup sans que je touche à la config de mon coté

Hors ligne

#7 2014-02-24 06:32:13

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14550

Re: [Résolu] Accès aux album disparu- Erreur 404 page not found

Bonjour,

Tu vas dans administration -> Plugins -> LocalFile Editor -> onglet 'configuration locale'

et tu regarde ce que tu as mis ;-)


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#8 2014-02-24 06:36:01

jmezes
Membre
2014-02-21
5

Re: [Résolu] Accès aux album disparu- Erreur 404 page not found

Bonjour.
Effectivement les deux paramètres ont la valeur "false".
Je ne pense pas avoir configuré quoi que ce soit à cet endroit et le site a fonctionné correctement pendant des semaines.
Dois je passer ces valeurs à "true" ?

Merci pour votre aide.

Hors ligne

#9 2014-02-24 06:43:22

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14550

Re: [Résolu] Accès aux album disparu- Erreur 404 page not found

re Bonjour,

Je viens d'aller sur ton site et de visiter des photos et je n'ai aucun problème ?


Tu utilise IE pour visiter ton site ?
Tu as fait une mise à jour de IE


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#10 2014-02-24 06:43:46

jmezes
Membre
2014-02-21
5

Re: [Résolu] Accès aux album disparu- Erreur 404 page not found

Rebonjour,

Je ne vais pas maintenir le suspens. Je n'ai pas résisté et j'ai procédé à la modification.

Résultat : ça fonctionne !!!

Je ne comprends pas comment ces paramètres ont été changé. En lisant les commentaires du fichier de config au sujet des deux paramètres, je comprends mieux leur fonction.

Merci encore à tous pour votre aide. Vous avez été d'une aide précieuse. Vous êtes mes dieux du PHP.
:-)

Bonne continuation à tous. Reste à trouver comment marquer ce post comme résolu.

Jean-Michel

Hors ligne

#11 2014-02-25 13:01:28

Laurent M.
Invité

Re: [Résolu] Accès aux album disparu- Erreur 404 page not found

Merci pour se sujet qui résoud mon problème.

J'avais exactement le même.
Je suis également hébergé chez Hostinger et d'un coup, je n'avais plus d'accès aux dossiers et photos, sans pour autant avoir modifié quoi que ce soit.

#12 2014-02-25 13:19:19

flop25
Équipe Piwigo
2006-07-06
6466

Re: [Résolu] Accès aux album disparu- Erreur 404 page not found

ils ont très certainement modifiés leur config serveur

Hors ligne

#13 2014-02-25 14:35:37

k5
Équipe Piwigo
lieu
2014-01-26
416

Re: [Résolu] Accès aux album disparu- Erreur 404 page not found

bonjour,
l'hebergeur hostinger, fait en ce moment une refonte de leur serveur donc une tres grande maintenance.
Ils ont appartement bloqué l'acces ftp et apparement ils ont des problemes dans le jquery, d'autres personnes n'ont pas acces à phpmyadmin. Maintenance depuis le 15 fevrier :(

Cordialement
k5


Ayez comme premier réflexe de faire les mises à jours piwigo et extensions. merci

Hors ligne

  •  » Utilisation
  •  » [Résolu] Accès aux album disparu- Erreur 404 page not found

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact