•  » Styles
  •  » [Slide] menus ouvert par défaut ?

#1 2014-02-17 19:03:10

manu.p
Membre
Foie gras land
2014-01-28
17

[Slide] menus ouvert par défaut ?

Bonjour,

Deux questions à propos de Slide, au vu de mon site lepassepartout.fr :

1. Pourquoi "Contacter" n'est-il pas aligné à la même hauteur que les autres "menus" (ou l'inverse), et comment les aligner ?

2. Pourquoi les menus sont-ils ouverts lorsqu'on arrive sur la page ?

Merci, et désolé si ça a déjà été demandé auparavant, je n'ai pas trouvé...

Version de Piwigo: 2.6.1
Version de PHP: 5.3
Version de MySQL: 5.5
URL Piwigo: http://lepassepartout.fr


manu'

Hors ligne

#2 2014-02-17 19:14:38

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14380

Re: [Slide] menus ouvert par défaut ?

Bonjour,

Tu devrais préciser le thème que tu utilises et les changement que tu y as fait


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2014-02-17 19:22:38

manu.p
Membre
Foie gras land
2014-01-28
17

Re: [Slide] menus ouvert par défaut ?

Merci ddtddt pour la réponse rapide.

ddtddt a écrit:

Tu devrais préciser le thème que tu utilises et les changement que tu y as fait

Slide comment indiqué dans le titre et dans mon message. C'est la dernière version du thème, c'était pareil sur la précédente.

J'ai un template modifié comme mentionné ici pour réduire la largeur des thumbnails.

Les plugins installés :

    Add < head > element
    Additional Pages
    Advanced Menu Manager
    Contact Form
    Grum Plugin Classes
    LocalFiles Editor
    Perso About
    Perso Footer
    Sitemap
    Statistics


manu'

Hors ligne

#4 2014-02-17 19:57:53

Harry
Membre
2011-10-07
143

Re: [Slide] menus ouvert par défaut ?

Pour les menus ouverts, déconnecte Advanced Menu Manager et ça devrait aller mieux... Maintenant, je suis sûr que Miklfe va régler ça dans une prochaine version, mais en attendant, si tu veux garder AMM,  tu peux toujours mettre quelques {display : none} dans les CSS. C'est ce que j'ai fait sur mon site Itinéraires Bis ! ;-)

Dernière modification par Harry (2014-02-17 19:58:30)

Hors ligne

#5 2014-02-17 20:09:08

manu.p
Membre
Foie gras land
2014-01-28
17

Re: [Slide] menus ouvert par défaut ?

Harry a écrit:

Pour les menus ouverts, déconnecte Advanced Menu Manager et ça devrait aller mieux... Maintenant, je suis sûr que Miklfe va régler ça dans une prochaine version, mais en attendant, si tu veux garder AMM,  tu peux toujours mettre quelques {display : none} dans les CSS. C'est ce que j'ai fait sur mon site Itinéraires Bis ! ;-)

Merci Harry pour le coup de main !
Bon ben je crois que je vais devoir jouer du CSS parce qu'en désactivant AMM j'ai tous les menus déroulés...

Pour ma gouverne, il faut jouer sur la class liSub ?
Merci pour toute information qui me facilite le taf... ;)


manu'

Hors ligne

#6 2014-02-17 20:15:13

Harry
Membre
2011-10-07
143

Re: [Slide] menus ouvert par défaut ?

Chez moi, c'est du genre
#mbSpecials dd {display:none}
(pour cacher le sous-menu, mais garder l'entête)

Hors ligne

#7 2014-02-18 00:13:26

manu.p
Membre
Foie gras land
2014-01-28
17

Re: [Slide] menus ouvert par défaut ?

OK merci ! j'ai trouvé pour les dd, reste l'alignement et pour l'instant je suis sec...


manu'

Hors ligne

#8 2014-02-18 06:59:35

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14380

Re: [Slide] menus ouvert par défaut ?

manu.p a écrit:

OK merci ! j'ai trouvé pour les dd, reste l'alignement et pour l'instant je suis sec...

Bonjour,

La différence c'est que sur contacter tu as un liens et pas sur les autres
il te faut ajouter un règle CSS pour les liens du menu pour qu'il ai la même présentation que les 'non lien'

mais la je ne peux plus afficher ton site


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#9 2014-02-18 08:10:59

Miklfe
Membre
Sarthe
2010-11-13
364

Re: [Slide] menus ouvert par défaut ?

Salut
pour le menu contact c'est corrigé et tu peu mettre à jour
Pour les menu de Advanced Menu Manager je ne reproduis, pas il faut que tu remette ton site en ligne, mais normalement ils doivent se replier comme les autres(chez moi ça marche en tout cas).

Hors ligne

#10 2014-02-18 09:36:43

manu.p
Membre
Foie gras land
2014-01-28
17

Re: [Slide] menus ouvert par défaut ?

Merci Miklfe pour la prise en compte rapide de l'alignement des menus !

Tu devrais pouvoir récupérer l'arborescence du site ici.

J'ai rajouté dans la section "menu"

Code:

#mbAdditionalPages dd {
    display:      none ;
}
#mbAMM_links dd {
    display:      none ;
}

Dernière modification par manu.p (2014-02-18 10:01:50)


manu'

Hors ligne

#11 2014-02-18 10:44:04

patfrwar
Membre
Tours
2011-05-24
164

Re: [Slide] menus ouvert par défaut ?

Bonjour

j'ai juste une question à poser

au sujet de Advanced Menu Manager, pourquoi les templates de ces menus sontdans le dossier :
"piwigo/plugin/AMenuManager/menu_templates"
et ne sont pas dans le dossier propre aux template: "piwigo/template-extension"
qui faciliterai la customisation de ces menus grâce à "Local File Editor"

Cdlt
Patrick

Hors ligne

#12 2014-02-19 11:14:33

manu.p
Membre
Foie gras land
2014-01-28
17

Re: [Slide] menus ouvert par défaut ?

patfrwar a écrit:

au sujet de Advanced Menu Manager, pourquoi les templates de ces menus sontdans le dossier :

C'est une question qui aurait sans doute plus sa place dans ce sujet dédié à Advanced Menu Manager, qu'ici où on parle avant tout du thème Slide. Comme beaucoup, si je cherche à un moment des réponses concernant "truc", je ne vais pas les chercher dans des sujets parlant de "machin"...

Mais parlant de template et de Slide, je me posais justement des questions concernant local_head.tpl, la 1ère étant pourquoi n'est-il pas dans le sous-répertoire template du thème, mais surtout comment le surcharger sans intervenir directement dessus, car il sera (possiblement) écrasé à chaque mise à jour du thème. Or si on veut changer par exemple la police utilisée, comment s'y prend-t-on pour ne pas devoir y revenir à chaque màj ?


manu'

Hors ligne

#13 2014-02-19 12:15:57

Miklfe
Membre
Sarthe
2010-11-13
364

Re: [Slide] menus ouvert par défaut ?

Mais parlant de template et de Slide, je me posais justement des questions concernant local_head.tpl, la 1ère étant pourquoi n'est-il pas dans le sous-répertoire template du thème, mais surtout comment le surcharger sans intervenir directement dessus, car il sera (possiblement) écrasé à chaque mise à jour du thème. Or si on veut changer par exemple la police utilisée, comment s'y prend-t-on pour ne pas devoir y revenir à chaque màj ?

ce n'est pas spécifique à slide, tous les themes sont comme ça.
tu peux utiliser le plugin add < head > element pour ajouter ce que tu veux dans le head

Hors ligne

#14 2014-02-19 12:23:30

manu.p
Membre
Foie gras land
2014-01-28
17

Re: [Slide] menus ouvert par défaut ?

Ah ben oui... merci Miklfe :o)

As-tu trouvé quelque chose dans ce que je t'ai mis à disposition ? (je ne vais pas le laisser en ligne longtemps)


manu'

Hors ligne

#15 2014-02-19 12:39:03

Miklfe
Membre
Sarthe
2010-11-13
364

Re: [Slide] menus ouvert par défaut ?

Tu peux le retirer ça ne m'est pas d'une grande utilité, mais j'ai vu que ton site était de nouveau en ligne les menus ont l'air de fonctionné. pour le reste c'est un peu dur dur, ton hébergement ne serrait pas chez free par hasard?

Hors ligne

  •  » Styles
  •  » [Slide] menus ouvert par défaut ?

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact