Annonce

#1 2014-01-22 17:37:21

Newdeclic
Invité

Message d'erreur

Bonjour,

Je suis un nouvel utilisateur de Piwigi.
L'installation sur sur le serveur de mon site hébergé chez 1and1) s'est déroulée sans problème.
L'ajout de quelques images pour test c'est parfaitement exécuté.
L'affichage de la miniature de l'album se fait sans problème.
L'affichage des miniatures des photos se fait sans problème.
Mais lorsque je clique sur une miniature,la photo s'affiche mais j'ai  les 3 messages d'erreur ci-dessous:

----------
Strict Standards: DateTime::__construct(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead in /homepages/40/d507972891/htdocs/piwigo/include/functions.inc.php on line 553
----------
Strict Standards: DateTime::__construct(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead in /homepages/40/d507972891/htdocs/piwigo/include/functions.inc.php on line 553
----------
Warning: Cannot modify header information - headers already sent by (output started at /homepages/40/d507972891/htdocs/piwigo/include/functions.inc.php:553) in /homepages/40/d507972891/htdocs/piwigo/include/page_header.php on line 101
-----

Merci d'avance pour vos réponses

JL

#2 2014-01-22 17:39:32

Newdeclic
Invité

Re: Message d'erreur

oups j'ai oublié de mettre le lien de la galerie, :

http://www.newdeclic.com/piwigo/

Merci

#3 2014-01-22 17:55:35

flop25
Équipe Piwigo
2006-07-06
6477

Re: Message d'erreur

Bonjour
je vous invite à utiliser la fonction recherche du forum merci

Dernière modification par flop25 (2014-01-22 17:56:14)

Hors ligne

#4 2014-01-22 18:08:31

Newdeclic
Invité

Re: Message d'erreur

flop25 a écrit:

Bonjour
je vous invite à utiliser la fonction recherche du forum merci

Merci pour votre réponse mais comme je n'y comprends rien, je ne sais pas où chercher.

JL

#5 2014-01-22 20:05:52

Newdeclic
Invité

Re: Message d'erreur

Dommage une excellente galerie, mais chez moi ça ne fonctionne pas correctement, des erreurs qui ne sont pas mentionnées à l'installation, mais probablement une mauvaise configuration PHP ou/et Mysql chez mon hébergeur.

Je désinstalle... et je ferai de nouveaux essais ultérierement.

A bientôt,

JL

#6 2014-01-22 21:32:40

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14878

Re: Message d'erreur

Bonjour,

tu as mis ce qu'il faut pour être en php > 5.3


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#7 2014-01-23 09:35:55

barbichou
Membre
2013-01-06
85

Re: Message d'erreur

Salut,

Chez 1&1 il faut ajouter cette ligne dans local file editor -> configuration locale

date_default_timezone_set('Europe/Paris');

et le problème disparaît...
je me suis fait avoir aussi en passant à php5.4

@+ ;)

Hors ligne

#8 2014-01-26 08:13:28

newdeclic
Invité

Re: Message d'erreur

Merci, j'ai réinstallé et j'ai suivi vos conseils (ddtddt et barbichou) et maintenant ça fonctionne impeccable.

Je prends connaissance tout doucement de toutes les fonctionnalités maintenant et je fais des essais avec des plugins qui me semblent utiles.

Merci encore :)

JL

#9 2014-05-26 19:09:19

Stf4
Invité

Re: Message d'erreur

Bonjour,

merci de me précisez ou se trouve le fichier de configuration que vous évoquez .

a bientot

#10 2014-05-26 20:26:35

newdeclic
Membre
Vaucluse
2014-01-26
142

Re: Message d'erreur

Bonsoir,
@stf4: Désolé, mais ce post aurait du être mis en résolu. Au moment où je l'ai écrit je n'étais pas encore inscrit, et je crois que maintenant cela n'est pas possible à mon niveau. :(

Dernière modification par newdeclic (2014-05-26 20:35:37)


Hébergement 1and1 - Système d'exploitation (serveur): Linux
Version Piwigo :  2.10. - Version PHP : 7.3- Version MySql : 5.7
Bibliothèque graphique: External Imageagick 6.8.9-9

Hors ligne

#11 2014-09-29 01:49:01

Volfangel
Invité

Re: Message d'erreur

Stf4
    2014-05-26 19:09:19

Bonjour,

merci de me précisez ou se trouve le fichier de configuration que vous évoquez .

a bientot




alors moi aussi j'ai eu du mal a comprendre mais voila plus précisément se qu'il disait:

dans ton administration piwigo , tu vas dans Plugins
dans les plugins installé (s'il y est et qu'il n'y est pas activé, active le ! puis...)





configure le plugin nomée "Local Files Editor" une nouvelle fenetre s'ouvre et tu y trouvera des onglet dont le fameux onglet "configuration local"

et donc entre les balises PHP tu ajoute des ligne et plein millieu tu met la ligne

date_default_timezone_set('Europe/Paris');

tu fait enregistrer et bam !!! en clacant sur ton aceuil d'administration tu a tes ligne de disparut voila c'est tout simple


PS : si toutefois tu n'a pas "Local Files Editor" dans tes plugins tu peut le trouver iciPS http://piwigo.org/ext/extension_view.php?eid=144
tu le télécharge et l'installe dans les plugins voir la methode d'intall
mais cela est un autre tuto !

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact