#16 2014-01-22 07:20:09

Harry
Membre
2011-10-07
143

Re: Slide 2.0

Version 1.2.0 installée, mais aucun changement...

Hors ligne

#17 2014-01-22 12:08:50

Miklfe
Membre
Sarthe
2010-11-13
364

Re: Slide 2.0

Tu peux ouvrir un ticket dans la section plugin, parce que j'ai refait une instal complet avec le plugin et le theme et je ne reproduit pas.
La piste de la version php est une bonne piste moi je suis en 5.4.3

Hors ligne

#18 2014-01-22 14:59:43

Harry
Membre
2011-10-07
143

Re: Slide 2.0

Oui, apparemment, c'est bien ça ( ce post)... Mon hébergeur vient de me proposer de me déplacer sur un autre serveur avec PHP 5.3... C'est sans doute ce que je vais faire...

Sinon, petite question, Miklfe : Slide est basé sur "Elégant", qui dispose, lui, de flèches pour masquer ou afficher les infos/commentaires... C'est un choix délibéré de ta part de les avoir fait disparaître, ou est-ce que cela t'a été imposé du fait du chargement par load() ? Autrement dit, est-ce que ça vaut la peine que je cherche un moyen de réinstaller ces boutons, ou est-ce que c'est impossible ? (Si c'est impossible, et bien, mes visiteurs se passeront d'infos et de commentaires... Ils n'en mourront pas ! ;-D)

Edit : je dis ça parce que, normalement, j'aurais mis un peu de Jquery avec des hide() et show() mais puisqu'apparemment, il n'y a pas moyen de faire passer le moindre bout de Javascript...

Dernière modification par Harry (2014-01-22 23:06:35)

Hors ligne

#19 2014-01-23 01:30:46

Miklfe
Membre
Sarthe
2010-11-13
364

Re: Slide 2.0

effectivement c'est un choix de ma part, mais rien n'est figé.

je dis ça parce que, normalement, j'aurais mis un peu de Jquery avec des hide() et show() mais puisqu'apparemment, il n'y a pas moyen de faire passer le moindre bout de Javascript...

Ha non?!!! le theme est basé à 85% sur jquery mais à par ça : pas moyen de passer le moindre bout de code!! ;)))

une piste: avec la 2.6 de piwigo on à changer de version de jquery aussi.
dans les version précédente de jquery live() permettait d'appliquer à l'objet ou qu'il soit dans le dom un événement, c'était pratique mais très gourmand en ressource.
on pouvait par exemple faire

Code:

$('.mon_Objet_Qui_n_existe_pas_encore_mais_que_je_vais_céer_plus_tard').live('click' , function(){
//un évènement 
 })

avec la nouvelle version on utilise on(), et on applique l’événement par délégation à l'objet de cette façon

Code:

$('.l_objet_parent_existant_qui_va_contenir_mon_futur_objet').on('click' , '.mon_Objet_Qui_n_existe_pas_encore_mais_que_je_vais_céer_plus_tard' , function(){
//un évènement 
})

Hors ligne

#20 2014-01-23 20:08:33

Harry
Membre
2011-10-07
143

Re: Slide 2.0

Yes ! Oh, qu'il est content, le Harry !
Inutile de dire que je te dois une grosse boîte de chocolat à l'occasion, Miklfe, (ou même, soyons fous, une bouteille de champagne, c'est la spécialité dans mon coin...) vu que je n'aurais jamais trouvé sans toi !

Bon, par contre, j'ai placé pour l'instant mes essais de code dans slide.js (vu que, là, j'étais certain que ça serait lu ! ;-D )... Avant que j'aille plus loin, il y a moyen de placer un nouveau .js "à part" dans le même dossier pour qu'il soit combiné automatiquement avec les autres ?

Hors ligne

#21 2014-01-23 21:04:17

Miklfe
Membre
Sarthe
2010-11-13
364

Re: Slide 2.0

Essaye de mettre dans le local_head.tpl

Code:

{combine_script id='mon_nouveauJS' load='footer' require='jquery' path='themes/Slide/js/mon_nouveauJS.js'}

l'endroit ou tu place ton js n'a pas d'importance
sinon avec le pluggin Add < head > Element

Code:

<script src="le_chemin/vers/mon_nouveauJS.js" type="text/javascript"></script>

Sinon ça donne plutôt bien sauf que tu as un problème de fluidité quand tu referme le block (tu peux me montrer ton code par MP si tu veux).

Hors ligne

#22 2014-01-29 17:13:33

manu.p
Membre
Foie gras land
2014-01-28
17

Re: Slide 2.0

J'apprécie beaucoup ce thème pour une galerie que je suis en train de monter.

Une question : y a-t-il un moyen simple pour changer la dimension des 'thumbnails", je parle des photos qui représentent les albums ?
De ce que j'en vois, elles seraient en 1000x250px, mon idée serait de les tomber à 800px de large...

Merci.


manu'

Hors ligne

#23 2014-01-29 19:13:40

Miklfe
Membre
Sarthe
2010-11-13
364

Re: Slide 2.0

manu.p a écrit:

J'apprécie beaucoup ce thème pour une galerie que je suis en train de monter.

Une question : y a-t-il un moyen simple pour changer la dimension des 'thumbnails", je parle des photos qui représentent les albums ?
De ce que j'en vois, elles seraient en 1000x250px, mon idée serait de les tomber à 800px de large...

Merci.

Salut

pour les miniatures d'acceuil:
créer un template extention: copier mainpage_categories.tpl de Slide (themes/Slide/template/)
coller dans le dossier template-extention de Piwigo: renommer le fichier et ouvrer le avec votre éditeur de code.
à la ligne:

Code:

{define_derivative name='mainpage_derivative_params' height="250px" width="1000px" min_width="1000px" crop=true}

changer 1000px par 800px, activé ensuite le template extention (administration/configuration/templates)

Hors ligne

#24 2014-01-29 19:19:17

manu.p
Membre
Foie gras land
2014-01-28
17

Re: Slide 2.0

Merci Miklfe, parfait ! :o)


manu'

Hors ligne

#25 2014-01-30 04:20:53

Affligem
Membre
2011-09-05
9

Re: Slide 2.0

Salut à tous

Vous  pouvez peut être me faire gagner quelques minutes, est il possible de deplacer la description sous les miniatures comme illustré sur la photo ci-jointe

Merci
Eric


Images attachées

Dernière modification par Affligem (2014-01-30 04:21:53)

Hors ligne

#26 2014-01-30 07:04:17

Miklfe
Membre
Sarthe
2010-11-13
364

Re: Slide 2.0

Salut
avec localFiles editor -> onglet css -> choisir Slide puis coller :

Code:

#imageInfos{display:block}

Hors ligne

#27 2014-02-06 19:23:48

Harry
Membre
2011-10-07
143

Re: Slide 2.0

Bonjour, Miklfe,

Je poste ici parce que ça peut peut-être intéresser d'autres personnes... En fouillant un peu avec Google, je me suis aperçu que mes photos étaient normalement référencées... ou tout du moins les miniatures ! Car, si j'ai retrouvé toutes les miniatures que j'ai cherchées, aucune photo grande taille n'est proposée... Surpris, je suis allé voir dans le code source des pages images où j'ai trouvé un :
<meta name="robots" content="noindex,nofollow"> rédhibitoire, qui n'apparaît pas sur les autres pages... J'imagine qu'il y a une raison pour qu'il se trouve là... Mais laquelle ?

Dernière modification par Harry (2014-02-06 20:45:45)

Hors ligne

#28 2014-02-06 22:22:58

Miklfe
Membre
Sarthe
2010-11-13
364

Re: Slide 2.0

Il faut poser la question aux développeurs de Piwigo, je ne peux rien te dire à ce sujet.

Hors ligne

#29 2014-02-07 08:10:44

Harry
Membre
2011-10-07
143

Re: Slide 2.0

Merci de ta réponse, Miklfe... Je comprends d'autant moins que, ce matin, je n'arrive pas à reproduire (la balise meta robot affiche index,all,follow...). Diantre !
(Et, hier, ce n'est pas que j'avais mal lu puisque la balise citée était un copier-coller du code source et non une recopie)...

Dernière modification par Harry (2014-02-07 08:14:33)

Hors ligne

#30 2014-02-07 08:19:59

Harry
Membre
2011-10-07
143

Re: Slide 2.0

Ca y est : j'ai trouvé ! C'est le plugin Look Like GBO (que j'utilise uniquement pour forcer l'affichage des exifs) qui créée cette balise... Je l'avais désactivé ce matin...

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact