#1 2014-01-20 00:02:09

Miklfe
Membre
Sarthe
2010-11-13
364

Slide 2.0

Voilà la toute nouvelle version de slide: Slide 2.0
Esthétiquement le design a peu changé , le thème parent est maintenant "elegant", ce qui apporte des changements surtout sur la page des photos.
coté dev : slide n'utilise plus le plugin jquery pageslide, il n'y a donc plus d'iframe, les pages sont chargés avec load de jquery , ce qui apporte un plus pour le référencement.
autre nouveauté l'utilisation de pushstate qui permet l'affichage de l'url dans la barre des taches du navigateur et gestion de l'historique de celui-ci, là encore amélioration du référencement.
Je vous conseil néanmoins l'utilisation du plugin RV SiteMap pour améliorer votre référencement.
du coté petite nouveauté, le thème à son propre diaporama et la page est chargé avant de lancer le slide (ce qui évite l'arriver d'une page vide).
Pensez à créer vos miniatures avant d'utiliser le thème.

Plugin compatible (tester): GThumb+; EasyCaptcha; ContactForm; Guestbook;
probablement d'autres mais si vous avez un problème de compatibilité n’hésitez pas.

Dernière modification par Miklfe (2014-01-20 22:32:27)

Hors ligne

#2 2014-01-20 16:55:56

Harry
Membre
2011-10-07
143

Re: Slide 2.0

Hello, Miklfe !

Petit souci avec la mise à jour : le sliding a l'air bien plus efficace mais, sur la page des grandes images, je n'ai plus aucun lien pour passer à la page suivante ou précédente, ni en map sur l'image, ni en flèches en haut à droite (par contre, je peux revenir à l'accueil ou à l'album et charger une autre image).
Bien sûr, j'ai déconnecté tous les plugins, enlevé ce que j'avais mis dans le <head> et mes modifs de CSS. Tu as une idée ? (lien vers ma galerie ci-dessous)

Edit : par contre, les miniatures de navigation fonctionnent si je les active...

Edit2 : en fait, je m'aperçois en plus que je n'ai aucune icône en haut !

Dernière modification par Harry (2014-01-20 19:34:38)

Hors ligne

#3 2014-01-20 20:59:44

Miklfe
Membre
Sarthe
2010-11-13
364

Re: Slide 2.0

Salut Harry
Ce sont les icons de la page image(voir capture)
Donne moi un lien svp


Images attachées

Dernière modification par Miklfe (2014-01-20 21:04:03)

Hors ligne

#4 2014-01-20 21:07:22

Harry
Membre
2011-10-07
143

Re: Slide 2.0

Miklfe a écrit:

Donne moi un lien svp

Ici...

Hors ligne

#5 2014-01-20 21:18:40

Miklfe
Membre
Sarthe
2010-11-13
364

Re: Slide 2.0

J'ai fait une correction met à jour le thème

Hors ligne

#6 2014-01-20 21:37:54

Harry
Membre
2011-10-07
143

Re: Slide 2.0

OK, ça marche ! Merci ! Mais j'en conclus qu'il n'y a pas de navigation sur l'image sur ton nouveau thème ? (Pas dramatique pour moi ; juste pour info...)

Hors ligne

#7 2014-01-20 22:21:48

Miklfe
Membre
Sarthe
2010-11-13
364

Re: Slide 2.0

tout juste

Hors ligne

#8 2014-01-20 22:31:41

Miklfe
Membre
Sarthe
2010-11-13
364

Re: Slide 2.0

j'ai oublié de préciser qu'il faut que les miniatures soit créé avant d'utiliser Slide.

Hors ligne

#9 2014-01-20 23:07:14

Harry
Membre
2011-10-07
143

Re: Slide 2.0

Tiens, une question pendant que j'y pense : quand je clique sur une image, j'ai un curieux petit carré semi-transparent qui apparaît (un peu n'importe où, apparemment, parfois assez loin de la zone du click)... C'est faisable de le faire disparaître (vu que sa position est variable et qu'il n'apparaît que lors d'un click, je ne vois pas comment le "chopper" avec Firebug) ?

Hors ligne

#10 2014-01-20 23:17:23

Miklfe
Membre
Sarthe
2010-11-13
364

Re: Slide 2.0

En fait c'est le loader de la page: si ta page met plus d'une demi seconde à ce charger le loader démarre, dans ton cas il démarre quelques millisecondes avant que la page arrive. Ce que tu peux faire c'est augmenté ce temps de 1/2 seconde.
dans slide.js à la ligne 33

Code:

$('#slideLoading').css('z-index',1000)
}, 500);

tu peux augmenté le 500

j'ai fais ça parce que parfois le temps d'attente de la page était trop important, et je pense que l'utilisateur aurai pu re-cliquer (il y a des nerveux)

Hors ligne

#11 2014-01-21 08:02:46

Harry
Membre
2011-10-07
143

Re: Slide 2.0

Merci, Miklfe !

Hors ligne

#12 2014-01-21 16:41:44

Harry
Membre
2011-10-07
143

Re: Slide 2.0

Hello, Miklfe !

Apparemment, petit problème avec le plugin "Social buttons"... Si j'essaie de l'activer, j'obtiens :

Code:

Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /home2/eq89185/html/photos2/include/template.class.php(1182) : runtime-created function on line 1

et, bien sûr, pas de boutons...
Pas que j'aie besoin de ce plugin, mais ça peut en intéresser d'autres...

Edit : Et, tiens, je viens de tester le diaporama... Superbe, avec les miniatures !!! Mais par contre, quel que soit l'album, j'ai un souci avec la dernière image de chaque album qui est décalée vers le bas à droite (alors que c'est impec pour les autres). Voir pièce jointe...


Images attachées

Dernière modification par Harry (2014-01-21 16:53:52)

Hors ligne

#13 2014-01-21 17:52:45

Miklfe
Membre
Sarthe
2010-11-13
364

Re: Slide 2.0

Pour social buttons je ne reproduit pas, désactive tes autres plugin pour voir
pour le slideshow petit bug effectivement je regarde à ça.

Hors ligne

#14 2014-01-21 18:24:15

Harry
Membre
2011-10-07
143

Re: Slide 2.0

Tout supprimé (plugins, css, <head>) et ça reste... Peut être parce que mon PHP est en 5.2.17 seulement ?

Hors ligne

#15 2014-01-22 06:40:29

Miklfe
Membre
Sarthe
2010-11-13
364

Re: Slide 2.0

supprime le dossier Social Buttons et ré-installe, le pour voir. Tu n'a peut-être pas la bonne version (version en cour 1.2.0)

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact