•  » Utilisation
  •  » Plus aucun album visible même en mode public!!

#1 2012-10-16 15:33:16

Huget
Invité

Plus aucun album visible même en mode public!!

Bonjour,
depuis 1 an nous utilisons Piwigo comme banque d'image accessible pour nos clients (tout en mode public). La semaine dernière nous avons décidé d'aller plus loin et de mettre les galeries de photo en mode privé. Dès lors le utilisateurs doivent s'inscrire... Jusque là tout va bien si ce n'est que maintenant nous ne parvenons plus à montrer un album à quiconque autre qu'un administrateur.

1. mettons une galerie de photo que je définit en mode privé mais accessible au groupe 'Presse', lorsque j'accède via un compte utilisateur qui fait partie du groupe 'Presse', aucune photo n'est visible.

2. je décide de remettre une galerie 'privée' en mode 'public', cette galerie n'est pas visible sur la page par défaut. Si je me connecte avec un compte utilisateur, je n'ai toujours pas accès à cette galerie (ni aucune d'ailleurs)

3. Si je paramètre le compte utilisateur comme faisant partie du groupe 'presse' (qui donne accès a mes albums), que son niveau de confidentialité est élevé à 'famille' ou 'admin', ce compte ne peut voir aucune image. Ce n'est qu'en changeant le statut en 'Administrateur' que ce compte peut voir les visus. 

Je suis très ennuyé car depuis qu'on a fait ce changement, nos agence de presse etc nous demandent des visuels et nous ne somme plus en mesure de pouvoir leur fournir autrement qu'en les envoyant nous même. On a essayé de remettre nos visuels en mode public mais comme dit plus haut, ça ne change rien, plus rien n'est visible tant qu'on est pas administrateur.
Au secours

#2 2012-10-16 16:10:18

Mascarille
Membre
Lyon Avignon
2009-12-21
778

Re: Plus aucun album visible même en mode public!!

Bonjour,
en quelle version de Piwigo êtes-vous ?
Si vous êtes à jour des versions :
Lorsque vous allez dans Groupes, dans la ligne du groupe concerné, cliquez sur le petit cadenas, vos albums sont en "Autorisés" ou "Interdits"
S'ils sont en interdits sélectionnez les et faites les passer en autorisés avec la flèche d'en bas

Dans l'attente de vos réponses, pas de panique, on va y arriver !

Hors ligne

#3 2012-10-16 16:14:05

flop25
Équipe Piwigo
2006-07-06
6407

Re: Plus aucun album visible même en mode public!!

vérifiez aussi que vous n'avez pas mélangé groupe/album privé et niveau de confidentialité des images. Ça arrive

Hors ligne

#4 2012-10-16 16:25:31

Huget
Invité

Re: Plus aucun album visible même en mode public!!

Bonjour Mascarille et Flop25,
Je suis en version 2.4.4 (upgrated from 2.1..)
Pour les groupes "autorisés" ou "interdits" c'est bien comme il faut, les albums qui doivent être visible pour le groupe créé sont bien dans la colonne "autorisés".

flop25 : j'ai vérifié, les photos sous "Qui peut voir les photos?" sont en "tout le monde" et comme dit à Mascarille, J'ai bien definit les albums comme étant autorisés dans le groupe.

Ce que je ne comprend pas c'est que je ne parviens même plus à avoir un album en mode public. (enfin, je veux dire qu'ils sont définits comme étant publics, mais ils ne s'affichent pas hors connection)

#5 2012-10-16 16:26:58

flop25
Équipe Piwigo
2006-07-06
6407

Re: Plus aucun album visible même en mode public!!

je peux avoir un accès admin par mail svp?

Hors ligne

#6 2012-10-16 21:35:07

flop25
Équipe Piwigo
2006-07-06
6407

Re: Plus aucun album visible même en mode public!!

Problème : Les albums sont verrouillés
solution : déverrouiller les sur la page admin.php?page=cat_options&section=visible

Hors ligne

#7 2012-10-16 22:57:56

Mascarille
Membre
Lyon Avignon
2009-12-21
778

Re: Plus aucun album visible même en mode public!!

Intéressant, je n'avais pas pensé à ça...
Seule une connexion admin permettait de trouver.
Bonne soirée

Hors ligne

#8 2012-10-17 02:58:09

flop25
Équipe Piwigo
2006-07-06
6407

Re: Plus aucun album visible même en mode public!!

Mascarille a écrit:

Intéressant, je n'avais pas pensé à ça...
Seule une connexion admin permettait de trouver.
Bonne soirée

j'avoue que j'y pensais pas non plus ^^
et c'est peu utilisé

Hors ligne

#9 2012-10-17 09:47:59

trouille2
Membre
2012-10-09
44

Re: Plus aucun album visible même en mode public!!

Merci pour votre recherche. Ca marche!! Excellent.

Hors ligne

#10 2012-10-17 10:15:15

Mascarille
Membre
Lyon Avignon
2009-12-21
778

Re: Plus aucun album visible même en mode public!!

flop25 a écrit:

j'avoue que j'y pensais pas non plus ^^
et c'est peu utilisé

Alors pour éviter ce type d'oubli - et le stress utilisateur ! - il faut peut-être afficher clairement - avec une ligne en rouge ou en gras - sur "Base de données" de la page admin : xxx albums verrouillés.

Bonne journée

Hors ligne

#11 2012-10-17 14:31:42

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: Plus aucun album visible même en mode public!!

Mascarille a écrit:

flop25 a écrit:

j'avoue que j'y pensais pas non plus ^^
et c'est peu utilisé

Alors pour éviter ce type d'oubli - et le stress utilisateur ! - il faut peut-être afficher clairement - avec une ligne en rouge ou en gras - sur "Base de données" de la page admin : xxx albums verrouillés.

Bonne journée

Pas faux, c'est un paramètre souvent mal compris et donc source d'erreurs.
Mais une fois utilisée à bon escient ca devient une très bonne option :-)


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

  •  » Utilisation
  •  » Plus aucun album visible même en mode public!!

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2018 · Contact