•  » Utilisation
  •  » [Résolu] Bug lors de la mise à jour description/titre d'un album

#1 2011-11-08 13:00:16

jeradam
Membre
2006-10-15
29

[Résolu] Bug lors de la mise à jour description/titre d'un album

bonjour,
Depuis la mise à jour 2.3.1 (c'est peut etre un hasard!), quand je modifie la fiche d'un album, il me le mets en catégorie principale.  La valeur "id_uppercat"  devient  Null alors qu'il devrait y avoir 68.
Vous pouvez voir sur le deuxième screenshot que piwigo me déplace bien l'album alors que j'ai juste modifié le nom et la description
Quelqu'un d'autre aurait t il le même soucis que moi?
Merci de votre aide


Images attachées

Dernière modification par jeradam (2011-11-08 13:00:56)

Hors ligne

#2 2011-11-08 13:40:46

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] Bug lors de la mise à jour description/titre d'un album

Ok, je confirme bien le bug (certainement introduit avec [Bugtracker, ticket 2491, fixed] "1 album moved" message when editing properties) que je reproduis avec des albums physiques uniquement (chargement via FTP).

@plg : il faut ouvrir un nouveau un ticket ou bien rouvrir le premier ?


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#3 2011-11-08 13:44:15

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12277

Re: [Résolu] Bug lors de la mise à jour description/titre d'un album

Gotcha a écrit:

@plg : il faut ouvrir un nouveau un ticket ou bien rouvrir le premier ?

:-/

J'ai fait beaucoup de tests, mais pas avec les albums physiques j'avoue.

jeradam, tu confirmes que c'est avec un album physique que ça pose problème ?

Hors ligne

#4 2011-11-08 13:44:52

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12277

Re: [Résolu] Bug lors de la mise à jour description/titre d'un album

et oui, il faut ouvrir un nouveau bug, car cela n'a rien à voir avec le premier (qui lui est bien corrigé), puis lier les 2 bugs.

Hors ligne

#5 2011-11-08 13:54:46

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] Bug lors de la mise à jour description/titre d'un album


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#6 2011-11-08 14:34:01

jeradam
Membre
2006-10-15
29

Re: [Résolu] Bug lors de la mise à jour description/titre d'un album

oui c'est des albums physique, j'ai que ça moi :P

Hors ligne

#7 2011-11-08 15:41:30

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12277

Re: [Résolu] Bug lors de la mise à jour description/titre d'un album

Bon, dans l'immédiat, il faut télécharger admin/cat_modify.php et l'envoyer par FTP sur votre site dans le répertoire "admin"

Hors ligne

#8 2011-11-09 15:26:02

Mascarille
Membre
Lyon Avignon
2009-12-21
778

Re: [Résolu] Bug lors de la mise à jour description/titre d'un album

Et Gotcha qui nous disait qu'on ne pouvait pas déplacer un album physique !
Et bien si... partiellement ^-^

Je n'avais pas vu ce fil et je suis tombé sur le même problème

Je confirme que le problème se pose avec des albums physiques :

En mettant à jour une description
Le message "album déplacé" apparaît, comme avant la correction
==> [Bugtracker, bug 2491, fixed] "1 album moved" message when editing properties
mais cette fois il le fait !
Le dossier "apparaît" à la racine

J'ai fait une synchronisation rapide pour ramener le dossier à sa place (enfin les liens...)
la synchro dit bien : dossier ajouté / dossier supprimé / photos ajoutées.
mais en perdant la description du dossier, ce qui est assez logique.

Je vais faire la correction préconisée

Hors ligne

#9 2011-11-09 15:31:29

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12277

Re: [Résolu] Bug lors de la mise à jour description/titre d'un album

Pour ceux qui sont affectés par le bug, c'est à dire qui ont fait une modification des propriétés d'un album physique (ajouté par synchronisation) sur la page admin.php?page=cat_modify, alors il faut :

1) repérer l'identifiant numérique de l'album affecté par le bug, par exemple 9 (évidemment, ça sera différent pour chaque utilisateur)

2) repérer l'identifiant numérique de l'album qui est sensé être le bon album parent, par exemple 8

3) aller dans la base de données, et appliquer la requête suivante (adapter le 8 et le 9 selon vos propres identifiants)

update piwigo_categories set id_uppercat=8 where id=9;


4) aller sur l'écran [Administration > Outils > Maintenance] et appliquez l'action de mise à jour des informations des albums

Hors ligne

#10 2011-11-09 15:36:32

Mascarille
Membre
Lyon Avignon
2009-12-21
778

Re: [Résolu] Bug lors de la mise à jour description/titre d'un album

Je confirme qu'avec la correction c'est désormais correct

Hors ligne

#11 2011-11-10 12:46:03

jeradam
Membre
2006-10-15
29

Re: [Résolu] Bug lors de la mise à jour description/titre d'un album

Bonjour,
J'ai bien le nouveau fichier cat_modify sur mon ftp mais en modifiant l'ordre de mes sous catégorie, la categorie principale a disparu de ma page d'accueil alors qu'elle se trouve bien dans la colonne de gauche, et je peux la voir dans la base de donnée et dans l'administration... est ce que ça à un lien avec le nouveau fichier cat_modify?!

EDIT : j'ai fait "4) aller sur l'écran [Administration > Outils > Maintenance] et appliquez l'action de mise à jour des informations des albums" et ça remarche...

Dernière modification par jeradam (2011-11-10 12:47:04)

Hors ligne

  •  » Utilisation
  •  » [Résolu] Bug lors de la mise à jour description/titre d'un album

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact