•  » Styles
  •  » [ Thème stripped ] compatibilité avec l'indexation par les moteurs

#1 2011-09-18 16:22:25

chrisaga
Former Piwigo Team
France (92)
2005-08-10
564

[ Thème stripped ] compatibilité avec l'indexation par les moteurs

Je pense être tombé sur un problème de compatibilité entre le thème stripped et l'indexation des galeries Piwigo.
J'ai d'abord cru à un problème général (Cf. http://fr.piwigo.org/forum/viewtopic.php?id=20925), mais j'ai fini par recentrer la question autour du comportement de ce thème.
Ça n'est bien évidemment gênant que si c'est le thème par défaut de la galerie.

Je résume ce que j'ai trouvé :

* Si l'on utilise le thème stripped, les meta author, keywords, descriptions ne sont jamais générées dans la page html  et  nofollow et noindex sont systématiquement positionnées, alors que meta_ref est bien à 'true' dans le fichier de config.

* Il semble que le thème "stripped" active l'affichage optionnel des métadonnées, leur visibilité réelle étant gérée alors par les onglets de ce thème.

* Le template prévoit de ne pas afficher les meta de la page html et empêche l'indexation lorsque les métadonnée exif ou iptc de l'image sont affichées (ça ne me paraissait pas indispensable, mais pourquoi pas ?).

J'en conclus que dans la situation actuelle, on ne peut pas utiliser stripped comme thème par défaut si l'on veut que sa galerie soit un tout petit peu indexée.

Pour ma part, j'ai indiqué (lien ci-dessus) le petit hack que j'utilise temporairement, mais je n'ai pas vraiment d'idée pour une solution pérenne.
De plus, je ferme le bug Piwigo que j'avais ouvert croyant être tombé sur un problème général (et j'aurais bien aimé ouvrir un bug dans mantis sur stripped, mais je ne l'ai pas trouvé).


Utilisateur depuis la version 1.3, Impliqué depuis la 1.4, Responsable du template des 1.5 et 1.6  ... et en (in)disponibilité sur la 1.7

Hors ligne

#2 2011-09-18 16:27:25

chrisaga
Former Piwigo Team
France (92)
2005-08-10
564

Re: [ Thème stripped ] compatibilité avec l'indexation par les moteurs

Je pense que le problème est que la variable de session qui indique l'affichage des métadonnées (normalement activée par le bouton "show exif") est toujours activée lorsque l'on utilise stripped.

Serait-il possible de ne le faire que si l'onglet exif ou l'onglet iptc est actif ?


Utilisateur depuis la version 1.3, Impliqué depuis la 1.4, Responsable du template des 1.5 et 1.6  ... et en (in)disponibilité sur la 1.7

Hors ligne

#3 2011-09-18 16:51:58

Zaphod
Équipe Piwigo
Toulouse
2006-11-13
2422

Re: [ Thème stripped ] compatibilité avec l'indexation par les moteurs

chrisaga a écrit:

Serait-il possible de ne le faire que si l'onglet exif ou l'onglet iptc est actif ?

Sauf que si je ne mets pas cette valeur à true, l'onglet n'apparait pas du tout.
Donc on ne peut plus cliquer dessus...

Hors ligne

#4 2011-09-18 17:13:38

chrisaga
Former Piwigo Team
France (92)
2005-08-10
564

Re: [ Thème stripped ] compatibilité avec l'indexation par les moteurs

Zaphod a écrit:

chrisaga a écrit:

Serait-il possible de ne le faire que si l'onglet exif ou l'onglet iptc est actif ?

Sauf que si je ne mets pas cette valeur à true, l'onglet n'apparait pas du tout.
Donc on ne peut plus cliquer dessus...

Je m'en doutais un peu.
Comme je l'ai dit dans l'autre discussion, je ne suiq pas certain de l'intérêt de cette "protection" (mais peut-être que je me trompe) :
Les métadonnées iptc et exif ont été récupérée par Piwigo dans l'image elle-même, donc si les robots peuvent lire l'image, pourquoi leur interdire de lire les métadonnées extraites de l'image alors qu'ils peuvent les extraire eux-mêmes ?

Ça devait avoir une raison à l'époque, mais je ne sais pas laquelle.
Donc remonter la question à l'équipe "active"  (moi, je suis un ex-actif  ;-)
C'est peut-être comme ça que l'on s'en sortira ...


Utilisateur depuis la version 1.3, Impliqué depuis la 1.4, Responsable du template des 1.5 et 1.6  ... et en (in)disponibilité sur la 1.7

Hors ligne

#5 2011-09-19 02:43:09

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14792

Re: [ Thème stripped ] compatibilité avec l'indexation par les moteurs

chrisaga a écrit:

Donc remonter la question à l'équipe "active"  (moi, je suis un ex-actif  ;-)

cela ne dépend que de toi pour repasser en actif :-D


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#6 2011-09-19 18:54:25

chrisaga
Former Piwigo Team
France (92)
2005-08-10
564

Re: [ Thème stripped ] compatibilité avec l'indexation par les moteurs

ddtddt a écrit:

chrisaga a écrit:

Donc remonter la question à l'équipe "active"  (moi, je suis un ex-actif  ;-)

cela ne dépend que de toi pour repasser en actif :-D

Je sais bien, mais comme le temps de boulot est malheureusement incompressible, ça vient amputer le temps que je passe sur mes photos. Comme j'ai quelques projets en cours, je voudrais limiter le temps que je passe sur Piwigo à ce qui est nécessaire pour avoir une belle galerie, mais en le faisant intelligemment (c.a.d remonter les bugs, investiguer , et  aider à corriger si je peux).


Utilisateur depuis la version 1.3, Impliqué depuis la 1.4, Responsable du template des 1.5 et 1.6  ... et en (in)disponibilité sur la 1.7

Hors ligne

#7 2011-09-24 19:56:15

gbo
Membre
Martigues
2006-11-01
1152

Re: [ Thème stripped ] compatibilité avec l'indexation par les moteurs

Si cela peut aider.
J'avais un problème similaire au début du plugin LLGBO pour de l'affichage des Exifs au survol du bouton.
je l'ai résolu en désactivant le 'meta_robots' de la page metadata.
unset ($page['meta_robots']);

Hors ligne

  •  » Styles
  •  » [ Thème stripped ] compatibilité avec l'indexation par les moteurs

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact