•  » Plugins
  •  » [Plugin] LCAS - Insensibilité aux accents et à la casse

#16 2012-09-30 23:41:12

LucMorizur
Membre
Vienne (Isère, 38)
2009-03-01
1969

Re: [Plugin] LCAS - Insensibilité aux accents et à la casse

Ah ben nous v'là beaux :-/ ...

Espérons qu'un testeur mieux loti et compréhensif, viendra à notre secours...

:-D

Hors ligne

#17 2012-10-01 12:20:25

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Plugin] LCAS - Insensibilité aux accents et à la casse

Si vous me donner une procédure de test je peux y regarder ;-)


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#18 2012-10-01 18:52:16

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Plugin] LCAS - Insensibilité aux accents et à la casse

Fonction d'envoi de mail testé avec Piwigo 2.4.4 : OK - RAS.

En fait, dans Piwigo 2.4.x, c'est la gestion des photos qui a été revue avec l'apparition des générations à la volée. Les plugins qui ne traitent pas des photos (affichage, modification, etc...) comme LCAS ne posent, a priori, pas de problème particulier.

Il faudrait quand même tester des utilisations "hors-norme" ou dans des conditions extrêmes pour être certain que tout est OK.

Hors ligne

#19 2012-10-01 23:10:52

LucMorizur
Membre
Vienne (Isère, 38)
2009-03-01
1969

Re: [Plugin] LCAS - Insensibilité aux accents et à la casse

Ben... je n'ai pas vu trop de cas "hors-normes"... alors j'ai passé LCAS compatible 2.4...

Hors ligne

#20 2012-10-01 23:34:32

julien1311
Membre
2010-09-01
141

Re: [Plugin] LCAS - Insensibilité aux accents et à la casse

LucMorizur a écrit:

Ben... je n'ai pas vu trop de cas "hors-normes"... alors j'ai passé LCAS compatible 2.4...

Merci

Hors ligne

#21 2012-10-02 11:57:09

LucMorizur
Membre
Vienne (Isère, 38)
2009-03-01
1969

Re: [Plugin] LCAS - Insensibilité aux accents et à la casse

[HS]

Gotcha a écrit:

Si vous me donner une procédure de test je peux y regarder ;-)

Au fait Gotcha, merci pour ta proposition ! Éric a été plus rapidement que moi, j'allais te proposer un protocle de test.
[/HS]

julien1311 a écrit:

Merci

De rien :-) !

Hors ligne

#22 2013-03-17 23:26:36

clemouel
Membre
94 - Val de Marne
2005-11-13
182

Re: [Plugin] LCAS - Insensibilité aux accents et à la casse

Bonjour / Bonsoir,

Ma piwigothèque vient d'évoluer en 2.5.0.

Ce plugin, LCAS version 2.2.3., est indiqué comme sembler ne pas être compatible avec PWG 2.5.0.

Toutefois, je viens de l'activer et il semble fonctionner correctement.

Si tel est bien le cas pour tout le monde, peut être pourriez-vous enlever ce marquage de compatibilité ?

Merci.

Cyril

Hors ligne

#23 2013-03-18 21:50:01

LucMorizur
Membre
Vienne (Isère, 38)
2009-03-01
1969

Re: [Plugin] LCAS - Insensibilité aux accents et à la casse

clemouel a écrit:

Bonjour / Bonsoir,

Ma piwigothèque vient d'évoluer en 2.5.0.

Ce plugin, LCAS version 2.2.3., est indiqué comme sembler ne pas être compatible avec PWG 2.5.0.

Toutefois, je viens de l'activer et il semble fonctionner correctement.

Si tel est bien le cas pour tout le monde, peut être pourriez-vous enlever ce marquage de compatibilité ?

Merci.

Cyril

Eh bien voilà qui est fait...

Merci Cyril !

Hors ligne

#24 2013-03-18 22:17:25

clemouel
Membre
94 - Val de Marne
2005-11-13
182

Re: [Plugin] LCAS - Insensibilité aux accents et à la casse

Parfait, c'est magnifique Luc.

Hors ligne

#25 2014-01-12 23:18:50

LucMorizur
Membre
Vienne (Isère, 38)
2009-03-01
1969

Re: [Plugin] LCAS - Insensibilité aux accents et à la casse

Bonjour ;

je teste LCAS pour la révision 2.6 de Piwigo. Je suis tombé sur une erreur dûe à la présence d'un known_script dans header21.tpl. Or header21.tpl est appelé dans global.tpl, par les lignes ci-dessous :

Code:

{html_head}
{if PHPWG_VERSION < 2.2 }
  {include file= $LCAS_PATH_ABS|@cat:'template/header21.tpl'}
{else}
  {include file= $LCAS_PATH_ABS|@cat:'template/header22.tpl'}
{/if}
{/html_head}

Cela ne fonctionne manifestement pas, puisque PHPWG_VERSION vaut "2.6.0RC2" (vérifié). À moins que ce soit la présence de "RC2" qui pose problème ?

En tous cas, y a-t-il un moyen simple de coder ça de façon correcte pour Smarty ? Sinon je ne laisserai que la référence à header22.tpl, et casserai la compatibilité avec les versions précédentes, ce qui ne sera pas très grave à mon avis.

Hors ligne

#26 2014-01-30 22:29:55

LucMorizur
Membre
Vienne (Isère, 38)
2009-03-01
1969

Re: [Plugin] LCAS - Insensibilité aux accents et à la casse

Bonsoir ;

j'essaie doucement de rendre [extension by Eric] LCAS compatible avec Piwigo 2.6.1, ce n'est actuellement pas le cas. Le problème pour le moment est que la fonction get_email_address_as_display_text a disparu dans la nouvelle version de functions_user.inc.php . Mais je ne sais pas par quoi la remplacer. Je n'ai rien trouvé à ce sujet dans les forums (francophone et anglophone), ni dans les notes techniques des changements de la version 2.6.

Merci...!

Hors ligne

#27 2014-01-31 09:41:26

clemouel
Membre
94 - Val de Marne
2005-11-13
182

Re: [Plugin] LCAS - Insensibilité aux accents et à la casse

Bonjour Luc,

C'est Béatrice qui est marri de la situation l'obligeant à garder son ex PWG.

Elle vous apporte tout son soutien moral pour aboutir dans une révision de LCAS compatible avec son tout nouveau piwigo, tout mignon tout beau, qu'elle convoite tant.

Ah BÉA, une femme formidable !

Cyril
LCAS("Cyril") ="Cyril"

Hors ligne

#28 2014-01-31 12:45:24

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Plugin] LCAS - Insensibilité aux accents et à la casse

Salut Luc,

LucMorizur a écrit:

Le problème pour le moment est que la fonction get_email_address_as_display_text a disparu dans la nouvelle version de functions_user.inc.php . Mais je ne sais pas par quoi la remplacer

Tu peux simplement supprimer l'appel à cette fonction. Par exemple, si tu avais
$test = get_email_address_as_display_text($email);

tu remplaces simplement par
$test = $email;

Hors ligne

#29 2014-01-31 23:24:06

LucMorizur
Membre
Vienne (Isère, 38)
2009-03-01
1969

Re: [Plugin] LCAS - Insensibilité aux accents et à la casse

Bon, je ne sais pas ce que j'ai m[censuré]dé, j'avais déjà livré la version 2.2.4 avec la mention "compatibilité avec 2.6" (où j'avais déjà retiré l'utilisation de get_email_address_as_display_text , mais pas le test de la version de Piwigo), mais en fait ça ne fonctionnait pas et en plus la compatibilité n'était pas notée dans PEM. Il y a quand même eu une centaine de téléchargements, j'espère qu'il n'y a pas eu trop de gêne :-/ .

En tous cas comme je l'écrivais dernièrement, la prochaine version cassera la compatibilité avec les anciennes de Piwigo (avant 2.2). Appelle-t-on la nouvelle version "2.2.5", ou bien cela justifie-t-il le passage à une version 2.3 de LCAS ?

Hors ligne

#30 2014-02-01 13:52:49

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Plugin] LCAS - Insensibilité aux accents et à la casse

Vu les changements techniques apportés par Piwigo 2.6 et l'impact sur certains plugins, il serait très compliqué de maintenir une compatibilité descendante pour les plugins comme LCAS.

Pour ma part, la dernière version d'UAM ne peut être compatible qu'avec Piwigo 2.6, d'où un numéro de version 2.60.x avec création d'une branche spécifique 2.60. Ainsi, je conserve la possibilité (si besoin était) d'apporter des correctifs sur l'ancienne branche 2.50 pour les versions de Piwigo < 2.6.

Mais ce n'est qu'une approche personnelle du problème. On peut très bien partir du fait que la dernière version d'un plugin fait foi et s'accorde avec la dernière version de Piwigo en vigueur. Tant pis pour les anciennes versions et quitte à militer pour que les utilisateurs passent à la dernière version de leur galerie préférée...

Donc, libre à toi de numéroter la version de LCAS à ta convenance. Une version LCAS 2.3 serait en tous cas justifiée selon moi ;-)

Hors ligne

  •  » Plugins
  •  » [Plugin] LCAS - Insensibilité aux accents et à la casse

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact