•  » Utilisation
  •  » [Résolu] Problème lors de recherches approfondies

#1 2010-12-17 10:00:20

epphoto
Membre
2010-11-24
24

[Résolu] Problème lors de recherches approfondies

Bonjour.

Sur mon site : www.epphotostock.fr
lorsque on fait une recherche précise

Tout se passe bien si je tape du texte en haut, j'ai bien des réponses que je peux visionner.
Si je coche des tags, ça marche aussi.
Mais si je tape du texte plus coche des tags, j'ai des réponses mais lorsque je clique sur la miniature pour voir la photo voilà ce qui s'affiche :

Notice: Undefined offset: 0 in /homepages/41/d279872492/htdocs/picture.php on line 203

Warning:  [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '6164,5140)' at line 3

SELECT *
  FROM piwigo_images
  WHERE id IN (6165,6170,,6164,5140)
; in /homepages/41/d279872492/htdocs/include/functions.inc.php on line 923


Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /homepages/41/d279872492/htdocs/picture.php on line 387

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/picture.php on line 562

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/picture.php on line 577

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/picture.php on line 680

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/picture.php on line 818

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/picture.php on line 826

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/picture.php on line 833

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/picture.php on line 857

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/picture.php on line 860

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/picture.php on line 930

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/include/picture_rate.inc.php on line 31

Warning: Cannot modify header information - headers already sent by (output started at /homepages/41/d279872492/htdocs/picture.php:203) in /homepages/41/d279872492/htdocs/include/page_header.php on line 98

Je me doute que mes nombreuses modif un peu approximatives y sont pour quelque chose mais alors quoi faire ?

Merci d'avance si quelqu'un a une idée

Dernière modification par epphoto (2010-12-17 10:00:47)

Hors ligne

#2 2010-12-17 10:23:44

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14308

Re: [Résolu] Problème lors de recherches approfondies

est e que tu utilises un plugin / recherche ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2010-12-17 10:26:38

epphoto
Membre
2010-11-24
24

Re: [Résolu] Problème lors de recherches approfondies

Non pas de plugin recherche

Hors ligne

#4 2010-12-17 10:53:06

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14308

Re: [Résolu] Problème lors de recherches approfondies

Avant toutes choses, est ce que tu peux aller dans

Administration -> Outils -> Maintenance ->

et

    * Mettre à jour les informations des catégories
    * Mettre à jour les informations des images
    * Réparer et optimiser la base de données


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#5 2010-12-17 11:06:28

epphoto
Membre
2010-11-24
24

Re: [Résolu] Problème lors de recherches approfondies

C'est fait ...

même résultat quand on veut regarder les réponses à une recherche mot + tag

Notice: Undefined offset: 0 in /homepages/41/d279872492/htdocs/picture.php on line 203

Notice: Undefined offset: 12 in /homepages/41/d279872492/htdocs/picture.php on line 210

Warning:  [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '3789,)' at line 3

SELECT *
  FROM piwigo_images
  WHERE id IN (3809,3828,,3789,)
; in /homepages/41/d279872492/htdocs/include/functions.inc.php on line 923


Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /homepages/41/d279872492/htdocs/picture.php on line 387

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/picture.php on line 562

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/picture.php on line 577

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/picture.php on line 680

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/picture.php on line 818

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/picture.php on line 826

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/picture.php on line 833

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/picture.php on line 857

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/picture.php on line 860

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/picture.php on line 930

Notice: Undefined index: current in /homepages/41/d279872492/htdocs/include/picture_rate.inc.php on line 31

Warning: Cannot modify header information - headers already sent by (output started at /homepages/41/d279872492/htdocs/picture.php:203) in /homepages/41/d279872492/htdocs/include/page_header.php on line 98

Hors ligne

#6 2010-12-19 23:21:37

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] Problème lors de recherches approfondies

Bonsoir,

Lors de l'installation de votre galerie, avez-vous utilisé la méthode "NetInstall" ou bien le transfert manuel des fichiers de Piwigo via FTP ?


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#7 2010-12-20 10:40:46

epphoto
Membre
2010-11-24
24

Re: [Résolu] Problème lors de recherches approfondies

Je ne suis vraiment plus certain mais je dirai méthode manuelle.
En attendant de trouver une solution j'ai supprimé les tags de la recherche approfondie sur mon site, pour que les visiteurs ne rencontrent pas ce problème. Mais c'est beaucoup moins pratique.

Hors ligne

#8 2010-12-25 19:34:30

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] Problème lors de recherches approfondies

Bonjour,

Je suspecte une erreur lors du transfert de fichiers...


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#9 2010-12-25 21:50:39

epphoto
Membre
2010-11-24
24

Re: [Résolu] Problème lors de recherches approfondies

Bonjour.
Merci.
de quel transfert parlez vous, de quel fichier ?
puis je trouver une solution à mon problème ?

Hors ligne

#10 2010-12-26 16:16:26

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] Problème lors de recherches approfondies

Il faudrait connaître la date de l'installation de votre galerie ainsi que la date de la découverte du dysfonctionnement. Par la même occasion, est-ce que le problème est subitement arrivé un beau matin ou bien le problème a toujours été constaté ?


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#11 2011-01-02 16:48:12

epphoto
Membre
2010-11-24
24

Re: [Résolu] Problème lors de recherches approfondies

Bonjour.
pour la date d'installation, je n'en suis plus certain mais la plus part des fichiers sur mon site datent du 11/05/2010. la découverte du problème date de mon premier post le 17/12.
Je ne saurai dire si le problème a toujours existé, je ne pense pas. Mais ne pourrais en être certain puisque le problème vient uniquement dans un cas particulier de recherche d'un mot plus de tag coché.
je ne saurai plus dire si cela fonctionnait avant ou si j'ai découvert le problème par hasard.

Hors ligne

#12 2011-01-03 10:59:25

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] Problème lors de recherches approfondies

Je viens de procédé à une recherche toute simple sur votre galerie via le formulaire search.php

J'observe (voir PJ) une erreur avec le fichier search.php
Je préconise de remplacer le fichier qui se trouve sur votre serveur par un fichier "propre" (Lien).


Images attachées


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#13 2011-01-05 20:54:08

epphoto
Membre
2010-11-24
24

Re: [Résolu] Problème lors de recherches approfondies

Bonsoir.

En remplaçant le fichier search/php avec celui en lien, j'obtiens cette erreur :

Fatal error: Call to undefined function pwg_db_real_escape_string() in /homepages/41/d279872492/htdocs/search.php on line 42

J'ai donc remis l'ancien fichier search pour l'instant.
J'ai effectivement depuis toujours constaté un message tel que vous me l'indiquiez lors des recherches mais sans avoir le temps de le lire puisque immédiatement après, les réponses à la recherche apparaissent sans problème.

Hors ligne

#14 2011-01-05 21:11:24

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] Problème lors de recherches approfondies

Ok je reproduis sur ma galerie aussi le même problème sur la page search.php

J'en avise le reste de l'équipe.


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#15 2011-01-05 21:35:26

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12269

Re: [Résolu] Problème lors de recherches approfondies

Bonsoir epphoto, très chouette galerie au passage :-)

A noter que tu utilises Piwigo 2.0 et non Piwigo 2.1 ce qui explique l'erreur sur pwg_db_real_escape_string.

epphoto a écrit:

Mais si je tape du texte plus coche des tags, j'ai des réponses mais lorsque je clique sur la miniature pour voir la photo voilà ce qui s'affiche :

Notice: Undefined offset: 0 in /homepages/41/d279872492/htdocs/picture.php on line 203

Je ne reproduis pas ce problème sur Piwigo 2.1, j'ai lancé une recherche sur le mot "mother" avec le tag "woman", j'ai 2 résultats et aucun message d'erreur.

Sur ta galerie, est-ce que tu reproduis le problème systématiquement avec le champ libre + tags, ou ça dépend du champ libre et des tags ?


Dernier billet du blog Piwigo.com (9 novembre 2018) Pourquoi Flickr (re)devient payant

Hors ligne

  •  » Utilisation
  •  » [Résolu] Problème lors de recherches approfondies

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact