•  » Outils
  •  » ploader et openSUSE

#1 2010-11-13 10:31:27

jdd
Membre
Toulouse
2009-12-20
374

ploader et openSUSE

Bonjour,

Jusqu'à présent, j'utilise le ftp pour charger ma galerie et ca marche bien, mais à quelques détails près.

Je voudrais donc essayer ploader, mais lui ne veut pas marcher.

Comme d'habitude, il n'y a aucune doc. Je vous propose donc, si vous êtes d'accord pour m'aider, de faire marcher ploader et de documenter l'installation et le fonctionnement, d'abord sur mon propre site (brouillon) puis ici même.

Si vous placez ce type de document en tête du forum, ca devrait arranger pas mal de gens.

qu'en pensez-vous? Par quelle version faut-il commencer (je n'ai essayé que la version 1.5 - dans le temps j'avais réussi à faire marcher une version 2.xx, mais je ne sais plus comment :-()

merci
jdd

Hors ligne

#2 2010-11-13 10:59:15

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: ploader et openSUSE

Pas de documentation comme d'habitude ?!

Excusez-moi mais là je vois rouge.
Regardez donc le haut de page de toutes les pages du site piwigo.org
N'y a t-il pas un lien vers "Docs" pointant vers le [wiki] et que trouves t-on sur la première page ??? Un lien pointant vers pLoader.

...


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#3 2010-11-13 11:36:00

jdd
Membre
Toulouse
2009-12-20
374

Re: ploader et openSUSE

oui, mais rien d'utile, en fait. Et comment se fait-il qu'un minimum de doc ne soit pas dans l'archive du programme?

je n'ai pas ubuntu, et d'ailleurs ubuntu en est à 10.4, et ploader s'arrète à 9.10. La doc dit "voici une copie, valable pour la version 2.0.7" et ploader a changé de numérotation depuis je ne sais quand (il est à 1.6??).

Quand à jiwigo, je ai trouvé aucune doc sur l'installation.

vu que ces outils sont semble-t-il maintenant la méthode privilégiée pour la mise en place des images, il serait bien que la doc soit à jour.

Je suis un peu trop occupé dans d'autres projets pour vous aider autant que je le voudrais, mais c'est vrai que le wiki piwigo est à la ramasse (heureusement que le forum est très actif). Je vous propose quand même d'améliorer les choses, si vous ne voulez pas, tant pis.

Ce n'est pas vraiment un reproche, chacun fait ce qu'il peut, mais la recherche des réponses est une vrai galère

jdd

Hors ligne

#4 2010-11-13 12:01:46

jdd
Membre
Toulouse
2009-12-20
374

Re: ploader et openSUSE

"La doc est dans Piwigo (rubrique Liens / instructions"

je ne trouve plus cette rubrique, elle a disparu ou je n'ai pas les yeux en face des trous (je m'en souviens de cette rubrique!)

merci
jdd

Hors ligne

#5 2010-11-13 12:08:24

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14752

Re: ploader et openSUSE

le wiki est ouvert bienvenue pour améliorer tout cela ;-)


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#6 2010-11-13 13:27:09

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12358

Re: ploader et openSUSE

Avant pLoader 1.5, on avait un guide d'utilisation. Mais on a fait des changements dans pLoader pour rendre cette documentation inutile : le logiciel ne laisse pas l'utilisateur dans le doute. C'est sans doute perfectible mais c'est l'objectif car il faut comprendre que seule une toute petite minorité des gens lit les documentations, donc il faut que le logiciel soit suffisamment intuitif pour s'utiliser sans documentation.

De même, le formulaire d'upload web n'est documenté nulle part et nous n'avons pas spécialement de retour sur la nécessité d'une documentation : l'utilisateur ne peut pas se tromper (et si c'est le cas, alors il faut améliorer l'interface utilisateur, pas écrire une documentation).

jdd a écrit:

"La doc est dans Piwigo (rubrique Liens / instructions"

je ne trouve plus cette rubrique, elle a disparu ou je n'ai pas les yeux en face des trous (je m'en souviens de cette rubrique!)

Administration > A l'aide (en haute à droite)


Dernier billet du blog Piwigo.com (20 juin 2019) Modus, nouveau thème par défaut sur Piwigo.com

Hors ligne

#7 2010-11-13 13:31:32

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12358

Re: ploader et openSUSE

jdd a écrit:

Je vous propose donc, si vous êtes d'accord pour m'aider, de faire marcher ploader et de documenter l'installation et le fonctionnement, d'abord sur mon propre site (brouillon) puis ici même.

documenter l'installation, notamment pour les distributions Linux, ça oui c'est utile. A noter que pour Linux, la meilleure méthode est décrite sur [Forum, topic 16806] Installer pLoader sous linux 64bits (et autres ?), c'est orienté 64bits, mais en fait c'est une méthode universelle bien plus compatible que l'utilisation des binaires qui sont en effet compilés avec Ubuntu 9.10 au mieux.

Evidemment, on est d'accord pour t'aider :-)


Dernier billet du blog Piwigo.com (20 juin 2019) Modus, nouveau thème par défaut sur Piwigo.com

Hors ligne

#8 2010-11-13 14:11:45

jdd
Membre
Toulouse
2009-12-20
374

Re: ploader et openSUSE

plg a écrit:

Administration > A l'aide (en haute à droite)

oui, mais là on me dit téléchargez, installez, utilisez... mais quand j'ai téléchargé le tgz, je ne suis pas plus avancé :-(.

J'ai des soucis de dépendances en chaine, il me faut un peu de temps...

Hors ligne

#9 2010-11-16 20:30:58

jdd
Membre
Toulouse
2009-12-20
374

Re: ploader et openSUSE

Bon, on avance.

Je vous donne une copie de ce que je viens d'écrire sur un forum openSUSE:

Bonjour,

Je voudrais utiliser le logiciel pLoader, fourni par l'équipe de Piwigo, la galerie photo libre et programmée par des français que j'utilise (http://dodin.org/piwigo/index.php).

pLoader sert à envoyer les photos vers la galerie. C'est un moyen parmis d'autres, mais il marche du premier coup sous Windows (:-() *et* sous ubuntu - je viens de le tester sur la 10.04 LTS, ou il marche du premier coup, sans aucun ajout.

En fait c'est un problème de version de librairies.
Il demande---------------j'ai
libpng12----------------pas sur
libtiff.so.4---------------la version 3
libMagicCore (et Wand).so.2 et on a .3!

Je vais voir avec l'auteur si il peut être un peu moins précis sur les dépendances, mais comment peut-on avoir des versions un peu différentes de libs, et qui marchent?

J'ai essayé de faire un lien symbolique, ca permet de faire marcher le programme, mais il segfault dès qu'on le fait travailler sur les graphiques.

Donc ma première question serait: est-il possible d'avoir une version qui soit un peu moins sensible à la version de la librairie?  J'ai réussi en faisant des liens symboliques pour tromper pLoader à le lancer, à sélectionner une photo, mais bien sûr, dès qu'on lance le traitement graphique ca plante.

merci
jdd
merci

Hors ligne

#10 2010-11-16 20:42:52

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12358

Re: ploader et openSUSE

jdd, les problèmes de version de librairie, c'est avec la version binaire ou avec la version source que tu les rencontres ?


Dernier billet du blog Piwigo.com (20 juin 2019) Modus, nouveau thème par défaut sur Piwigo.com

Hors ligne

#11 2010-11-16 22:10:37

jdd
Membre
Toulouse
2009-12-20
374

Re: ploader et openSUSE

plg a écrit:

jdd, les problèmes de version de librairie, c'est avec la version binaire ou avec la version source que tu les rencontres ?

avec la version binaire pour ubuntu, j'ai pas encore essayé l'autre

merci

Hors ligne

#12 2010-11-16 22:18:54

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12358

Re: ploader et openSUSE

jdd a écrit:

avec la version binaire pour ubuntu, j'ai pas encore essayé l'autre

Alors en effet c'est normal. Abandonnes l'idée de faire tourner la version binaire sur une plateforme pour laquelle cela n'a pas été compilé. Je recommande très très fortement l'utilisation de la version source qui est beaucoup plus compatible.


Dernier billet du blog Piwigo.com (20 juin 2019) Modus, nouveau thème par défaut sur Piwigo.com

Hors ligne

#13 2010-11-16 22:34:56

jdd
Membre
Toulouse
2009-12-20
374

Re: ploader et openSUSE

plg a écrit:

jdd a écrit:

avec la version binaire pour ubuntu, j'ai pas encore essayé l'autre

Alors en effet c'est normal. Abandonnes l'idée de faire tourner la version binaire sur une plateforme pour laquelle cela n'a pas été compilé. Je recommande très très fortement l'utilisation de la version source qui est beaucoup plus compatible.

oui, mais où je trouve l'environnement de développement pour Linux? car là il me manque plein de routines perl et quand on en installe une il en manque une autre :-(

Hors ligne

#14 2010-11-16 22:41:50

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12358

Re: ploader et openSUSE

jdd a écrit:

oui, mais où je trouve l'environnement de développement pour Linux?

Je ne sais pas comment fonctionne openSUSE par rapport aux modules Perl. Je connais beaucoup mieux Debian et sa dérivée Ubuntu. Un grand nombre de modules Perl sont disponibles sous forme de paquets Debian. Clément en a fait une liste sur [Forum, topic 16806] Installer pLoader sous linux 64bits (et autres ?)

libwx-perl-processstream-perl
libfile-slurp-perl
libfile-homedir-perl
libjson-perl
libdigest-md5-file-perl
libimage-exiftool-perl
perlmagick
libcrypt-cbc-perl
libcrypt-des-perl
libclass-accessor-perl

En prenant l'hypothèse qu'openSUSE package les modules Perl de façon plus ou moins équivalent, il faut trouver les paquets openSUSE qui correspondent à ces paquets Debian.

jdd a écrit:

[...] car là il me manque plein de routines perl et quand on en installe une il en manque une autre :-(

C'est normal et c'est la façon que Clément a probablement utilisé pour déterminer la liste des modules Debian à installer. En lisant le message d'erreur  "missing library ..." puis en cherchant dans les paquets Debian le module Perl correspondant il a établi la liste des paquets Debian qui permet d'utiliser pLoader sans erreur. C'est un peu pénible, mais une fois cette recherche réalisée, tous les utilisateurs d'openSUSE en profitent.


Dernier billet du blog Piwigo.com (20 juin 2019) Modus, nouveau thème par défaut sur Piwigo.com

Hors ligne

#15 2010-11-16 23:15:23

jdd
Membre
Toulouse
2009-12-20
374

Re: ploader et openSUSE

Bon, j'avance peut-être... je ne suis pas sur.

En fait il y a deux problèmes: certaines librairies ne sont pas les mêmes et le poste sur lequel je suis est un 64 bits, ca ne doit pas faciliter les choses :-(

en effet j'ai entrepris deux choses:

* recopier d'ubuntu vers openSUSE les librairies qui manquent (mais mon ubuntu est 32 bits)
* mettre des liens pour certaines librairies très proches (un 0.1.0.5 et un 0.1.5)

du coup ploader se lance et fait une partie de traitement. Le téléchargement que j'ai tenté a été interompu, il est trop tard ce soir pour que je regarde pourquoi :-))

Hors ligne

  •  » Outils
  •  » ploader et openSUSE

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact