•  » Utilisation
  •  » [Résolu] dysfonctionnement de lien interne dans bloc principal

#1 2010-05-31 10:07:35

himbas
Membre
Andernos
2010-05-30
7

[Résolu] dysfonctionnement de lien interne dans bloc principal

Bonjour,
Je suis novice dans l'utilisation de Piwigo je n'ai donc pas tous les prérequis. Je bute sur un problème de lien.
Le lien accueil situé dans la bloc principal m'envoie sur index of .... (répertoire où est stocké piwigo) au lieu de pointer directement sur index.php.
Pourtant ce lien fonctionne par ailleurs puisque je peux lancer l'application qui passe obligatoirement par cet index.php. Les liens categorie fonctionnent très bien.
Ce dysfonctionnement est apparu depuis la mise à jour automatique de 2.09 vers 211 (quel que soit le thème).
Merci pour vos conseils.

Hors ligne

#2 2010-05-31 10:10:33

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] dysfonctionnement de lien interne dans bloc principal

Auriez-vous des templates-extension ?

Sinon, un lien nous permettrait de mieux observer le phénomène ;-)


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#3 2010-05-31 10:35:49

himbas
Membre
Andernos
2010-05-30
7

Re: [Résolu] dysfonctionnement de lien interne dans bloc principal

Merci pour ta réponse rapide.
J'avais initialement des templates-extensions avec la version 209 mais avec 211 il s'agit de thèmes.
Je t'envoie le lien par courriel.

Hors ligne

#4 2010-05-31 14:28:53

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] dysfonctionnement de lien interne dans bloc principal

Ok vu.
Seulement je ne suis pas assez bon pour savoir comment y remédier. Nicolas devrait être plus doué que moi avec ce problème.

Je pense deviner que c'est le serveur qui ne sait pas rediriger vers la page "index.php" par défaut lorsqu'on explore le dossier.

Je le préviens d'intervenir :-)


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#5 2010-05-31 14:41:25

nicolas
Former Piwigo Team
2004-12-30
1526

Re: [Résolu] dysfonctionnement de lien interne dans bloc principal

Est-ce un serveur dédié ? Avez-vous accès à la configuration d'apache ?
Dans un cas comme dans l'autre je vous conseille d'ajouter soit dans apache soit dans un fichier ".htaccess" les lignes suivantes :

Code:

Options -Indexes
DirectoryIndex index.php index.html

La première ligne demande à apache d'interdire de lister le contenu des répertoires
La deuxième ligne lui demande d'exécuter le fichier index.php s'il existe si une url se termine par un slash.


Donnez du peps à vos tags
Laissez vos visiteurs vous aidez à tagger vos images avec user_tags

Hors ligne

#6 2010-05-31 14:55:31

himbas
Membre
Andernos
2010-05-30
7

Re: [Résolu] dysfonctionnement de lien interne dans bloc principal

Cela fonctionne avec un .htaccess (DirectoryIndex index.php). Merci Gotcha et Nicolas pour vos conseils.

Hors ligne

#7 2010-05-31 15:06:03

laurent.duretz
Équipe Piwigo
22 France
2004-06-29
693

Re: [Résolu] dysfonctionnement de lien interne dans bloc principal

Cela est lié à
-> la conf du serveur
-> l'intégration de linkroot dans le code

Vous avez choisi de modifier la conf serveurs à travers le .htacces

Vous auriez pu configurer le paramètre home_page dans la configuration de piwigo


« Entre Ce que je pense, Ce que je veux dire, Ce que je crois dire, Ce que je dis, Ce que vous avez envie d'entendre, Ce que vous entendez, Ce que vous comprenez... il y a dix possibilités qu'on ait des difficultés à communiquer. Mais essayons quand même... »
[ Bernard Werber ]

Hors ligne

#8 2010-05-31 15:17:36

himbas
Membre
Andernos
2010-05-30
7

Re: [Résolu] dysfonctionnement de lien interne dans bloc principal

Pour laurent.duretz,

Effectivement la multiplication des .htaccess me gêne.  Comment modifier le home_page?
Merci pour la réponse.

Hors ligne

#9 2010-05-31 15:42:46

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] dysfonctionnement de lien interne dans bloc principal

himbas a écrit:

Comment modifier le home_page?

http://fr.piwigo.org/doc/doku.php?id=pw … onf_locale


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

  •  » Utilisation
  •  » [Résolu] dysfonctionnement de lien interne dans bloc principal

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact