•  » Outils
  •  » Installer pLoader sous linux 64bits (et autres ?)

#31 2012-08-04 13:51:50

iGor
Membre
2012-08-04
13

Re: Installer pLoader sous linux 64bits (et autres ?)

Bonjour et merci pour la réponse,

Il se trouve qu'avant de comprendre qu'il y avait incompatibilité entre ubuntu 12.04 64bits et pLoader, donc avant de suivre ce tutoriel d'installation, en fouillant, j'étais déjà tombé sur se conseil. Aussi, ce répertoire a déjà été supprimé sur mon poste.

Hors ligne

#32 2012-08-04 13:54:34

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12356

Re: Installer pLoader sous linux 64bits (et autres ?)

Mais... il n'y a pas d'incompatibilité. Je suis sur Ubuntu 12.04 et j'arrive à faire tourner pLoader 1.6 (bon là je n'ai pas cet environnement disponible, mais je suis quasiment sûr d'avoir testé depuis la mise à jour d'Ubuntu)


Dernier billet du blog Piwigo.com (20 juin 2019) Modus, nouveau thème par défaut sur Piwigo.com

Hors ligne

#33 2012-08-04 14:04:20

iGor
Membre
2012-08-04
13

Re: Installer pLoader sous linux 64bits (et autres ?)

Ah ben c'est une bonne nouvelle alors. Du coup je ne comprends pas bien la raison de ce topic/tutoriel...

Parce que si j'utilise le paquet dans les dépôts (1.6), que je démarre en console, alors j'ai :

Code:

Gtk-Message: Failed to load module "pk-gtk-module"
Byte order is not compatible at /usr/lib/perl/5.14/Storable.pm line 379.
Byte order is not compatible at /usr/lib/perl/5.14/Storable.pm line 379, at /usr/share/perl5/Uploader/GUI/wxApp.pm line 218
Byte order is not compatible at /usr/lib/perl/5.14/Storable.pm line 379, at /usr/share/perl5/Uploader/GUI/wxApp.pm line 218

D'autant que j'aimerais bien pouvoir utiliser la version 2.0.7c qui me convenait bien, mais que je n'ai pas réussi à démarrer, que ce soit en suivant ce tutoriel ou avec l'installation précédente.

Hors ligne

#34 2012-08-04 14:05:26

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12356

Re: Installer pLoader sous linux 64bits (et autres ?)

hum... je n'utilise pas le paquet, j'utilise pLoader à partir des sources.


Dernier billet du blog Piwigo.com (20 juin 2019) Modus, nouveau thème par défaut sur Piwigo.com

Hors ligne

#35 2012-08-04 14:15:33

iGor
Membre
2012-08-04
13

Re: Installer pLoader sous linux 64bits (et autres ?)

Alors on revient au message d'erreur que j'ai signalé plus haut :

Code:

perl ploader.pl 
Gtk-Message: Failed to load module "pk-gtk-module"
Byte order is not compatible at /usr/lib/perl/5.14/Storable.pm line 379.
Byte order is not compatible at /usr/lib/perl/5.14/Storable.pm line 379, at /usr/share/perl5/Uploader/GUI/wxApp.pm line 218
Byte order is not compatible at /usr/lib/perl/5.14/Storable.pm line 379, at /usr/share/perl5/Uploader/GUI/wxApp.pm line 218

Hors ligne

#36 2012-08-04 14:56:31

iGor
Membre
2012-08-04
13

Re: Installer pLoader sous linux 64bits (et autres ?)

Pour finir j'ai installé le plugin qui me permet d'uploader les images via shotwell.

Merci pour le travail autour de piwigo :)

Hors ligne

#37 2012-08-04 15:46:57

iGor
Membre
2012-08-04
13

Re: Installer pLoader sous linux 64bits (et autres ?)

Il se trouve que la version de pLoader dans les dépôts fonctionne bien sous Ubuntu 12.04 32bits. La version 2.0.7c par contre, ce n'est pas le cas.
Tout cela m'ennuie, parce que shotwell ne gère pas très bien l'orientation des photos en portrait, alors que pLoader fait ça très bien...

Hors ligne

#38 2012-08-06 10:29:44

Vin100
Invité

Re: Installer pLoader sous linux 64bits (et autres ?)

Je suis désolé, mais quand on est newbie  sur Linux, le tuto est incompréhensible
Je suis sous 64 bit et  Voyageur 12.04 et je n'arrive pas à installer Ploader
Quelqu'un pourrait faire quelque chose pour les nuls? Siouplait.

#39 2012-10-09 22:55:35

Clément
Membre
Lyon
2010-01-11
35

Re: Installer pLoader sous linux 64bits (et autres ?)

iGor a écrit:

Ah ben c'est une bonne nouvelle alors. Du coup je ne comprends pas bien la raison de ce topic/tutoriel...

Il n'y a pas toujours eu de dépôt et à l'origine il n'y avait pas de version compilée pour les systèmes 64bits.

Vin100 a écrit:

Je suis désolé, mais quand on est newbie  sur Linux, le tuto est incompréhensible
Je suis sous 64 bit et  Voyageur 12.04 et je n'arrive pas à installer Ploader
Quelqu'un pourrait faire quelque chose pour les nuls? Siouplait.

Ce tutoriel n'est plus à jour. Je le referai peut-être un jour.

Il n'y a en fait rien de compliquer. Il suffit simplement de copier les lignes qui ne sont pas en gras pour les coller dans un terminal. Il n'y a même pas besoin de comprendre ce que l'on fait :)

Le principe de ce tutoriel est commun à toutes les versions de Debian et dérivées (Ubuntu), par contre la fin est obsolète pour nombre de distributions, notamment les principales depuis le passage à GNOME 3.

Hors ligne

#40 2012-11-17 21:53:11

djiit
Invité

Re: Installer pLoader sous linux 64bits (et autres ?)

Je confirme, le paquet comme les sources sous ubuntu 12.04 64 bits ne fonctionnent pas (alors que cela marche très bien en 32 bits).

Systématiquement, cette erreur apparait :

Long integer size is not compatible at /usr/local/lib/perl/5.14.2/Storable.pm line 380.
Long integer size is not compatible at /usr/local/lib/perl/5.14.2/Storable.pm line 380, at Uploader/GUI/wxApp.pm line 218
Long integer size is not compatible at /usr/local/lib/perl/5.14.2/Storable.pm line 380, at Uploader/GUI/wxApp.pm line 218

J'ai essayé différents trucs cpan Wx ... ou autre mais rien n'y fait...

Le message de longueur d'entier est surement dû au longueurs différentes entre 32 et 64 bits....

Si quelqu'un a une idée, je suis preneur...

#41 2013-04-06 12:03:35

iGor
Membre
2012-08-04
13

Re: Installer pLoader sous linux 64bits (et autres ?)

Personnellement ça m'ennuie beaucoup de ne pas pouvoir utiliser pLoader sur mon Ubuntu 12.10, parce que c'est l'outil qui me convenait le mieux pour uploader mes photos.

Du coup, je ne mets plus à jour piwigo depuis quelques mois. C'est dommage me semble-t-il.

J'ai essayé d'installer depuis les dépôts Ubuntu, depuis le paquets à télécharger, depuis les sources. Rien n'y fait. J'ai beau tout désinstaller, purger, et réinstaller, rien n'y fait non plus.

Je viens d'installer ploader sur une debian wheezy, par synaptic. C'est la version 1.6.0-1.1, qui vient du dépôt testing/main. Cette debian est aussi une 64bits. pLoader fonctionne parfaitement bien.

Et sous Ubuntu 12.10, c'est la même version de pLoader, mais au démarrage j'ai toujours l'erreur suivante :

Code:

igor@asus:~$ ploader
Byte order is not compatible at /usr/lib/perl/5.14/Storable.pm line 379.
Byte order is not compatible at /usr/lib/perl/5.14/Storable.pm line 379, at /usr/share/perl5/Uploader/GUI/wxApp.pm line 218
Byte order is not compatible at /usr/lib/perl/5.14/Storable.pm line 379, at /usr/share/perl5/Uploader/GUI/wxApp.pm line 218

Au passage, pour la question de la rotation des images, depuis que j'utilise rapid-photo-downloader, je n'ai plus ce souci, puisque ce logiciel (contrairement à shotwell par exemple) dispose les photos dans le bon sens, et inscrit l'information dans les métadonnées.

Reste que si je parvenais à utiliser pLoader sur mon poste principal, ce serait quand même mieux :)

Hors ligne

#42 2013-04-06 19:49:24

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12356

Re: Installer pLoader sous linux 64bits (et autres ?)

iGor a écrit:

Byte order is not compatible at /usr/lib/perl/5.14/Storable.pm line 379.

C'est le fichier de cache de pLoader qui est corrompu. Supprime ton $HOME/.ploader (ou .pLoader je ne sais plus)


Dernier billet du blog Piwigo.com (20 juin 2019) Modus, nouveau thème par défaut sur Piwigo.com

Hors ligne

#43 2013-04-06 19:58:53

iGor
Membre
2012-08-04
13

Re: Installer pLoader sous linux 64bits (et autres ?)

Merci beaucoup pour cette réponse, c'est en effet ça.

Le répertoire est en fait : $HOME/.local/share/.pLoader
Mais c'est bien ça le problème.

Tout ça pour ça. Désolé et encore merci.

Hors ligne

#44 2015-06-07 10:07:55

odpf
Membre
2010-02-24
20

Re: Installer pLoader sous linux 64bits (et autres ?)

Bonjour,

Après une nouvelle réinstallation (je suis désormais sous Xubuntu 15.04), j'essaie de réinstaller ploader en 64 bits.
J'ai donc suivi le tuto.

Quand en console je lance ploader.pl, j'obtiens

read_file '../bin/properties.ini' - sysopen: Aucun fichier ou dossier de ce type at Uploader/GUI/wxApp.pm line 964.
Can't locate object method "ParseDate" via package "Wx::DateTime" at Uploader/GUI/DlgCommon.pm line 253.

Pour la première info : j'ai copié properties.ini qui était dans /src dans /bin
Pour la 2ème, je suis dépassé !

Merci d'avance

Hors ligne

#45 2016-12-15 22:32:40

skeroy
Membre
2012-02-02
12

Re: Installer pLoader sous linux 64bits (et autres ?)

Pour la deuxième j'ai remplacé le code autour de l'erreur par

Code:

    'Wx::DatePickerCtrl' => sub { my ($ctrl, $value ) = @_;
                                  my $date = Wx::DateTime->new;
                                  my ($yyyy, $mm, $dd, $hh, $mi, $ss ) = split(/[:\/\\\-\.\s]/, $value);
                                      $date->SetToCurrent;

                                  $ctrl->SetValue($date);

Pour le moment ça fonctionne je n'ai rien remarqué

Hors ligne

  •  » Outils
  •  » Installer pLoader sous linux 64bits (et autres ?)

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact