Annonce

#1 2010-01-06 00:08:41

Djum
Membre
Date d'inscription: 2010-01-05
Messages: 10

[Résolu] Installation 2.0.7 (en local) : écran blanc.

[EDIT]
Une solution à était trouvée. Voir : [Forum, post 133133 by cram51 in topic 16746] Installation 2.0.7 (en local) : écran blanc.
[/EDIT]
**********************************************


Bonjour,

Je viens de découvrir piwigo et je suis bloqué à l'installation.
Je précise que je l'installe sur un serveur personnel, j'ai donc accès à tout.

Dans l'écran d'installation où l'on saisi la "configuration de base", la "configuration de base de données" et la "Configuration du compte Administrateur", je saisis tous les champs avec :

Langue : Français

Hôte MySql : localhost
Utilisateur : root
Mot de passe : <celui de root qui fonctionne à coup sûr>
Nom de la base : piwigo (que j'ai crée)
Préfixe des noms de table : piwigo_

Administrateur : admin
Mot de passe : <un mot de passe>
Mot de passe [ Confirmer ] : <le même que précédemment et pas celui de la base, celui d'admin>
Email : <une adresse syntaxiquement valide>

Je clique ensuite sur "Démarrer l'installation" et je tombe aussitôt sur un écran blanc, sans contenu html, sans message d'erreur.

Infos techniques du serveur sur lequel j'essaie d'installer :
Debian 5.0.3
Apache 2
Php 5
MySql 5

Hors ligne

#2 2010-01-06 00:19:06

ddtddt
Équipe Piwigo
Lieu: Quetigny (21) - France
Date d'inscription: 2007-07-27
Messages: 12398

Re: [Résolu] Installation 2.0.7 (en local) : écran blanc.

As tu essayé de re transférer les fichier pour éliminer l'erreur de transfert FTP


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2010-01-06 13:24:21

Djum
Membre
Date d'inscription: 2010-01-05
Messages: 10

Re: [Résolu] Installation 2.0.7 (en local) : écran blanc.

La première fois, j'avais fait une netInstall.
Je viens de recommencer en téléchargeant l'archive et j'obtiens le même résultat.
Ce qui est bizarre, c'est que quelles que soient les informations saisies (même sans infos)  dans l'écran d'installation, le résultat est le même.

Hors ligne

#4 2010-01-06 16:14:21

ddtddt
Équipe Piwigo
Lieu: Quetigny (21) - France
Date d'inscription: 2007-07-27
Messages: 12398

Re: [Résolu] Installation 2.0.7 (en local) : écran blanc.

C'est en local ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#5 2010-01-06 22:04:38

Djum
Membre
Date d'inscription: 2010-01-05
Messages: 10

Re: [Résolu] Installation 2.0.7 (en local) : écran blanc.

Non.
Pour rentrer dans les détails :
- piwigo est installé dans une machine virtuelle sous Debian.
- j'accède à la page de configuration depuis mon pc (qui n'est pas l'hôte de la VM) sous firefox (ie = même résultat).
- je n'ai pas (et ne veux pas) d'environnement graphique sur la machine (virtuelle donc) où est installé piwigo.

Hors ligne

#6 2010-01-06 23:22:10

ddtddt
Équipe Piwigo
Lieu: Quetigny (21) - France
Date d'inscription: 2007-07-27
Messages: 12398

Re: [Résolu] Installation 2.0.7 (en local) : écran blanc.

Djum a écrit:

Non.

Donc tu peux me donner un lien en MP ? de ton install piwigo


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#7 2010-01-07 00:02:13

Djum
Membre
Date d'inscription: 2010-01-05
Messages: 10

Re: [Résolu] Installation 2.0.7 (en local) : écran blanc.

C'est fait.

Hors ligne

#8 2010-01-07 13:07:30

nicolas
Former Piwigo Team
Date d'inscription: 2004-12-30
Messages: 1489
Site web

Re: [Résolu] Installation 2.0.7 (en local) : écran blanc.

Connais-tu un peu debian ? As-tu regardé les logs d'apache (fichier d'erreurs) ?


Donnez du peps à vos tags
Laissez vos visiteurs vous aidez à tagger vos images avec user_tags

Hors ligne

#9 2010-01-07 13:38:15

Djum
Membre
Date d'inscription: 2010-01-05
Messages: 10

Re: [Résolu] Installation 2.0.7 (en local) : écran blanc.

Oui, on va dire que je connais plutôt bien. Si je suis venu ici, c'est que je ne comprends vraiment pas ce qui se passe. Quand je valide le formulaire d'install, voici la log apache qui correspond :

"POST /piwigo/install.php?language=fr_FR HTTP/1.1" 200 - "http://url.de.mon.site/piwigo/install.php" "Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.16) Gecko/2009120208 Firefox/3.0.16 GTB6 (.NET CLR 3.5.30729)"

Code 200 ok et pourtant, rien a l'écran.

Hors ligne

#10 2010-01-07 14:10:55

nicolas
Former Piwigo Team
Date d'inscription: 2004-12-30
Messages: 1489
Site web

Re: [Résolu] Installation 2.0.7 (en local) : écran blanc.

Est-ce que les tables sont créées ?


Donnez du peps à vos tags
Laissez vos visiteurs vous aidez à tagger vos images avec user_tags

Hors ligne

#11 2010-01-07 14:47:12

Djum
Membre
Date d'inscription: 2010-01-05
Messages: 10

Re: [Résolu] Installation 2.0.7 (en local) : écran blanc.

Non :

mysql> use piwigo
Database changed
mysql> show tables;
Empty set (0.01 sec)

Hors ligne

#12 2010-01-07 14:52:56

Gotcha
Equipe Piwigo, Modérateur
Lieu: Pierrelatte (26)
Date d'inscription: 2007-03-14
Messages: 13265
Site web

Re: [Résolu] Installation 2.0.7 (en local) : écran blanc.

Je risque de passer pour un neuneu mais est-ce que la BDD est créée ?
Piwigo créera des tables dans une base de données mais il lui la trouver avant.


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#13 2010-01-07 15:22:51

nicolas
Former Piwigo Team
Date d'inscription: 2004-12-30
Messages: 1489
Site web

Re: [Résolu] Installation 2.0.7 (en local) : écran blanc.

Donc l'installation échoue. Quel est le niveau d'erreur de php (à trouver dans phpinfo) ?
As-tu regarder le fichier d'erreur d'apache : tailf /var/log/apache2/error_log ?


Donnez du peps à vos tags
Laissez vos visiteurs vous aidez à tagger vos images avec user_tags

Hors ligne

#14 2010-01-07 15:45:18

Djum
Membre
Date d'inscription: 2010-01-05
Messages: 10

Re: [Résolu] Installation 2.0.7 (en local) : écran blanc.

Je ne maîtrise pas bien php par contre, voici donc ce que je trouve au niveau de phpinfo() concernant les erreurs :

display_errors    On    On
display_startup_errors    Off    Off
error_append_string    no value    no value
error_log    no value    no value
error_prepend_string    no value    no value
error_reporting    6135    6135
html_errors    On    On
ignore_repeated_errors    Off    Off
ignore_repeated_source    Off    Off
log_errors    Off    Off
log_errors_max_len    1024    1024

De quelle variable en particulier voudrais-tu connaître la valeur ?

Concernant Apache, les erreurs sont les suivantes (sans impact à mon avis) :
File does not exist: /var/www/piwigo/template-common/local-layout.css
File does not exist: /var/www/piwigo/admin/template/roma (oui, elle est bizarre celle là).
File does not exist: /var/www/favicon.ico

Hors ligne

#15 2010-01-09 11:34:38

Djum
Membre
Date d'inscription: 2010-01-05
Messages: 10

Re: [Résolu] Installation 2.0.7 (en local) : écran blanc.

Je vais tenter de réinstaller le système complet. Je vous tiens au courant.

Hors ligne

Pied de page des forums

Propulsé par FluxBB

twitter facebook google+ newsletter Faire un don Piwigo.org © 2002-2014 · Contact