•  » Plugins
  •  » le Plugin Piclens trebuche sur pwg_high

#1 2009-10-19 10:52:55

grodid
Membre
2009-09-16
98

le Plugin Piclens trebuche sur pwg_high

Bonjour,

Je suis sous Piwigo 2.0.5 sur Vista, et j'ai un petit souci avec le plugin CoolIris/Piclens (0.4.1)
pour lequel je n'utilise que la partie Piclens (cad SANS le mur 3D) : si l'une au moins des photos
de la categorie a ete transferee avec la photo d'origine (cad qu'il y a une image associee
dans le dossier pwg_high), la vue speciale Piclens s'ouvre dans la page du client, mais
aucune photo (ni aucune miniature d'ailleurs) n'apparait.

Ce pb ne depend pas du navigateur utilise, AMHA.

Je n'ai trouve aucun post/topic dans le forum mentionnant ce pb, ce qui me surprend.

Votre avis ?

Merci d'avance,   G.

Hors ligne

#2 2009-10-19 11:38:47

tiico
Membre
Yvelines
2007-05-29
337

Re: le Plugin Piclens trebuche sur pwg_high

grodid a écrit:

Bonjour,

Je suis sous Piwigo 2.0.5 sur Vista, et j'ai un petit souci avec le plugin CoolIris/Piclens (0.4.1)
pour lequel je n'utilise que la partie Piclens (cad SANS le mur 3D) : si l'une au moins des photos
de la categorie a ete transferee avec la photo d'origine (cad qu'il y a une image associee
dans le dossier pwg_high), la vue speciale Piclens s'ouvre dans la page du client, mais
aucune photo (ni aucune miniature d'ailleurs) n'apparait.

Ce pb ne depend pas du navigateur utilise, AMHA.

Je n'ai trouve aucun post/topic dans le forum mentionnant ce pb, ce qui me surprend.

Votre avis ?

Merci d'avance,   G.

Salut,

ton problème (non identifié à ce jour...), n'apparait que si une des images possède sa représentation High? si tu supprimes cette image "high", le problème n'apparait plus?
Peux-tu me donner, à défaut d'une URL (je pense que tu dois être en local), les paramètres que tu utilises (onglet 1 et 2). Ainsi que le détail du flux RSS généré?
Pour le flux RSS, il suffit de copier l'URL du client qui s'ouvre et de ne prendre que ce qui suite "feed="

Sans ces éléments, je ne vois pas d'ou peut provenir le pb.
@+
Tiico

Hors ligne

#3 2009-10-19 19:32:17

grodid
Membre
2009-09-16
98

Re: le Plugin Piclens trebuche sur pwg_high

tiico a écrit:

ton problème (non identifié à ce jour...), n'apparait que si une des images possède sa représentation High?

Une ou plusieurs images de la categorie.

tiico a écrit:

si tu supprimes cette image "high", le problème n'apparait plus?

Exactement, le probleme alors disparait.

Peux-tu me donner, à défaut d'une URL (je pense que tu dois être en local)

Sur ce site-la (embryonnaire) :  http://www.grodid.org
tu trouveras 3 categories utiles pour toi :
- tf1 : 10 images sans High
- th1 : 1 image avec high
- PiclensBug : la reunion des 2 precedentes

Piclens ne marche que sur la 1ere categorie (tf1).

les paramètres que tu utilises (onglet 1 et 2). Ainsi que le détail du flux RSS généré?
Pour le flux RSS, il suffit de copier l'URL du client qui s'ouvre et de ne prendre que ce qui suite "feed="

As-tu qd meme besoin de ces renseignements, stp ?

Merci,   G.

Hors ligne

#4 2009-10-19 19:46:13

francis6789
Membre
78 Les Mureaux
2008-09-30
59

Re: le Plugin Piclens trebuche sur pwg_high

Bonjour.

Depuis hier j'ai upgradé mon site de PWG 1.7 en Piwigo 2.05
Installation neuve sur serveur local, puis remplacement progressif des plugins, (dernière version).
Quand les problèmes apparents sont résolus upgrade de la base en cours 1.7 à la place de la nouvelle base Piwigo.

Je suis actuellement sur ces Forums pour essayer de résoudre les petits soucis qui restent, dont celui avec Piclens exactement le même problème déjà décrit.
Toutes mes photos sont high définition et plugin Download Multi.  Constat de l'anomalie tout le temps.
Ce n'est pas trop grave, mais ce qui est beaucoup plus gênant ce sont les erreurs de PHP enregistrées dans le fichier "php-error.log".

Sous Win XP SP3, Apache: 1.3.39, PHP 5.05, MySql: 5.051b.
Je n'utilise pas le block du mur 3D.

Voici les 2 lignes d'erreur par image affichée sur le mur défilant. Cela correspond à la high définition.

[19-Oct-2009 19:13:30] PHP Notice:  Undefined variable: user in d:\www\pwg\plugins\piclens\include\config_param.inc.php on line 30
[19-Oct-2009 19:13:30] PHP Notice:  Undefined variable: user in d:\www\pwg\plugins\piclens\include\config_param.inc.php on line 58

En 1 minute, le log passe de 100 Ko, taille habituelle au bout de 1 an, à 5 Mo, (pour ~30 photos). Les hébergeurs vont pas être content du tout.

J'espère que ces infos peuvent éclairées le chemin de la recherche.


Si c'est simple, ce n'est pas compliqué. Plus c'est simple, et plus c'est compliqué.

Hors ligne

#5 2009-10-19 21:13:23

grodid
Membre
2009-09-16
98

Re: le Plugin Piclens trebuche sur pwg_high

@francis6789 :
Je confirme l'erreur PHP mentionnée : je n'avais pas remarqué qu'elle était liée à Piclens, honte à moi.

@Tiico : au cas où :
- les paramètres onglet 1 : Tout est coché, avec récursivité
- onglet 2 : Type de récursivité paramétré :         Standard
- le flux RSS : je ne vois pas où capturer l'URL en question, désolé ...

A+,  G.

Hors ligne

#6 2009-10-19 21:31:45

tiico
Membre
Yvelines
2007-05-29
337

Re: le Plugin Piclens trebuche sur pwg_high

Bonsoir Grodid et francis,

je pense que votre problème est le même (erreur de variable mal initialisée dans le code de piclens) et est normalement corrigé dans la version sur le dépot SVN.
Le bug 1165 (http://piwigo.org/bugs/view.php?id=1165) préalablement identifié est celui qui est identifié chez vous.
Normalement, avec le fichier sur le dépot (lien ne fonctionnant pas actuellement), ca doit corriger le pb.
Voici le fichier config_param.inc.php à placer dans le répertoire piclens/include et qui devrait corriger votre pb.

Cette correction fera parti de la version 0.4.2. Si vous avez des retours (si ca fonctionne ou pas), je suis preneur.

@+
Tiico

Dernière modification par tiico (2009-10-19 21:32:44)

Hors ligne

#7 2009-10-19 21:47:19

grodid
Membre
2009-09-16
98

Re: le Plugin Piclens trebuche sur pwg_high

Bonsoir Tiico,

Merci bcp pour la correction, c'est parfait.

Et bravo pour la vitesse d'intervention !

A+,    G.

Hors ligne

#8 2009-10-19 21:49:05

tiico
Membre
Yvelines
2007-05-29
337

Re: le Plugin Piclens trebuche sur pwg_high

grodid a écrit:

Bonsoir Tiico,

Merci bcp pour la correction, c'est parfait.

Et bravo pour la vitesse d'intervention !

A+,    G.

Salut,

content que la correction fonctionne. Pour la rapidité, merci, c'était facile, elle était déjà prête...
Je pense que la version 0.4.2 (corrigeant entre autre ce bug "officiellement") ne devrait pas tarder.
@+
Tiico

Hors ligne

#9 2009-10-19 22:57:55

francis6789
Membre
78 Les Mureaux
2008-09-30
59

Re: le Plugin Piclens trebuche sur pwg_high

Bonsoir et merci pour la réactivité.

Je testais la mise à jour de Batch Optimiser et je tarde un peu.
Mais le soucis était lié et aussi avec Dowlnload Multi. Il y a encore un truc qui cloche dans l'affichage high définition des images. Pas de main, pas d'affichage,  les droits = oui, téléchargement =oui.

Pour PHP:  Excellent ! C'est réglé.
Merci pour l'action efficace et rapide.


Si c'est simple, ce n'est pas compliqué. Plus c'est simple, et plus c'est compliqué.

Hors ligne

  •  » Plugins
  •  » le Plugin Piclens trebuche sur pwg_high

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact