Annonce

  •  » Plugins
  •  » [plugin] Mail_supervisor

#1 2009-10-11 02:47:47

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

[plugin] Mail_supervisor

Salut cljosse.

Je viens d'installer avec succès ton plugin sur une de mes galeries pour tester. Mais... As-tu prévu une doc ?

Il est vrai qu'il est tard (ou tôt, c'est selon ;-) ) mais j'avoue avoir du mal a en comprendre le fonctionnement. Par exemple :
- A quels types de mail s'applique le plugin ? Les mails de notifications ? Les NBM ? Les mails groupés ? Les 3 ?
- Ajouter un bloc texte dans l'entête : Ok mais le champ est juste assez grand pour contenir "Bonjour". C'est un peu léger pour un "bloc" non ?
- L'interface n'est pas très claire. A quoi correspondent "1W" et "2D" ?
- ...

Bref, ce serait bien d'avoir un peu d'info sur l'utilisation du plugin, non ?



Sinon, il y a un problème avec l'url de ton plugin dans le fichier maininc.php. Elle pointe sur http://piwigo.org/ext/ alors que tu devrais avoir :

Code:

Plugin URI: http://piwigo.org/ext/extension_view.php?eid=309

Cela va poser des problèmes pour les mises à jour.

Hors ligne

#2 2009-10-11 12:31:36

cljosse
Équipe Piwigo
2006-11-12
1167

Re: [plugin] Mail_supervisor

Eric a écrit:

Salut cljosse.Bref, ce serait bien d'avoir un peu d'info sur l'utilisation du plugin, non ?
.

Salut.
  Bien sur tout à fait d'accord avec toi, une doc est prévue mais patience...

en attendant:

Eric a écrit:

- A quels types de mail s'applique le plugin ? Les mails de notifications ? Les NBM ? Les mails groupés ? Les 3 ?

A tous les envoies qui utilise la fonction pwg_mail().

Eric a écrit:

-  Ajouter un bloc texte dans l'entête : Ok mais le champ est juste assez grand pour contenir "Bonjour". C'est un peu léger pour un "bloc" non ?

A utiliser Uniquement si la fonction n'est pas incluse dans dans include\functions_mail.inc.php

Eric a écrit:

-  - L'interface n'est pas très claire. A quoi correspondent "1W" et "2D" ?

1W pour date du premier mail envoyé + une semaine ;

2D pour date du premier spam (mise en quarantaine détecté)  + deux jours ;

M pour minute;
H pour heures;
S pour seconde;
W pour semaine


A+

Hors ligne

#3 2009-10-11 12:44:43

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [plugin] Mail_supervisor

Ok, je comprends un peu mieux maintenant. Merci !

cljosse a écrit:

Bien sur tout à fait d'accord avec toi, une doc est prévue mais patience...

;-)

Hors ligne

#4 2009-10-11 14:17:23

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [plugin] Mail_supervisor

Autre petit détail : Il faudrait que tu encodes tes fichiers en UTF8 sans BOM au lieu de ANSI. Cela t'évite de convertir les caractères accentués en code (é = é) et cela respecte l'encodage de tout Piwigo qui est en UTF8.



[Edit]
Voir aussi : Coding guidelines

Cela s'applique principalement à Piwigo mais je pense qu'il serait bon de s'en inspirer pour le codage des plugins.[/Edit]

Dernière modification par Eric (2009-10-11 14:23:52)

Hors ligne

#5 2009-10-14 12:58:26

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [plugin] Mail_supervisor

Suite à mise à jour du plugin vers la version 1.0.2a, il semble qu'il y ait des soucis de traduction et dans le format de date/heure sur les champs "free_depuis_le" (cf capture jointe).


Images attachées

Hors ligne

#6 2009-10-14 13:42:33

cljosse
Équipe Piwigo
2006-11-12
1167

Re: [plugin] Mail_supervisor

Eric a écrit:

Suite à mise à jour du plugin vers la version 1.0.2a, il semble qu'il y ait des soucis de traduction et dans le format de date/heure sur les champs "free_depuis_le" (cf capture jointe).

Effectivement.
  Je n'ai pas encore fait de traductions des messages.
   je devrais faire un test si les traductions existe...

A+

Hors ligne

#7 2009-10-14 17:37:55

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [plugin] Mail_supervisor

Je me suis mal exprimé, désolé. Ce que je voulais dire c'est que je suis en FR sur ma galerie et sur le panneau d'admin. La langue FR existe dans ton plugin mais les balises ne semblent pas interprétées.

Sur l'une de mes galeries, j'ai procédé en utilisant l'installation automatique. Aucune autre version du plugin n'était présente et c'est là que j'ai remarqué le pb.

Sur une autre galerie, j'avais déjà une version précédente (1.0.1) du plugin. J'ai fait l'update auto et là, je n'ai pas ce pb.

J'ai vérifié sur mon site qui montre le problème de traduction si tous les fichiers du plugin étaient bien là : RAS.

Bizarre...

Hors ligne

#8 2009-10-14 18:28:42

cljosse
Équipe Piwigo
2006-11-12
1167

Re: [plugin] Mail_supervisor

Eric a écrit:

Sur une autre galerie, j'avais déjà une version précédente (1.0.1) du plugin. J'ai fait l'update auto et là, je n'ai pas ce pb.

J'ai vérifié sur mon site qui montre le problème de traduction si tous les fichiers du plugin étaient bien là : RAS.

Bizarre...

Je regarde dès que possible.
A+

Hors ligne

#9 2009-10-15 12:57:30

cljosse
Équipe Piwigo
2006-11-12
1167

Re: [plugin] Mail_supervisor

Eric a écrit:

Sur une autre galerie, j'avais déjà une version précédente (1.0.1) du plugin. J'ai fait l'update auto et là, je n'ai pas ce pb.

J'ai vérifié sur mon site qui montre le problème de traduction si tous les fichiers du plugin étaient bien là : RAS.

Bizarre...

Bonjour.
En mettant en ligne une nouvelle version, j'ai vu que j'avais oublié d'ajouter les nouveaux fichiers lors de la 'livraison' avec totoisesvn.
   Est ce la source du problème ?
  certainement mais tous les fichiers était là ??? ....

A suivre...

  Au sujet des Spams, j'ai toujours un spam détecté si j'essaye d'envoyer un texte en multi destinataire.
Cas ou cela se produit:
a) " Envoyer une copie vers le WebMaster" non validé.
b)   Une seule personne dans le groupe d'envoie.

Ce qui est logique, si il n'y a qu'un destinataire il ne faut pas utiliser "Bcc" ou "Cc" ! .

Encore une modification à prèvoir...
     A+

Dernière modification par cljosse (2009-10-15 13:00:15)

Hors ligne

#10 2009-10-15 19:05:34

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [plugin] Mail_supervisor

C'est qu'il commence à avoir de la gueule ce plugin ;-)

Quelques remarques tout de même :

- Mise à jour depuis la version 1.0.2a vers 1.1.2 : En màj auto, çà ne fonctionne pas super. Un warning apparait après l'installation, quand on se rend sur l'interface de gestion du plugin.

- Traduction des balises de langue : Les onglets, c'est super. Mais il y a toujours un problème au niveau de l'affichage des textes (cf capture d'écran).

[Edit] Et le format de date sous free_depuis_le est bizarre, non ?[/Edit]


Images attachées

Dernière modification par Eric (2009-10-15 19:07:04)

Hors ligne

#11 2009-10-15 20:04:11

cljosse
Équipe Piwigo
2006-11-12
1167

Re: [plugin] Mail_supervisor

Eric a écrit:

- Traduction des balises de langue : Les onglets, c'est super. Mais il y a toujours un problème au niveau de l'affichage des textes (cf capture d'écran).

[Edit] Et le format de date sous free_depuis_le est bizarre, non ?[/Edit]

Normalement ça devrait être traduit.
On voit que la prise en compte de la langue ne se fait pas correctement. ???
Tu ne devrais pas avoir des texte comme free_xxx dans les labels.


Supprime l'ancien free_mail completement.

Desinstalle le plugin completement, supprime le  et le recharge le.


  Je vais refaire des tests demain.

A+

Hors ligne

#12 2009-10-15 21:13:33

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [plugin] Mail_supervisor

cljosse a écrit:

Supprime l'ancien free_mail completement.

Desinstalle le plugin completement, supprime le  et le recharge le.

C'est ce que j'ai fait dès le début. Pensant à un pb avec l'installation auto chez Free, j'ai même téléchargé l'archive pour l'envoyer dans le dossier plugins par FTP après l'avoir supprimé de ma liste de plugins. Pas mieux...

Hors ligne

#13 2009-10-16 10:19:25

cljosse
Équipe Piwigo
2006-11-12
1167

Re: [plugin] Mail_supervisor

Bonjour.

Eric a écrit:

- Traduction des balises de langue : Les onglets, c'est super. Mais il y a toujours un problème au niveau de l'affichage des textes

Je pense avoir trouvé le bug dans mon fichier fonctions.php
 
   Je charge le fichier lang  ( load_language('plugin.lang', MAIL_SUPERV_PATH); )
avant
d' inclure                          (include_once(PHPWG_ROOT_PATH.'admin/include/functions.php'); )

Eric a écrit:

- Mise à jour depuis la version 1.0.2a vers 1.1.2 : En màj auto, çà ne fonctionne pas super. Un warning apparait après l'installation, quand on se rend sur l'interface de gestion du plugin.

Je ne sais pas pourquoi mais j'ai changé le nom du répertoire de "Mail_supervisor" en "mail_supervisor" entre les deux versions, grossière erreur.

Je modifie les sources en conséquence.
A+

Hors ligne

#14 2009-10-16 12:53:40

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [plugin] Mail_supervisor

Installation de zéro de la version 1.1.5.

Je suis désolé de te dire çà mais... Le pb de traduction des balises de langues est toujours présent :-(


Images attachées

Hors ligne

#15 2009-10-16 13:46:18

cljosse
Équipe Piwigo
2006-11-12
1167

Re: [plugin] Mail_supervisor

Eric a écrit:

Installation de zéro de la version 1.1.5.

Je suis désolé de te dire çà mais... Le pb de traduction des balises de langues est toujours présent :-(

Alors la je ne comprends pas.
  Chez moi, sur mes galleries ça à l'air ok...

  Un problème dans la base de donnée ?.
   Mon plug in incompatible avec un Un autre plug que tu utilises ? .
 
Si tu pouvais me donner l'acces à ta galerie par mail peut être que j'y verrais un peu plus...

Bizarre.................


A+

Hors ligne

  •  » Plugins
  •  » [plugin] Mail_supervisor

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact