•  » Outils
  •  » connection impossible avec pLoader 2.0.3a

#1 2009-08-18 19:40:28

Photoslive
Membre
2009-07-05
24

connection impossible avec pLoader 2.0.3a

Bonsoir à tous,

J'utilise depuis 2 jours l'extension pLoader pour charger mes photos sur mon site.
Hier tout c'est bien passé, j'ai mis une vingtaine de photos, tout fonctionnait très bien sur le site.

ce soir, je n'arrive pas à connecter avec pLoader il m'indique :
"not acceptable
La connection à Http://www.photoslive.fr a échoué"

pourtant mes identifiants sont corrects (d'ailleurs je n'ai rien changé par rapport à hier login enregistré)

Avez-vous déjà rencontré cette erreur en PJ ?

vs Piwigo 2.0.2
vs ploader for windows Révision 2.0.3a
mon windows est sous vista

Merci de votre aide
Ludovic


Images attachées

Hors ligne

#2 2009-08-18 22:48:41

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12356

Re: connection impossible avec pLoader 2.0.3a

Je n'y crois pas vraiment (pas du tout même, mais bon, ça montre que quelqu'un a vu ton appel au secours), mais peux-tu soit mettre à jour Piwigo en 2.0.3 (recommandé) soit utiliser plutôt pLoader 2.0.2c ?


Dernier billet du blog Piwigo.com (20 juin 2019) Modus, nouveau thème par défaut sur Piwigo.com

Hors ligne

#3 2009-08-19 12:31:18

Photoslive
Membre
2009-07-05
24

Re: connection impossible avec pLoader 2.0.3a

ok j'essaie ce soir mais je vais commencé par la solution ploader 2.0.2c
je suppose que je dois désinstaller ploader 2.0.3 avant ? et réinstaller ensuite 2.0.2c ? c'est bien ça ?

Merci
Ludovic

Hors ligne

#4 2009-08-19 19:18:11

Photoslive
Membre
2009-07-05
24

Re: connection impossible avec pLoader 2.0.3a

Salut,

Bon, j'ai réinstallé ploader 2.0.2c mais j'ai le même message, rien n'y fait.

j'ai lu sur le forum qu'une personne avait eu le même soucis que moi mais ensuite il s'est dirigé vers des catégories physiques.
C'est dommage car ploader semblait bien pratique :-(
c'est dingue que d'un coup comme ça il me mette en erreur.

y a -t-il un autre plugin moyen pour transférer ces photos comme ploader ?
si non, je vais tout recréer en catégories physiques et passer par mon ftp.

Merci de votre aide.

Ludovic

PS : je passerai en vs en 2.0.3 un peu plus tard il faut que je lise correctement le wiki pour ne pas faire de bêtises, je n'ai pas envie de tout casser lol

Hors ligne

#5 2009-08-19 21:18:02

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: connection impossible avec pLoader 2.0.3a

Photoslive a écrit:

PS : je passerai en vs en 2.0.3 un peu plus tard il faut que je lise correctement le wiki pour ne pas faire de bêtises, je n'ai pas envie de tout casser lol

[extension by P@t] Piwigo Auto Upgrade

Et cela devrait t'éviter quelques questions inutiles.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#6 2009-08-19 23:22:26

Photoslive
Membre
2009-07-05
24

Re: connection impossible avec pLoader 2.0.3a

bien vu et merci pour le plugin auto upgrade.
Je suis donc passé en qqls secondes à piwigo 2.0.3 :-)

cependant pour ploader, ça ne fonctionne tjs pas, j'ai réinstallé la dernière vs, nada c'est tjs le même message.

Ludo

Dernière modification par Photoslive (2009-08-19 23:23:07)

Hors ligne

#7 2009-08-21 08:35:13

ron
Former Piwigo Team
2008-09-30
211

Re: connection impossible avec pLoader 2.0.3a

Photoslive a écrit:

cependant pour ploader, ça ne fonctionne tjs pas, j'ai réinstallé la dernière vs, nada c'est tjs le même message.

Peux tu me transmettre en MP un login/password pour que je fasse un test de connexion à ta galerie ?

Hors ligne

#8 2009-08-22 09:12:43

ron
Former Piwigo Team
2008-09-30
211

Re: connection impossible avec pLoader 2.0.3a

Je me suis connecté à ta galerie avec l'identifiant que  tu m'as transmis. La version actuelle de pLoader ne peut effectivement pas se connecter à ta galerie. J'ai dû modifier un paramètre dans l'identification du user agent utilisé par pLoader afin de tromper le serveur et lui faire croire que c'est un navigateur ( Mozilla ) qui se connecte. Il doit s'agir de règles de sécurité au niveau du serveur.

J'ai pu créer une catégorie, par contre l'envoi de photos retourne une erreur 500 "file transfert failed". Je vais avoir besoin des compétences de plg pour éclaircir tout ça.

Hors ligne

#9 2009-09-29 18:29:08

grodid
Membre
2009-09-16
99

Re: connection impossible avec pLoader 2.0.3a

Bonjour,

Je suis desole de me sentir oblige de reveiller un peu ce topic,
mais je n'arrive pas a connecter pLoader a mon serveur Web de test local (localhost).

Description cote client :
- pLoader 2.0.3a sur WinXP SP2

Cote Serveur :
- Piwigo 2.0.4 sur Win XP SP2 (le meme, of course), installe au dessus de WAMPSERVER2

Qd je lance pLoader, et que je rentre l'info (pour etre precis, le champ 'adresse du site piwigo' est : http://localhost/tpiwigo1),
j'obtiens une fenetre avec le titre 'erreur de connection a Piwigo',
et le message : 'la connection a http://localhost/tpiwigo1 a echoue'.
Le login/pwd que j'utilise dans cet essai est correctement enregistre comme administrateur.

Bien sur, mon serveur tourne correctement, et j'ai reussi a me logger dessus avec Firefox, pour y configurer un certain nb de parametres.

J'ai desinstalle moult fois pLoader pour essayer la 2.0.2c 9entre autres), comme suggere dans d'autres discussions, mais sans succes.
J'ai aussi supprime les dossiers .pLoader et par-<user> comme suggere ailleurs, meme punition.

J'ai essaye pLoader avec mon autre galerie Piwigo sur un site public, et cela marche tout comme il faut.

Tout cela me parait bien etrange. Une idee ?

Merci d'avance pour votre aide.

Gilbert.

Hors ligne

#10 2009-10-01 18:06:40

grodid
Membre
2009-09-16
99

Re: connection impossible avec pLoader 2.0.3a

Bonjour,

Une petite precision, on ne sait jamais : ce message est affiche en haut de chaque page qd
je visite mon site installe avec WAMPSERVER2 et PHP5.3.0 :
Deprecated: Function set_magic_quotes_runtime() is deprecated in C:\wamp\www\tpiwigo1\include\common.inc.php on line 31

Cela pourrait-il etre a l'origine de mon pb avec pLoader, svp ?

Dans tous les cas, comment faire pour eviter cela ?

Merci d'avance,   Gilbert.

Hors ligne

#11 2009-10-01 18:20:18

grodid
Membre
2009-09-16
99

Re: connection impossible avec pLoader 2.0.3a

Additif au message #9, pour ne pas melanger les topics : mon pb avec pLoader subsiste
alors que j'ai refait mon installation sous Vista, et que mon serveur est distant
(plus de localhost dans l'URL du site cible par pLoader a l'ouverture).
Le message d'erreur est strictement le meme (snif).

J'ai verifie qu'un FTP (vers le port 21 de mon serveur) marchait bien (log file de FileZilla).

Mais il n'y a rien a faire pour que pLoader se connecte.

J'ai releve dans l'access log d'Apache les 3 messages suivants a chaque essai de connexion :

134.158.90.106 - grodip [30/Sep/2009:16:13:10 +0200] "POST /tpiwigo1/ws.php?format=json HTTP/1.1" 200 383
134.158.90.106 - grodip [30/Sep/2009:16:13:10 +0200] "GET /tpiwigo1/ws.php?format=json&method=pwg.categories.getList&recursive=true HTTP/1.1" 200 5201
134.158.90.106 - grodip [30/Sep/2009:16:13:10 +0200] "GET /tpiwigo1/ws.php?format=json&method=pwg.tags.getAdminList HTTP/1.1" 401 370

Beaucoup plus inquietantes, a mon avis, sont les erreurs relevees dans l'error log d'Apache pour le meme essai :

[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Deprecated:  Function set_magic_quotes_runtime() is deprecated in C:\\wamp\\www\\tpiwigo1\\include\\common.inc.php on line 31
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, boolean given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 527
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Deprecated:  Function set_magic_quotes_runtime() is deprecated in C:\\wamp\\www\\tpiwigo1\\include\\common.inc.php on line 31
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, boolean given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 527
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, array given in C:\\wamp\\www\\tpiwigo1\\include\\ws_protocols\\json_encoder.php on line 61
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, array given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, array given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, array given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, array given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, array given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, integer given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, integer given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, null given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, null given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, integer given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, integer given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, integer given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, integer given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, integer given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, integer given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Deprecated:  Function set_magic_quotes_runtime() is deprecated in C:\\wamp\\www\\tpiwigo1\\include\\common.inc.php on line 31
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, boolean given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 527

Ces erreurs empechent-elles la connection ?

Vos lumieres sauront-elles m'eclairer ?

Merci d'avance,   Gilbert.

Hors ligne

#12 2009-10-01 21:09:27

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: connection impossible avec pLoader 2.0.3a

grodid a écrit:

WAMPSERVER2 et PHP5.3.0

Puisque tu es avec WampServer2 essaie d'installer et de fonctionner en php 5.2.0 et ...


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#13 2009-10-01 21:45:58

grodid
Membre
2009-09-16
99

Re: connection impossible avec pLoader 2.0.3a

OK, merci, j'essaye dès que possible, et je vous tiens au courant.

Gilbert.

Hors ligne

#14 2009-10-02 15:11:52

ron
Former Piwigo Team
2008-09-30
211

Re: connection impossible avec pLoader 2.0.3a

grodid a écrit:

Ces erreurs empechent-elles la connection ?

Oui, les warnings sont retournés en même temps que le statut de connection au serveur et pLoader n'arrive pas à lire cette réponse et donc l'interprète comme une erreur.

Hors ligne

#15 2009-10-02 15:37:52

grodid
Membre
2009-09-16
99

Re: connection impossible avec pLoader 2.0.3a

OK, merci Ron, c'est bien ce que je pensais.

Entre temps, j'ai essaye la solution de VD, mais le passage en PHP 5.2.0 n'a rien change.

Gilbert.

Hors ligne

  •  » Outils
  •  » connection impossible avec pLoader 2.0.3a

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact