•  » Utilisation
  •  » [RESOLU] Déplacer le champs "nom de l'image"

#1 2009-07-11 17:09:27

Nol
Membre
2009-07-06
30

[RESOLU] Déplacer le champs "nom de l'image"

Je souhaiterai déplacer le champs "nom de l'image" (qui se situe au-dessus de l'image) en dessous de "créée le". Dans le fichier picture-perso.tpl, après avoir supprimer
{if $SHOW_PICTURE_NAME_ON_TITLE }
  <h2>{$current.TITLE}</h2>     

J'ai ajouté dans infoTable

<tr>
    <td class="label">{'Picture name'|@translate}</td>
    <td class="value">{if isset($INFO_PICTURE_NAME)}{$INFO_PICTURE_NAME}{else}{'N/A'|@translate}{/if}</td>
  </tr>


Mais le nom de l'image : non disponible

Dernière modification par Nol (2009-07-11 19:12:55)

Hors ligne

#2 2009-07-11 17:54:40

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [RESOLU] Déplacer le champs "nom de l'image"

Nol a écrit:

Dans le fichier picture-perso.tpl, ....
J'ai ajouté dans infoTable

<tr>
    <td class="label">{'Picture name'|@translate}</td>
    <td class="value">{if isset($INFO_PICTURE_NAME)}{$INFO_PICTURE_NAME}{else}{'N/A'|@translate}{/if}</td>
  </tr>

C'est bien la voie à prendre...
Essaie:

{if isset($current.TITLE)}
<tr>
    <td class="label">{'Picture name'|@translate}</td>
    <td class="value">{$current.TITLE}</td>
  </tr>
{/if}


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#3 2009-07-11 17:58:19

Nol
Membre
2009-07-06
30

Re: [RESOLU] Déplacer le champs "nom de l'image"

Ca marche nickel, encore une fois merci.


Pour info, pourquoi <td class="value">{$current.TITLE}</td>

à la place  de

<td class="value">{if isset($INFO_PICTURE_NAME)}{$INFO_PICTURE_NAME}{else}{'N/A'|@translate}{/if}</td>

Une histoire de table ??

Hors ligne

#4 2009-07-11 18:36:05

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [RESOLU] Déplacer le champs "nom de l'image"

Dans http://piwigo.org/dev/browser/tags/2.0. … e.php#L858
La table $infos, dans les valeurs sont assignées au template, il n'y a pas de clé "INFO_PICTURE_NAME"...
pas de $infos['INFO_PICTURE_NAME'] => quand $template->assign($infos);
le template n'a pas {$INFO_PICTURE_NAME}
=> isset($INFO_PICTURE_NAME) renvoie faux.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

  •  » Utilisation
  •  » [RESOLU] Déplacer le champs "nom de l'image"

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact