#1 2009-07-06 07:25:42

ddtddt
Équipe Piwigo
Lieu: Quetigny (21) - France
Date d'inscription: 2007-07-27
Messages: 13879
Site web

pLoader release 2.0.3a

Bonjour à toute la communauté Piwigo et aux utilisateurs de pLoader :-)

Dans ce mois de juillet ensoleillé une nouvelle version de pLoader vous est proposée. 
Plusieurs bugs ont été corrigés et une fonctionnalité importante a été ajoutée: le support des tags.

Voir les détails sur le [Forum, post 115025 by ddtddt in topic 15194] pLoader pour Windows, préparer et transférer ses photos

pLoader 2.0.3a est disponible pour Windows et pour Ubuntu Linux.

Comme toujours, vos commentaires sont attendus et seront appréciés :-)


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#2 2009-07-06 11:35:47

SNF69
Membre
Lieu: Lyon (69)
Date d'inscription: 2009-04-10
Messages: 1253
Site web

Re: pLoader release 2.0.3a

Salut les gens,

Encore une fois une nouvelle mouture fort sympathique avec une très bonnes nouvelles, l'intégration des tags ;o)). Pour moi pas de problème à l'installation et l'utilisation, par contre j'ai détecté un bug. En effet, sur la page des tags justement, si tu as beaucoup de tag et que tu redimensionnes la fenêtre et bien l'ascenseur ne suit pas le redimensionnement au bout d'un moment c'est pas glop (voir l'image ci dessous car je ne suis pas sur d'avoir était très clair ;o))


http://www.tarrajat.fr/Visuelforum/pLoader/pLoader.png


Quoi qu'il en soit grand crue ;o))
Bonne journée.


Seb


Ma galerie ?? c'est par ici : Galerie de Stephy et Seb

Hors ligne

#3 2009-07-06 13:07:10

LucMorizur
Membre
Lieu: Vienne (Isère, 38)
Date d'inscription: 2009-03-01
Messages: 1967
Site web

Re: pLoader release 2.0.3a

SNF69 a écrit:

Encore une fois une nouvelle mouture fort sympathique avec une très bonnes nouvelles, l'intégration des tags ;o)).

Toujours pas d'intégration des IPTC ?

Hors ligne

#4 2009-07-06 14:12:04

Gotcha
Equipe Piwigo
Lieu: Pierrelatte (26)
Date d'inscription: 2007-03-14
Messages: 13324
Site web

Re: pLoader release 2.0.3a

[HS]
Ca ne serait pas bien de créer une section spécifique à pLoader ???
Parceque là, c'est mélangé entre Piwigo, les extensions, les autres outils plus "modestes" etc.
Bon ok, pour le moment je ne suis pas le projet car comme le fait remarquer Luc juste au dessus, les IPTC sont un critère éliminatoire pour moi. Aussi, tout ce qui touche à pLoader pour le moment je le zap royalement.

Mais pour la clarté des information et une meilleures recherche, je pense qu'une section spécifique ne serait pas de trop ;-)
[/HS]


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#5 2009-07-06 21:39:03

plg
Équipe Piwigo
Lieu: Nantes, France, Europe
Date d'inscription: 2002-04-05
Messages: 12175
Site web

Re: pLoader release 2.0.3a

Note: petit écart de traduction, j'ai remplacé:

[...]  un élément important a été ajoutée: Les messages d'erreurs.

par

[...] une fonctionnalité importante a été ajoutée: le support des tags.

Ca a son importance quand même :-)


Dernier billet du blog Piwigo.com (21 mars 2017) Offres Piwigo.com Entreprise, enfin officielles !

Hors ligne

#6 2009-07-06 21:56:50

plg
Équipe Piwigo
Lieu: Nantes, France, Europe
Date d'inscription: 2002-04-05
Messages: 12175
Site web

Re: pLoader release 2.0.3a

SNF69 a écrit:

[...] si tu as beaucoup de tag et que tu redimensionnes la fenêtre et bien l'ascenseur ne suit pas le redimensionnement au bout d'un moment c'est pas glop [...]

Les tests ont été faits avec une fenêtre "photo properties" qui n'était pas "dockée". C'est vrai que là, c'est pas top. Peux-tu faire un rapport de bug (en anglais) ?


Dernier billet du blog Piwigo.com (21 mars 2017) Offres Piwigo.com Entreprise, enfin officielles !

Hors ligne

#7 2009-07-06 22:00:02

plg
Équipe Piwigo
Lieu: Nantes, France, Europe
Date d'inscription: 2002-04-05
Messages: 12175
Site web

Re: pLoader release 2.0.3a

LucMorizur a écrit:

Toujours pas d'intégration des IPTC ?

Non :-/ mais attention, la première étape sera simplement de ne pas y toucher aux IPTC justement (ne pas les supprimer). Je te conseille de "monitorer" (il faut s'inscrire sur le bugtracker pour cela) les issues suivantes:

* [Bugtracker, ticket 922, not a bug] keep IPTC metadata
* [Bugtracker, ticket 944, open] Read IPTC Fields when existing


Dernier billet du blog Piwigo.com (21 mars 2017) Offres Piwigo.com Entreprise, enfin officielles !

Hors ligne

#8 2009-07-06 22:02:24

plg
Équipe Piwigo
Lieu: Nantes, France, Europe
Date d'inscription: 2002-04-05
Messages: 12175
Site web

Re: pLoader release 2.0.3a

Gotcha a écrit:

Ca ne serait pas bien de créer une section spécifique à pLoader ???

Pour le moment, je dirais que non ce n'est pas la peine. Il y a les tags qui font déjà un bon boulot. Laissons nous encore quelques mois. Si on constate que pLoader "pollue" trop les autres sections du forum, on créera une section dédiée.

[HS]de toute façon, il faudrait revoir l'organisation du forum, on en a discuté récemment dans l'équipe, mais un sujet "public" ne ferait pas de mal[/HS]


Dernier billet du blog Piwigo.com (21 mars 2017) Offres Piwigo.com Entreprise, enfin officielles !

Hors ligne

#9 2009-08-04 18:21:59

Boris
Membre
Lieu: Woustviller
Date d'inscription: 2006-12-21
Messages: 4

Re: pLoader release 2.0.3a

Bonjour tout le monde,

je viens de tester la version Linux, mais cette dernière refuse de se lancer :

Code:

boris@positron bin % ./pLoader-ubuntu-2.0.3a 

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64

(pLoader-ubuntu-2.0.3a:10780): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: mauvaise classe ELF : ELFCLASS64
Can't load '/tmp/par-boris/cache-fa624c655df5b6d225ccaac463f2e3b317d72af3/ab73ee3d.so' for module Image::Magick: libtiff.so.4: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type at /usr/lib/perl/5.8/DynaLoader.pm line 225.
 at /usr/local/share/perl/5.8.8/PAR/Heavy.pm line 109
Compilation failed in require at Uploader/ImageList.pm line 25.
BEGIN failed--compilation aborted at Uploader/ImageList.pm line 25.
Compilation failed in require at Uploader/GUI/wxApp.pm line 279.
BEGIN failed--compilation aborted at Uploader/GUI/wxApp.pm line 279.
Compilation failed in require at script/ploader.pl line 24.
BEGIN failed--compilation aborted at script/ploader.pl line 24.
^C

Bon, les Warnings GTK je pense que ce n'est pas trop grave, par contre il mentionne des fichiers que je n'ai pas :

libtiff.so.4, moi j'ai /usr/lib64/libtiff.so.3

/usr/lib/perl/5.8/DynaLoader.pm , moi j'ai /usr/lib64/perl5/5.8.8/x86_64-linux/DynaLoader.pm

/usr/local/share/perl/5.8.8/PAR/Heavy.pm, moi j'ai /usr/lib64/perl5/5.8.8/Carp/Heavy.pm ou encore /usr/lib64/perl5/5.8.8/Exporter/Heavy.pm

Merci d'avance


$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'

Hors ligne

#10 2009-08-04 22:09:16

ddtddt
Équipe Piwigo
Lieu: Quetigny (21) - France
Date d'inscription: 2007-07-27
Messages: 13879
Site web

Re: pLoader release 2.0.3a

Quelle version ubuntu tu utilses ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#11 2009-08-14 19:49:51

Boris
Membre
Lieu: Woustviller
Date d'inscription: 2006-12-21
Messages: 4

Re: pLoader release 2.0.3a

Désolé pour le délai, je m'étais abonné au fil mais je n'ai pas eu de notification.

Je n'utilise pas Ubuntu mais Gentoo. J'avais cru comprendre que pLoader était compatible avec toutes les distros linux.


$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'

Hors ligne

#12 2009-08-20 20:28:16

plg
Équipe Piwigo
Lieu: Nantes, France, Europe
Date d'inscription: 2002-04-05
Messages: 12175
Site web

Re: pLoader release 2.0.3a

Boris a écrit:

Je n'utilise pas Ubuntu mais Gentoo. J'avais cru comprendre que pLoader était compatible avec toutes les distros linux.

Et non malheureusement. Il y a déjà des versions de pLoader qui fonctionnent avec Ubuntu 8.10 mais pas 9.04 :-/ Pour le moment, on se concentre par ordre décroissant de priorité, sur la version Windows, la version Ubuntu, la version Mac (et quand celle-ci sera sortie, elle passera en deuxième après Windows).

Cela dit, si tu veux nous aider à faire fonctionner pLoader sur Gentoo, ce serait super, je peux te retrouver de l'information pour savoir quoi faire sur le sujet :-)


Dernier billet du blog Piwigo.com (21 mars 2017) Offres Piwigo.com Entreprise, enfin officielles !

Hors ligne

#13 2009-08-20 21:26:57

SNF69
Membre
Lieu: Lyon (69)
Date d'inscription: 2009-04-10
Messages: 1253
Site web

Re: pLoader release 2.0.3a

plg a écrit:

... la version Mac (et quand celle-ci sera sortie, elle passera en deuxième après Windows).

Très bonne nouvelle je veux bien faire parti de l'équipe de test ;o))
Bonne soirée.


Seb


Ma galerie ?? c'est par ici : Galerie de Stephy et Seb

Hors ligne

#14 2009-08-22 14:52:34

Boris
Membre
Lieu: Woustviller
Date d'inscription: 2006-12-21
Messages: 4

Re: pLoader release 2.0.3a

plg a écrit:

Boris a écrit:

Cela dit, si tu veux nous aider à faire fonctionner pLoader sur Gentoo, ce serait super, je peux te retrouver de l'information pour savoir quoi faire sur le sujet :-)

Ben si c'était possible d'avoir les sources je voudrais bien y jeter un oeil...


$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'

Hors ligne

#15 2009-08-24 22:51:15

plg
Équipe Piwigo
Lieu: Nantes, France, Europe
Date d'inscription: 2002-04-05
Messages: 12175
Site web

Re: pLoader release 2.0.3a

Boris a écrit:

plg a écrit:

Boris a écrit:

Cela dit, si tu veux nous aider à faire fonctionner pLoader sur Gentoo, ce serait super, je peux te retrouver de l'information pour savoir quoi faire sur le sujet :-)

Ben si c'était possible d'avoir les sources je voudrais bien y jeter un oeil...

Les sources sont disponibles sous SVN :

Code:

svn checkout http://piwigo.org/svn/extensions/pLoader/trunk

Dernier billet du blog Piwigo.com (21 mars 2017) Offres Piwigo.com Entreprise, enfin officielles !

Hors ligne

Pied de page des forums

Propulsé par FluxBB