#1 2009-07-05 01:30:04

fibo
Membre
1970-01-01
14

[2.0.2] bug in ws_functions ?

J'ai dans mon répertoire principal le fichier error_log dont copie ci-dessous.
Pour une raison que je ne connais pas, il semblerait qu'il y ait une erreur dans merge_chunks, vraisemblablement sur un ++$i où $i n'a pas été initialisé.
Cette erreur déclenche un message d'erreur, qui ensuite bloque un reroutage par header() puisque du code html a déjà été généré.
--------------------------------------------
[03-Jul-2009 13:07:57] PHP Warning:  chmod() [<a href='function.chmod'>function.chmod</a>]: No such file or directory in /xxxxx/public_html/album-photos/include/ws_functions.inc.php on line 1062
[03-Jul-2009 13:07:57] PHP Warning:  md5_file(./upload/2009/07/03/20090703130757-d854e30b.jpg) [<a href='function.md5-file'>function.md5-file</a>]: failed to open stream: No such file or directory in /xxxxx/public_html/album-photos/include/ws_functions.inc.php on line 1065
[03-Jul-2009 13:07:57] PHP Warning:  Cannot modify header information - headers already sent by (output started at /xxxxx/public_html/album-photos/include/ws_functions.inc.php:1062) in /xxxxx/public_html/album-photos/include/functions_html.inc.php on line 770
[03-Jul-2009 13:16:37] PHP Notice:  Undefined variable: i in /xxxxx/public_html/album-photos/include/ws_functions.inc.php on line 970
[03-Jul-2009 13:16:37] PHP Warning:  Cannot modify header information - headers already sent by (output started at /xxxxx/public_html/album-photos/include/ws_functions.inc.php:970) in /xxxxx/public_html/album-photos/include/functions_html.inc.php on line 770
--------------------------------------------

Arrière-pensée: lors de l'install j'avais eu un warning à propose de la version de MySQL

# PHP: 5.2.6 (Montrer les informations) [2009-07-04 23:46:09]
# MySQL: 4.1.22-standard-log [2009-07-04 23:46:09]

Dernière modification par fibo (2009-07-05 01:51:53)

Hors ligne

#2 2009-07-05 11:31:06

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12360

Re: [2.0.2] bug in ws_functions ?

bonjour fibo,

C'est très très précisément [Bugtracker, ticket 1043, fixed] [pwg.images.add] error not sent when a transfert has failed à mon avis (voir [Subversion] r3513). Je l'ai fixé avant hier et la correction est disponible dans la release 2.0.3 qui vient de sortir :-)

Merci pour ce retour détaillé, et n'hésites pas si tu en as d'autres. J'avoue que ce bug là il m'est complètement passé sous le nez, parce que c'est un message d'erreur invisible qui masque un autre message d'erreur.


Dernier billet du blog Piwigo.com (20 juin 2019) Modus, nouveau thème par défaut sur Piwigo.com

Hors ligne

#3 2009-07-05 20:58:51

fibo
Membre
1970-01-01
14

Re: [2.0.2] bug in ws_functions ?

Mis à jour par la MAJ partielle depuis 2.0.X.

Tout a l'air OK, sauf toujours

-------------------------
Contrôle d'intégrité

Anomalie     Correction

La version de MySQL [4.1.22-standard-log] installée n'est pas compatible avec la version requise [4.1.22]    

Vous devez mettre à jour votre système pour profiter pleinement de l'application sinon l'application ne fonctionnera pas correctement, voire pas du tout

          Allez sur le forum ou le wiki pour plus d'informations
---------------------------
Ma version convient-elle ou non? possible d'éviter ce message toujousr inquiétant, dont on ne sait quoi faire...

Dernière modification par fibo (2009-07-06 11:04:54)

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact