#16 2009-05-01 19:30:36

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [plugin] LMT

Ok, d'accord, on va rester à la méthode "a mano" ^^

Merci Grum.


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#17 2009-05-01 20:15:26

gbo
Membre
Martigues
2006-11-01
1152

Re: [plugin] LMT

Pierrot_Rennes a écrit:

Bonjour,

Je viens d'essayer d'installer le plugin et j'ai cette superbe notice !!! ;-)

Fatal error: Cannot redeclare plugin_install() (previously declared in /homez.152/cartespu/www/plugins/look_like_gbo2/maintain.inc.php:33) in /homez.152/cartespu/www/plugins/lmt/maintain.inc.php on line 68

Un problème de compatibilité avec LLGBO ??

Le plugin refuse de s'installer

A suivre donc

Patricia a écrit:

Peut être mais pas chez moi !
yoga/Sylvia avec Look_like_GBo
http://***********.free.fr/galerie2

Chez moi en local comme chez Patricia les deux plugins fonctionnent sans souci.

Pour la position du logo de copyright,  LLGBO2 ne connaît pas la classe .licencetag, il n'est donc pas directement en cause.

Hors ligne

#18 2009-05-13 11:15:45

rio
Équipe Piwigo
Paris
2006-07-24
1589

Re: [plugin] LMT

Patricia a écrit:

Bonjour le Forum
J'ai ce message : lmt_gpc2_not_installed pourtant Classe 2 est installé et activé !

grum a écrit:

Quelle version de GPC as-tu d'installé ?
LMT nécessite la v2.0.2.

Même problème ... GPC 2.0.2 OK


-> /<Ä®¿M <-
http://riohome.free.fr
Il forum è anche in ITALIANO

Hors ligne

#19 2009-05-13 20:53:42

grum
Équipe Piwigo
50% Nantes - 50% Paris
2007-09-10
2502

Re: [plugin] LMT

Arf.
Chez moué tout est normal  o_O;
(et chez Patricia il me semble que le pb a été résolu après màj de la classe...)

Peux-tu me dire si le fichier grum_plugins_classes-2/common_plugin.class.inc.php existe ?

Sinon, dans le fichier maintain.inc.php il y a ce code :

Code:

$gpc_installed=false;
if(file_exists(PHPWG_PLUGINS_PATH.'grum_plugins_classes-2/common_plugin.class.inc.php'))
{
  @include_once(PHPWG_PLUGINS_PATH.'grum_plugins_classes-2/main.inc.php');
  // need GPC release greater or equal than 2.0.2
  if(checkGPCRelease(2,0,2))
  {
    @include_once('lmt_install.class.inc.php');
    $gpc_installed=true;
  }
}

Peux-tu le modifier de la sorte afin que j'ai une idée de ce qui ne va pas ?

Code:

$gpc_installed=false;
if(file_exists(PHPWG_PLUGINS_PATH.'grum_plugins_classes-2/common_plugin.class.inc.php'))
{
echo "1<br/>";
  include_once(PHPWG_PLUGINS_PATH.'grum_plugins_classes-2/main.inc.php');
  // need GPC release greater or equal than 2.0.2
  if(checkGPCRelease(2,0,2))
  {
echo "2<br/>";
    include_once('lmt_install.class.inc.php');
    $gpc_installed=true;
  }
}

Tenter l'install et me dire s'il y a des messages d'erreur ou non ? (et si les "1" et "2" sont affichés...)
Une chose pas normale, c'est l'affichage du "lmt_gpc2_not_installed ". Normallement le message est traduit (présent dans plugin.lang) donc y a p'tet un autre soucis quelque part aussi....


Mes photos avec Piwigo évidemment !
[ www.grum.fr ] [ photos.grum.fr ]

Hors ligne

#20 2009-05-14 22:30:09

rio
Équipe Piwigo
Paris
2006-07-24
1589

Re: [plugin] LMT

grum a écrit:

Peux-tu me dire si le fichier grum_plugins_classes-2/common_plugin.class.inc.php existe ?

En regardant de près, le rep du plugin s'appelait grum_plugins_classes
J'ai revérifié la mise à jour ... le plugin n'apparaissait pas dans la liste des plugin à mettre à jour.
J'ai désinstallé et reinstallé et tout est OK.

J'ai fait la même vérif sur deux autres site où je n'ai pas encore installé LMT.
Sur la première http://riohome.free.fr tout était OK. Le plugin à jour et le répertoire correspondait bien.
Sur la deuxième http://wael.kenza.free.fr même problème que la galerie test. Plugin semble à jour, mais le répertoire ne correspond pas.

Seule idée, un problème de FREE (ça arrive souvent) lors de la mise à jour.
Souvent, pour les opérations un peu longue, on arrive à une page blanche. C'est le cas pour la vérification des Màj des plugin, pour la MàJ des plugin pour la liste des plugin disponibles ...

Merci grum de t'y être penché!
:-))

Dernière modification par rio (2009-05-14 22:46:22)


-> /<Ä®¿M <-
http://riohome.free.fr
Il forum è anche in ITALIANO

Hors ligne

#21 2009-06-10 22:19:22

grum
Équipe Piwigo
50% Nantes - 50% Paris
2007-09-10
2502

Re: [plugin] LMT

le message par email a écrit:

> Bonsoir,
>
> Je suis en train de tester Piwigo, et je suis vivement intéressé par votre plugin LMT. Néanmoins, je suis bloqué par un bug. Au niveau de l'onglet "Gérer les affectations", un panier vide affiche un message correct, mais un panier plein affiche une liste vide, et 0 photo oO.
>
> Voici mes informations de version :
>
> Version de Piwigo
>
>         * Piwigo 2.0.2
>         * Dernière version ?
>
> Environnement
>
>         * System d'exploitation: Linux
>         * PHP: 5.2.9 (Montrer les informations) [2009-06-10 21:40:35]
>         * MySQL: 5.0.68-log [2009-06-10 21:40:40]
>
> Sachant que j'ai la version 1.0.1 de votre plugin. Avez vous une idée de la source du problème ? Bug connu ? Problème de config côté serveur ? Je suis à côté de la plaque (ca l'arrive ^^).
>
> Ah oui, j'ai également installé la version 2.0.2 de vos "Plugins classes". Tout a été installé via l'inteface d'administration de piwigo.
>
> Merci d'avance,

Le plugin génère sa page de la façon suivante :
si présence d'éléments dans le panier, fabriquer la page en générant un appel AJAX pour récupérer les élements du panier (permet de gérer la pagination sans recharger toute la table)
  sinon afficher le message que le panier est vide.

Donc la combinaison : faire appel à AJAX + retour = liste vide indique qu'il y a bien quelque chose dans le panier, mais que la seconde requête n'a pas fonctionné.

Pour essayer de comprendre d'où viens le pb, dans le fichier lmt_aip.class.inc.php
entre les lignes 918 et 934 tu as

Code:

    $sql="SELECT SQL_CALC_FOUND_ROWS img.id as image_id, img.file, img.path, img.tn_ext, cat.id as catid, cat.name as catname, cat.permalink,
                 lmti.licence_type, lmtla.text1, lmtla.text2 
          FROM ".CATEGORIES_TABLE." cat, ".CADDIE_TABLE." caddie, ".IMAGES_TABLE." img 
            LEFT OUTER JOIN ".$this->tables["images"]." AS lmti
              ON img.id = lmti.image_id  
            LEFT OUTER JOIN ".$this->tables["licence_author"]." lmtla 
              ON lmtla.id = lmti.author_id
          WHERE img.storage_category_id = cat.id 
            AND img.id = caddie.element_id
            AND caddie.user_id = '".$user['id']."'
          ORDER BY cat.id, img.id ";

    if($this->my_config['lmt_list_maxitems']>0)
    {
      $refdbt = ($pagenum-1)*$this->my_config['lmt_list_maxitems'];
      $sql.=" LIMIT ".$refdbt.", ".$this->my_config['lmt_list_maxitems'];
    }

ligne 935 tu ajoutes la ligne

Code:

echo $sql."<br/>";

retourne sur la page pour gérer les affectations.
sous la liste (vide) et avant le "0 photos"  la requête SQL soumise à mySQL sera affichée.

va sous phpmyadmin (normallement mis à dispo par la plupart des hébergeurs) et exécute la requête.

dis moi quel est le résultat (liste vide ?).


Mes photos avec Piwigo évidemment !
[ www.grum.fr ] [ photos.grum.fr ]

Hors ligne

#22 2009-06-10 22:33:56

Sedna
Membre
2009-06-10
4

Re: [plugin] LMT

Salut,

J'ai ajouté le debug ligne 135, il m'a retourné la requête suivante :

Code:

SELECT SQL_CALC_FOUND_ROWS img.id as image_id, img.file, img.path, img.tn_ext, cat.id as catid, cat.name as catname, cat.permalink, lmti.licence_type, lmtla.text1, lmtla.text2 
FROM piwigo_categories cat, piwigo_caddie caddie, piwigo_images img 
LEFT OUTER JOIN piwigo_lmt_images AS lmti ON img.id = lmti.image_id LEFT OUTER JOIN piwigo_lmt_licence_author lmtla ON lmtla.id = lmti.author_id 
WHERE img.storage_category_id = cat.id AND img.id = caddie.element_id AND caddie.user_id = '1' 
ORDER BY cat.id, img.id LIMIT 0, 1000

Mais par contre, 0 résultats lorsque je l'exécute directement dans phpMyAdmin :-(

Sachant que :
- Les 5 photos sont bien dans la table caddie
- mon id_user est bien '1'

Cdlt,

Damien

PS : au passage, la configuration par défaut du plugin mettait une limite à 0 dans la taille de la liste, est-ce normal ?

Hors ligne

#23 2009-06-10 22:51:39

grum
Équipe Piwigo
50% Nantes - 50% Paris
2007-09-10
2502

Re: [plugin] LMT

disposes-tu de la fonction "expliquer SQL" avec phpmyadmin ?

Après exécution de la requête elle apparait sous l'affichage de la requête SQL.

En cliquant dessus, tu devrais avoir un table (cf. image en exmple).


Images attachées


Mes photos avec Piwigo évidemment !
[ www.grum.fr ] [ photos.grum.fr ]

Hors ligne

#24 2009-06-10 22:53:40

grum
Équipe Piwigo
50% Nantes - 50% Paris
2007-09-10
2502

Re: [plugin] LMT

Sedna a écrit:

PS : au passage, la configuration par défaut du plugin mettait une limite à 0 dans la taille de la liste, est-ce normal ?

0 = pas de limite (donc pas de pagination).
pas trop conseillé dès que le panier atteind une centaine de photos...


Mes photos avec Piwigo évidemment !
[ www.grum.fr ] [ photos.grum.fr ]

Hors ligne

#25 2009-06-10 22:56:40

Sedna
Membre
2009-06-10
4

Re: [plugin] LMT

Yep, voilà le résultat de l'explication de requête :)

Et merci de ta réactivité !


Images attachées

Hors ligne

#26 2009-06-10 23:20:10

grum
Équipe Piwigo
50% Nantes - 50% Paris
2007-09-10
2502

Re: [plugin] LMT

ben tout me parait normal.

il trouve bien 5 images dans le panier, semble trouver les'images dans la table des images et fait correctement le lien sur la catégorie physique associée.
les jointure externes ne restituent rien, ce qui est aussi normal (vu que le plugin ne fonctionne pas, elles sont vides).

du coup là je comprends pas trop...

on va essayer une requête plus simple pour tenter de trouver ce qui ne va pas.

Code:

 SELECT img.id, img.file, img.path, img.tn_ext, cat.id, cat.name, cat.permalink, lmti.licence_type, lmtla.text1, lmtla.text2
FROM phpwebgallery_categories cat, phpwebgallery_caddie caddie, phpwebgallery_images img
LEFT OUTER JOIN phpwebgallery_lmt_images lmti ON img.id = lmti.image_id
LEFT OUTER JOIN phpwebgallery_lmt_licence_author lmtla ON lmtla.id = lmti.author_id
WHERE img.storage_category_id = cat.id
AND img.id = caddie.element_id
AND caddie.user_id = '1'
ORDER BY cat.id, img.id
LIMIT 0 , 1000

Dernière modification par grum (2009-06-10 23:21:07)


Mes photos avec Piwigo évidemment !
[ www.grum.fr ] [ photos.grum.fr ]

Hors ligne

#27 2009-06-10 23:32:26

Sedna
Membre
2009-06-10
4

Re: [plugin] LMT

Toujours pas de résultat dans la requête :-$
Je te joint l'explication

PS  : Pour les idées de features, tu préfères par mail ou dans ce sujet ? Ou dans un autre plus approprié ? (enfin ca c'est pour quand ca marchera ;-) )


Images attachées

Hors ligne

#28 2009-06-10 23:50:13

grum
Équipe Piwigo
50% Nantes - 50% Paris
2007-09-10
2502

Re: [plugin] LMT

pour l'instant effectivement on va peut-être continuer par mail... ^^;


Mes photos avec Piwigo évidemment !
[ www.grum.fr ] [ photos.grum.fr ]

Hors ligne

#29 2009-06-11 03:35:56

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [plugin] LMT

[HS]
Comment faites-vous pour flouter vos images ?
Merci
[/HS]


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#30 2009-06-11 09:24:01

Sedna
Membre
2009-06-10
4

Re: [plugin] LMT

Ca marche je passe sur les mails ;-)

Pour le flou, j'utilise Gimp : un cadre de sélection, un flou directionnel avec l'intensité au max, et hop !

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact