Annonce

  •  » Utilisation
  •  » [Résolu] Pb création nouveau compte

#1 2009-04-30 22:03:34

Korben
Membre
2008-09-17
139

[Résolu] Pb création nouveau compte

Bonsoir,

C'est encore moi. :-) :-)

Je reviens vers vous afin de comprendre un autre problème que je rencontre.
Je viens de faire le test d'inscrire un nouvel utilisateur et voici ce que j'obtiens à l'écran lorsque je dans le mail que ce nouvel utilisateur je clic sur le lien de confirmation de création de compte sur Pixigo

Notice: Use of undefined constant ACCESS_NONE - assumed 'ACCESS_NONE' in C:\xampp\htdocs\piwigo\plugins\UserAdvManager\ConfirmMail.php on line 11



Warning:  [mysql error 1146] Table 'piwigo.piwigo_user_confirm_mail' doesn't exist

    SELECT COUNT(*)
    FROM Piwigo_user_confirm_mail
    WHERE id = 'ZD31Pa99bFHxB7i2'
  ; in C:\xampp\htdocs\piwigo\include\functions.inc.php on line 918


Warning: mysql_fetch_row(): supplied argument is not a valid MySQL result resource in C:\xampp\htdocs\piwigo\plugins\UserAdvManager\include\functions_UserAdvManager.inc.php on line 176

Warning: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\piwigo\plugins\UserAdvManager\ConfirmMail.php:11) in C:\xampp\htdocs\piwigo\include\page_header.php on line 98
Ma Gallerie Perso

Mon site de photos personnelles

    * Accueil

Confirmation de votre inscription



Votre clef d'activation unique est érroné ou vous avez déjà validé votre compte, veuillez contacter le webmaster pour régler ce problème.



Propulsé par Piwigo - Contacter Webmestre phpMyVisites




Quelquun aurait-il une idée pour résoudre ce nouveau problème ?
Merci à vous !!

Dernière modification par Korben (2009-05-02 12:41:13)


Piwigo 2.5.1

Hors ligne

#2 2009-04-30 22:23:23

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] Pb création nouveau compte

Salut.

Mets le plugin UserAdvancedManager à jour (dernière version 2.10.5) et je pense que çà ira mieux ;-)

Hors ligne

#3 2009-04-30 22:33:31

Korben
Membre
2008-09-17
139

Re: [Résolu] Pb création nouveau compte

Je viens de le mettre à jour et ai supprimer mon compte test pour le recréer et ainsi refaire les tests et comme tout à l'heure le résultat est identique. Ca ne marche pas mieux.
Sinon j'ai tous les plugins qui sont à jour.

En fait, come indiqué dans le message d'erreur, il n'y a pas de table nommée : piwigo_user_confirm_mail
Je viens de vérifier ceci. Et d'ailleurs je ne l'ai jamais vu et rien n'installe cette fameuse table. Ni Piwigo, ni UserAdvManager
Je pense qu'il y a un problème de ce coté là.

Dernière modification par Korben (2009-04-30 22:38:18)


Piwigo 2.5.1

Hors ligne

#4 2009-04-30 22:50:48

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] Pb création nouveau compte

Essaies de désinstaller et supprimer le plugin UserAdvancedManager puis de le réinstaller manuellement au besoin (sans passer par l'installation automatique). Il est possible que l'install auto ne copie pas tous les fichiers du plugin ou, tout du moins, pas correctement.

J'ai fait plusieurs essais d'ajout et de suppression de ce plugin avec activation à l'issue sur ma galerie local sous Wampserver et la table en question se créé bien à chaque fois.

Hors ligne

#5 2009-05-01 15:53:43

Korben
Membre
2008-09-17
139

Re: [Résolu] Pb création nouveau compte

Bonjour,

J'ai fait ce que tu as dit à savoir désinstaller et réinstaller le plugin, ceci a bien créé les tables mais celles-ci ne se remplissent pas et aucun envoi de mail n'est effectué alors qu'il est bien noté dans le paramétrage que l'envoi d'un mail est effectué lorsqu'un utilisateur s'inscrit.
Un mail est juste envoyé à l'administrateur mais aucun mail n'est envoyé à l'utilisateur.


Piwigo 2.5.1

Hors ligne

#6 2009-05-01 20:46:33

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] Pb création nouveau compte

Oui, je confirme le bug. Je ne comprends pas encore où se trouve le problème mais j'y travaille.

De plus, il y a également un problème avec l'affectation des nouveaux inscrits dans les groupes spécifiques et les status... Pas encore au point mon affaire. Désolé :-(

Hors ligne

#7 2009-05-01 20:55:55

Korben
Membre
2008-09-17
139

Re: [Résolu] Pb création nouveau compte

J'ai réussi à faire l'envoi des mails à la fois à l'administrateur et aussi à l'utilisateur mais lorsque l'utilisateur confirme son mail, voici ce qu'il a à l'écran :



Notice: Use of undefined constant ACCESS_NONE - assumed 'ACCESS_NONE' in C:\xampp\htdocs\piwigo\plugins\UserAdvManager\ConfirmMail.php on line 11

Warning: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\piwigo\plugins\UserAdvManager\ConfirmMail.php:11) in C:\xampp\htdocs\piwigo\include\page_header.php on line 98
Ma Gallerie Perso

Mon site de photos personnelles

    * Accueil

Confirmation de votre inscription



Votre clef d'activation unique est érroné ou vous avez déjà validé votre compte, veuillez contacter le webmaster pour régler ce problème.




Si quelqu'un peut m'aider à résoudre ce pb ? Ce serait cool.
Merci


Piwigo 2.5.1

Hors ligne

#8 2009-05-01 21:06:03

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] Pb création nouveau compte

Korben a écrit:

J'ai réussi à faire l'envoi des mails à la fois à l'administrateur et aussi à l'utilisateur

???
Qu'as-tu fais pour que l'envoi du mail à l'utilisateur fonctionne ? Cà ne fonctionne toujours pas pour moi en mode débug du plugin.

Pour le second problème, je sais d'où çà vient et je l'ai corrigé chez moi. Mais j'attends de trouver une solution au problème d'envoi de mail avant de publier une version corrective du plugin.

Hors ligne

#9 2009-05-01 21:27:30

Korben
Membre
2008-09-17
139

Re: [Résolu] Pb création nouveau compte

En fait j'ai le plugin "NBC UserAdvManager v2.10.6" qui est maintenant désactivé et le plugin "User Advanced Manager v2.0.2-beta" qui est activé.
J'ai dû me servir du plugin "NBC UserAdvManager" pour créer les différentes tables dans la base et ensuite comme les mails ne fonctionnaient pas j'ai activé le plugin "User Advanced Manager" et là l'envoi de mail fonctionne, j'ai juste les messages d'erreur que j'ai mis plus haut.

Et pour l'envoi de mail j'ai aussi ceci comme paramètre dans le fichier "config_local.inc.php" : $conf['smtp_host'] = 'monFAI';

Si tu des des solutions, je suis preneur.

Dernière modification par Korben (2009-05-01 21:29:23)


Piwigo 2.5.1

Hors ligne

#10 2009-05-01 21:31:35

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] Pb création nouveau compte

Korben a écrit:

En fait j'ai le plugin "NBC UserAdvManager v2.10.6" qui est maintenant désactivé et le plugin "User Advanced Manager v2.0.2-beta" qui est activé.

Alors là, j'en perds mon latin... User Advanced Manager était un "brouillon" de NBC_UserAvancedManager. Faut croire que le brouillon fonctionnait mieux que la version définitive...

Je vais voir dans les archives du plugin si je parviens à trouver la différence qui génère ce pb.

[Edit] Pour m'éviter des recherches trop fastidieuses : Quelle est ta version de User Advanced Manager ?[/Edit]

Dernière modification par Eric (2009-05-01 21:34:54)

Hors ligne

#11 2009-05-01 21:38:40

Korben
Membre
2008-09-17
139

Re: [Résolu] Pb création nouveau compte

Pour m'éviter des recherches trop fastidieuses : Quelle est ta version de User Advanced Manager ?

Comme je te l'ai dit tout à l'heure :
- NBC UserAdvManager v2.10.6
- User Advanced Manager v2.0.2-beta


Piwigo 2.5.1

Hors ligne

#12 2009-05-01 21:47:24

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] Pb création nouveau compte

Pardon, j'ai lu trop en diagonale.

Merci, je te tiens au courant.

Hors ligne

#13 2009-05-01 21:57:35

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] Pb création nouveau compte

Je n'arrive à rien...

J'ai un gros doute sur la validité des fichiers. Pourrais-tu m'envoyer en PM le Zip du plugin User Advanced Manager que tu as, stp ?

Hors ligne

#14 2009-05-01 22:08:06

Korben
Membre
2008-09-17
139

Re: [Résolu] Pb création nouveau compte

Comment je fais pour t'envoyer en PM le ZIP ??


Piwigo 2.5.1

Hors ligne

#15 2009-05-01 22:12:06

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] Pb création nouveau compte

Tu m'envoies un PM en précisant ton email perso, j'y réponds et tu réponds à ma réponse en joignant le fichier zip.

Hors ligne

  •  » Utilisation
  •  » [Résolu] Pb création nouveau compte

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact