•  » Installation
  •  » Impossible d'upgrader de 1.7.2 vers 2.0.1

#1 2009-03-24 19:28:51

TokKy
Membre
Tarn (profond)
2007-08-25
8

Impossible d'upgrader de 1.7.2 vers 2.0.1

Bonjour,

Je voudrais faire évoluer ma plateforme de la version 1.7.2 vers PiWiGo 2.0.1.
Mais il semblerai que qqch m'y empèche, monsite http://photos.tok.fr est hébergé sur une dédibox avec du php5 sur apache2.

Les authorisations sont a 777 sur toute l'arborescence et le dossier _data et _data/templates_c/ ont été créé a la racine du site mais sans résultats... j'ai déplacé ce dossier un peu partout dans les dossiers parents et même dans le path_root de apache2 sans succès non plus.

Je suis sec, mon site est KC depuis deux jours et je n'y arrive pas.

voici le message d'erreur que j'ai qd je l'ance l'upgrade :

Piwigo encountered a non recoverable error

/templates_c pas d'accès en écriture

#1    mkgetdir /home/http/tok.fr/photos/include/template.class.php(61)
#2    Template::Template /home/http/tok.fr/photos/upgrade.php(188)

HELP !!


mon portail de photos  made in PWG http://photos.tok.fr

Hors ligne

#2 2009-03-24 20:33:53

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: Impossible d'upgrader de 1.7.2 vers 2.0.1

"dossier _data et _data/templates_c/ ont été créé a la racine du site "
Pas à la racine du site mais dans ./photos/ (répertoire de l'installation).


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#3 2009-03-24 20:41:57

TokKy
Membre
Tarn (profond)
2007-08-25
8

Re: Impossible d'upgrader de 1.7.2 vers 2.0.1

ils sont dans /home/http/tok.fr/photos/_data/templates_c/

non ?


mon portail de photos  made in PWG http://photos.tok.fr

Hors ligne

#4 2009-03-24 22:26:04

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: Impossible d'upgrader de 1.7.2 vers 2.0.1

Ça devrait être bon.

mais le message indique un pb de chmod sur /templates_c


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#5 2009-03-24 22:31:46

TokKy
Membre
Tarn (profond)
2007-08-25
8

Re: Impossible d'upgrader de 1.7.2 vers 2.0.1

et pourtant :

tokky@sd-xxxxx:/home/http/tok.fr/photos$ ls -l
total 272
-rwxrwxrwx  1 www-data www-data  3106 2009-03-23 16:48 about.php
-rwxrwxrwx  1 www-data www-data  5670 2009-03-23 16:48 action.php
drwxrwsrwx  5 www-data www-data  4096 2009-03-23 16:49 admin
-rwxrwxrwx  1 www-data www-data  6777 2009-03-23 16:49 admin.php
-rwxrwxrwx  1 www-data www-data  2446 2009-03-23 16:49 category.php
-rwxrwxrwx  1 www-data www-data 12379 2009-03-23 16:49 comments.php
drwxrwsrwx  3 www-data www-data  4096 2009-03-24 10:15 _data
drwxrwsrwx  2 www-data www-data  4096 2009-03-23 16:49 doc
-rwxrwxrwx  1 www-data www-data  6703 2009-03-23 16:49 feed.php
drwxrwsrwx  5 www-data www-data  4096 2008-08-18 16:21 galleries
-rwxrwxrwx  1 www-data www-data  3736 2009-03-23 16:49 identification.php
drwxrwsrwx  5 www-data www-data  4096 2009-03-24 10:52 include
-rwxrwxrwx  1 www-data www-data  8651 2009-03-23 16:50 index.php
drwxrwsrwx  3 www-data www-data  4096 2009-03-23 16:50 install
-rwxrwxrwx  1 www-data www-data 12975 2009-03-23 16:50 install.php
drwxrwsrwx 11 www-data www-data  4096 2009-03-23 16:52 language
-rwxrwxrwx  1 www-data www-data  4059 2009-03-23 16:52 nbm.php
-rwxrwxrwx  1 www-data www-data  3791 2009-03-23 16:52 notification.php
-rwxrwxrwx  1 www-data www-data  6351 2009-03-23 16:52 password.php
-rwxrwxrwx  1 www-data www-data 25884 2009-03-23 16:52 picture.php
drwxrwsrwx 19 www-data www-data  4096 2009-03-23 17:54 plugins
-rwxrwxrwx  1 www-data www-data  3259 2009-03-23 16:53 popuphelp.php
-rwxrwxrwx  1 www-data www-data  9356 2009-03-23 16:53 profile.php
-rwxrwxrwx  1 www-data www-data  2704 2009-03-23 16:53 qsearch.php
-rwxrwxrwx  1 www-data www-data  3168 2009-03-23 16:53 random.php
-rwxrwxrwx  1 www-data www-data  3499 2009-03-23 16:53 register.php
-rwxrwxrwx  1 www-data www-data  6820 2009-03-23 16:53 search.php
-rwxrwxrwx  1 www-data www-data  7549 2009-03-23 16:53 search_rules.php
-rwxrwxrwx  1 www-data www-data  6149 2009-03-23 16:53 tags.php
drwxrwsrwx  3 www-data www-data  4096 2008-08-18 16:21 template
drwxrwsrwx  3 www-data www-data  4096 2009-03-23 17:42 template-common
drwxrwsrwx  4 www-data www-data  4096 2009-03-23 17:42 template-extension
drwxrwsrwx  2 www-data www-data  4096 2009-03-23 16:55 tools
-rwxrwxrwx  1 www-data www-data  4260 2009-03-23 16:55 upgrade_feed.php
-rwxrwxrwx  1 www-data www-data 11650 2009-03-23 16:55 upgrade.php
-rwxrwxrwx  1 www-data www-data 14418 2009-03-23 16:55 upload.php
-rwxrwxrwx  1 www-data www-data 12009 2009-03-23 16:55 ws.php


et


tokky@sd-xxxxx:/home/http/tok.fr/photos/_data$ ls -l
total 4
drwxrwsrwx 2 www-data www-data 4096 2009-03-23 22:13 templates_c


Je ne peux pas faire mieux.

Il faut peut être que je place ce dossier ailleurs ?

Dernière modification par TokKy (2009-03-24 22:32:33)


mon portail de photos  made in PWG http://photos.tok.fr

Hors ligne

#6 2009-03-24 22:36:19

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: Impossible d'upgrader de 1.7.2 vers 2.0.1

Chez moi, ils sont en 755 et cela marche très bien.
Pas d'idée pour l'instant.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#7 2009-03-27 20:19:42

TokKy
Membre
Tarn (profond)
2007-08-25
8

Re: Impossible d'upgrader de 1.7.2 vers 2.0.1

si qq'un pouvait me donner le sequencement de l'upgrade ça me permettrai d'analyser où se trouve le soucis

merci d'avance


mon portail de photos  made in PWG http://photos.tok.fr

Hors ligne

#8 2009-03-27 20:55:49

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: Impossible d'upgrader de 1.7.2 vers 2.0.1


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#9 2009-03-29 19:40:49

TokKy
Membre
Tarn (profond)
2007-08-25
8

Re: Impossible d'upgrader de 1.7.2 vers 2.0.1

merci

mais je parlais pas de ça, mais plutot au niveau du code, quels fichiers sont appeler par tel ou tel fonctions, quels actions sont déclanché.....

la parti séquences du code !

merci d'avance


mon portail de photos  made in PWG http://photos.tok.fr

Hors ligne

#10 2009-06-09 12:32:07

graphonie
Membre
2009-06-09
5

Re: Impossible d'upgrader de 1.7.2 vers 2.0.1

Bonjour à tous,

Bonjour.

Je rencontre le même message d'erreur, adapté bien sur au chemin de mon site.

Ce site est un site distant, hébergé sous Linux, chez 1and1.fr.


Voici le message d'erreur, dès que j'appelle la page upgrade.php :

"Piwigo encountered a non recoverable error
/templates_c no_write_access

#1    mkgetdir /homepages/12/d203335877/htdocs/arts/galleries/include/template.class.php(61)
#2    Template::Template /homepages/12/d203335877/htdocs/arts/galleries/include/common.inc.php(169)
#3    include_once /homepages/12/d203335877/htdocs/arts/galleries/index.php(26)
"
PHP5
J'ai passé la version php en php 5.29, en me conformant aux préconisations de mon hébergeur, (création d'un fichier .htaccess recopié tant à la base de l'bebergement que dans chacun des réperoires correspondant au site en question) dont le contenu est :
.AddType x-mapp-php5 .php .php3 .php4 .htm .html

J'y ai meme ajouté la commande (lue sur le forum)
SetEnv PHP_VER 5
sans succès dans et l'autre cas.

Mes autres sites en php fonctionnent après cela. J'ai vérifié la bonne prise en compte de cette version nouvelle de php par un phpinfo dont voiic la copie .pdf :
http://arts.musarder.com/arts-musarder- … erveur.pdf


MYSQL
J'ai édité le fichier /include/mysql.inc.php  pour lui ajouter les deux dernieres  lignes 'spéciales Piwigo', et vérifier que le préfixe des tables restait bien celui déjà présent dans ma base de données, de la version 1.70. Voici le contenu de ce fichier, les infos personnelles étant bien sur remplacées par des acronymes :
"<?php
$cfgBase = 'ma_base_chez_1and1';
$cfgUser = 'mon_nom_d_utilisateur';
$cfgPassword = 'mon_pot_de_passe';
$cfgHote = 'l_adresse_de_ma_base_chez_1and1';

$prefixeTable = 'phpwebgallery_';

define('PHPWG_INSTALLED', true);
define('PWG_CHARSET', 'utf-8');
define('DB_CHARSET', 'utf8');
define('DB_COLLATE', '');

?>
"

DOSSIERS de MIGRATION
Conformément aux réponses dlues sur le forum, j'ai crée de mes blanches mimines
tant un répertoire /homepages/12/d203335877/htdocs/arts/galleries/_data et son sous répertoire /homepages/12/d203335877/htdocs/arts/galleries/_data/templates_c
qu'un réprtoire /homepages/12/d203335877/htdocs/arts/galleries/templates_c
qui sont donc tous deux au même niveau hierarchique que les autres répertoires de Piwigo (galleries, admin, include, doc,...)
J'ai chmodé avec succès chacun des répertoires en 0777.


Pourtant , je reste toujours bloqué sur la même erreur.

La configuration php5 de mon hébegeur serait elle en cause ? Merci de m'éclairer, et de m'aider à résoudre ce problème

Meric d'avance

Jean-François

Hors ligne

#11 2009-06-09 12:48:48

rio
Équipe Piwigo
Paris
2006-07-24
1589

Re: Impossible d'upgrader de 1.7.2 vers 2.0.1

Non je dirais plutôt un problème de template. Il est possible qu'un template utilisé n'existe plus dans la nouvelle version.
Fais une recherche sur le forum, le problème doit être réglé directement sur la base de données.

:-))


-> /<Ä®¿M <-
http://riohome.free.fr
Il forum è anche in ITALIANO

Hors ligne

#12 2009-06-09 13:01:26

graphonie
Membre
2009-06-09
5

Re: Impossible d'upgrader de 1.7.2 vers 2.0.1

Précision ultime :
Ma version d eMysql est la 5.0.

Merci de ta réponse, Rio,
Je n'utilisai pas d'autre template que le yoga par defaut, sans amenagements, de memoire.
Dois-je donc placer dans les 3 dossiers /templates , /template-extension, et /template-common uniquement le template yogoa de la nouvelle version, sans aucune référence à l'ancienne  (javais lu que ces dosseirs tempaltes etaient à sauvegarde, de façon optionnelle) ?
Je vais tester avec ce changement là.

Hors ligne

#13 2009-06-09 13:03:02

rio
Équipe Piwigo
Paris
2006-07-24
1589

Re: Impossible d'upgrader de 1.7.2 vers 2.0.1

Correction.
Ton problème vient probablement d'ailleurs … avant d’avancer, peux-tu revérifier le chmod de ../_data et ../_data/template_c ?
Tu peux supprimer le ../template_c
Merci

:-))


-> /<Ä®¿M <-
http://riohome.free.fr
Il forum è anche in ITALIANO

Hors ligne

#14 2009-06-09 13:10:01

rio
Équipe Piwigo
Paris
2006-07-24
1589

Re: Impossible d'upgrader de 1.7.2 vers 2.0.1

graphonie a écrit:

Dois-je donc placer dans les 3 dossiers /templates , /template-extension, et /template-common uniquement le template yogoa de la nouvelle version, sans aucune référence à l'ancienne  (javais lu que ces dosseirs tempaltes etaient à sauvegarde, de façon optionnelle) ?

Oui, c'est une bonne chose. Regarde déjà si tu as toujours le message d'erreur avec les fichier d'origine. En suite on regardera avec les modifs que tu as pu faire dans le passé.

:-))


-> /<Ä®¿M <-
http://riohome.free.fr
Il forum è anche in ITALIANO

Hors ligne

#15 2009-06-09 14:53:28

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: Impossible d'upgrader de 1.7.2 vers 2.0.1

graphonie a écrit:

...
Dois-je donc placer dans les 3 dossiers /templates , /template-extension, et /template-common uniquement le template yogoa de la nouvelle version, sans aucune référence à l'ancienne  (javais lu que ces dosseirs tempaltes etaient à sauvegarde, de façon optionnelle) ?

C'est surtout le template-extension qui va pouvoir être réutilisé dans le futur.
Dans le futur, c'est à dire tant qu'on ne changera pas à nouveau de moteur de template.
On vient de le changer... Donc à priori, pas de problème pendant quelques temps.
(Mais les anciens templates de PhpWebGallery sont incompatibles avec ceux de Piwigo.)

Donc, actuellement: "sans aucune référence à l'ancienne" la réponse est oui, malheureusement.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

  •  » Installation
  •  » Impossible d'upgrader de 1.7.2 vers 2.0.1

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact