Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

mhelleboid
2016-08-19 14:22:54

La dernière  version devrait corriger ce problème https://github.com/Piwigo/Piwigo-Java/r … ag/v0.0.13

oliverfr
2016-06-21 14:24:22

Je viens d'essayer, et je confirme que avec PWG 2.8.1 ça fait la même chose, parse error.

Phil Good1
2016-03-20 21:18:46

Bonjour,

  j ai testé il y a qq semaines cela fonctionnait à merveille..... et aujourd 'hui, j ai ça ....

   "INFO] User Philippe Lebon will sync gallery http://iphilgood.piwigo.com/ with directory /Users/plebon/Desktop/Remote
[INFO] will create album for /Users/plebon/Desktop/Remote/Pho1
[INFO] Connecting...
[INFO] Connect successful
[ERROR] Unable to parse response
[ERROR] Cannot create album for /Users/plebon/Desktop/Remote/Pho1
[INFO] will upload image for /Users/plebon/Desktop/Remote/Pho1/Brocante_2-1.jpg in album with id null
[ERROR] Unable to parse response
[ERROR] Cannot updload image for /Users/plebon/Desktop/Remote/Pho1/Brocante_2-1.jpg

Si vous avez une idées ....

Bonne journée.

     Phil
   http://prodigious-studio.com/

mhelleboid
2015-12-17 19:10:27

ton url est-elle la bonne? peux-tu essayer avec http://iphilgood.piwigo.com ?

PhilGood
2015-12-17 15:23:51

Aï....
cela ne fonctionne plus....
"[INFO] User Philippe Lebon will sync gallery http://iphilgood.piwigo.com/index?/category/249-selects with directory /Users/freelance/Desktop/Selects
[INFO] will create album for /Users/freelance/Desktop/Selects/ConcoursBain_2016_Ph03
[INFO] Connecting...
[ERROR] Unable to connect : Authorization required (code 401)
[ERROR] Error in sync
[INFO] Finished


   Une idée.

Merci

mhelleboid
2015-12-10 20:22:43
oliverfr
2015-12-10 11:03:02

mhelleboid a écrit:

Ok merci pour le retour.
/purge configuration/purge cache

A ce sujet-là, j'avoue que j'ai gardé des cicatrices mentales de la découverte que j'ai faite, il y a bientôt trois ans, que Filezilla gardait, en clair, mes bookmarks SFTP.

Les développeurs du logiciel n'ont jamais changé leur réponse, que c'était tant pis pour les utilisateurs, que ça n'était pas à eux de stocker les informations de connexion de façon cryptée ou non-exploitable, utilisez keepass ou retenez de mémoire vos mots de passe grow newbs, que de toutes façons si quelqu'un a accès à ta machine c'est trop tard, etcetera... N'empêche que, ils n'allaient pas non plus crier sur tous les toits l'information, que leur politique met en danger des milliers d'utilisateurs en leur faisant risquer de se faire voler des données cruciales. Désinstallez FZ, sitemanager.xml reste encore en place avec vos données.

Et là, pourquoi ça m'a dérangé, c'est que (1) je ne suis pas parvenu à savoir où étaient conservées les informations de connexion (je crois avoir demandé la purge de tous les dossiers temporaires que je connais, y-compris dans Ccleaner et Java-config, et c'était toujours retenu, je suis très curieux de savoir où ça se trouve en fait :D ) et (2) je ne sais pas si les informations de connexion sont conservées en clair ou pas.

Je ne me plains pas, hein, c'est juste pour donner un contexte, dire pourquoi, à mes yeux, ça peut avoir de l'importance :)

mhelleboid
2015-12-07 20:41:13

Ok merci pour le retour.
Je note les améliorations que tu cites dans les choses à faire : redirect auto/purge configuration/purge cache

oliverfr
2015-12-07 11:04:40

Vivi, pour le 301, je suggérais justement de le faire automatiquement (retenter avec/sans www) sans fermer sur une erreur.

Quant au reste de mon rapport d'erreurs, j'ai retenté ce matin, avec une install vierge, et là, c'était bon, aucun problème, ça a marché bien.

Il reste juste l'aspect légèrement dérangeant de voir le programme se rappeler des informations que j'ai données, sans avoir l'option de les effacer, et sans savoir où elles sont stockées, c'est troublant (sans gravité, hein.)
Peut-on envisager l'ajout d'un bouton pour "purger" les informations précédemment saisies dans les champs ?

mhelleboid
2015-12-03 20:37:47

oliverfr, move 301 permanantly indique certainement une redirection auto de http://www.mygallerie.com vers https://www.mygallerie.com, ou de http://mygallerie.com vers http://www.mygallerie.com je vais regarder ça
pour le deuxième essai, les images doivent être indiquées comme déjà uploadées dans le cache local. il faudrait supprimer les fichiers .piwigo_import_tree.txt dans l'arbo des photos

mhelleboid
2015-12-03 20:35:06

patrick_dtls, as-tu coché l'option "trust self-signed SSL certificate" ?

patrick_dtls
2015-12-03 09:44:48

Bonjour,
J'ai testé la V 0.0.12, toujours pas de connexion en https avec certificat auto-signé.
Les dossiers avec caractères accentués voient leurs noms affichés correctement dans la fenêtre sync, mais leur nom est tronqué au premier caractère accentué dans l'arborescence piwigo.

A+

patrick

oliverfr
2015-12-02 13:11:23

Hoooo, bravo, voilà, vous l'avez porté sous windows!! Merci, je teste :)

Version utilisée: https://github.com/Piwigo/Piwigo-Java/r … ag/v0.0.12

... bon, aie. Premier essai, j'ai une série d'erreurs, mais très probablement causées par une installation ratée.

Ma méthode de réinstallation vise à garder les utilisateurs existants, les plugins, les options, et les petits changements de code apportés ici ou là (par exemple, supprimer le lien permettant de supprimer l'historique résumé en maintenance).
. copier un piwigo qui marche par rsync des fichiers à l'exclusion des fichiers image ( --exclude='upload/' --exclude='_data'  ),
. dupliquer la BDD d'un piwigo existant puis mettre à jour le nom de base de données dans /local/config/database.inc.php
. vider certaines tables de la BDD dupliquée ( piwigo_categories - piwigo_comments - piwigo_comments_categories - piwigo_history - piwigo_history_summary - piwigo_images - piwigo_images_category - piwigo_image_tag - piwigo_search - piwigo_subscribe_to_comments - piwigo_tags )

- Dans remotesync-ui

- J'avais tapé mon domaine de test sans le "www", j'ai eu un échec immédiat, 301 moved. Je pense qu'il faudrait une option de réessayer d'abord avec puis sans www en cas d'erreur terminale 301.

- Je me suis dit que j'allais parcourir le résultat web avant la fin de l'upload, ça affiche un piwigo cassé côté visiteurs, avec juste un message d'erreur texte:
«
Notice: Undefined offset: 1537 in (le path de la galerie de test)/include/category_cats.inc.php on line 298 Notice: Undefined offset: 1229 in (le path de la galerie de test)/include/category_cats.inc.php on line 298

    Catchable fatal error: Argument 2 passed to DerivativeImage::__construct() must be an instance of SrcImage, null given, called in (le path de la galerie de test)/include/template.class.php on line 1275 and defined in (le path de la galerie de test)/include/derivative.inc.php on line 194
»

Si j'actualise souvent la page, cela charge parfois une version sans CSS de la miniatures de couvertures + titre des uploads déjà faits

- les uploads sont terminés, la gallerie piwigo est encore cassée, apparemment, même erreur en page d'accueil des visiteurs publics (même après control-F5, pas de cache)

- cependant, je peux accéder à l'intérieur d'un album, et là ça s'affiche correctement

- Dans l'admin, en gestion des albums, je constate que le compte du nombre d'images est incorrect. Tel album est listé comme contenant 90 images, je l'ouvre, non en fait il y en a 29 dedans.
. Tel autre album est listé comme contenant 33 images, il en contient en fait dix quand on l'ouvre.
. Le recordman est listé comme contenant 1069 photos, alors qu'en fait il contient... tiens, il contient les images des deux albums voisins en plus des siennes ?!? Pour un total de seulement 169 "vrais" wallpapers cette fois-ci.


**

Bon, on réessaye de nouveau, cette fois-ci avec une VRAIE installation vierge, plus de bricolage avec duplication/edits et tout.

Je retente une sync sur cette nouvelle install :

[INFO] User admin will sync gallery (domaine de test)/galeriesdetest/ with directory (mon dossier de test)
[INFO] Finished

Et c'est tout, rien ne s'uploade :D

C'est un bug de l'uploader, je peux changer le nom d'utilisateur et rajouter des caractères aléatoires dans le password, la même chose se produit. Changer l'URL de la galerie web provoque une erreur 404, par contre changer de travers le username, ou le password, là c'est buggé.

Et je peux fermer puis relancer le .jar autant que je veux, il continue de se rappeler les informations et pondre le même message d'erreur.

Je tente de supprimer les fichiers temporaires de l'ordinateur (Ccleaner, sur windows 7), et de Java (panneau de contrôle Java), mais le .jar se rappelle toujours des réglages. Je le supprime, le re-télécharge, il continue de se rappeler les réglages buggés.

Fin des tests pour moi, je ne sais pas trop quoi faire de plus.

plg
2015-11-26 12:15:24

plg a écrit:

Bonjour patrick_dtls,

patrick_dtls a écrit:

Le site est en https avec un certificat auto-signé [...]

[ERROR] Unable to connect : Unable to read response content

[Github] Piwigo-Java issue #1

mhelleboid a livré une version 0.0.11 qui devrait corriger le problème. A tester :-)

plg
2015-11-25 20:05:24

Bonsoir nicophotographies,

nicophotographies a écrit:

- Y a-t-il une documentation ? (qui pourrait éventuellement répondre à certaines questions qui suivent...)

Non, rien pour le moment. On va, au minimum, faire quelque chose du genre http://fr.piwigo.org/doc/doku.php?id=to … importtree pour Piwigo Import Tree.

nicophotographies a écrit:

- Le terme "synchronisation" sous-entend pour moi que le transfert de données se fait dans les deux sens Serveur <-> Dossier locaux. Est le cas ?

Non, c'est une synchronisation dans un seul sens, du local vers Piwigo. D'ailleurs, cela ne prend, pour le moment, en compte que les ajouts : si tu supprimes un fichier en local, cela ne le supprime pas sur Piwigo.

nicophotographies a écrit:

- Si, ce n'est pas le cas. Lors d'un premier lancement, est il possible de rapatrier le tout pour ensuite utiliser ce logiciel pour ajouter ses photos ? Ou bien il n'est utilisable que pour la création d'une nouvelle galerie ?

Il n'y a pas d'outil pour récupérer une arborescence Piwigo vers les fichiers locaux. Cela pourrait parfaitement se faire, techniquement parlant (dans ce logiciel ou un autre).

nicophotographies a écrit:

- Les mots-clefs et autres éventuelles données liées aux photos sont-elles synchronisée d'une manière ou d'une autre via ce logiciel ?

Si tu parles des mots-clef IPTC, si ton Piwigo est configuré pour les exploiter ($conf['use_iptc']) alors ce sera pris en compte. On passe par les méthodes habituelles de l'API Piwigo pour ajouter les photos. Exactement les mêmes que celles utilisées par Lightroom, pLoader ou l'application iOS (par exemple pwg.images.add)

nicophotographies a écrit:

- Pour les bogues éventuelles, faut il passer par Github ou on peut les remonter ici ?

Idéalement sur Github en anglais. Sinon en créant un nouveau topic pour chaque bug sur le forum Beta-testing

Bon test :-)

Pied de page des forums

Propulsé par FluxBB