Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

a310v6
2012-11-11 12:28:22

Bonjour,
je galère aussi pas mal avec ce plugin Icy Modify Picture ! Pour qu'il fonctionne autrement qu'avec admin ou webmaster  il faut créer un fichier ACL (icy_acl.zml) dans /piwigo/local/config/icy_acl.zml

Un exemple de fichier se trouve dans /Icy_picture_modify/doc/ icy_acl.zml.sample
La syntaxe est décrite dans le fichier/Icy_picture_modify/doc/zaml.md
Tout est expliqué ici: https://github.com/icy/icy_picture_modify

Perso j'ai copier/coller le fichier "icy_acl.zml.sample"dans /piwigo/local/config et je l'ai renommé "icy_acl.zml", pour le personnaliser, ne sachant pas ouvrir correctement un fichier .zml je le renomme provisoirement en .php le temps d'y faire mes modifs.

Mais bon ce n'est pas très pratique pour moi qui ne connais pas grand chose en PHP ! dommage que community d'usage plus simple n'offre pas cette option de pouvoir modifier les photos après téléchargement ...
Bonne journée

ghezibde
2012-11-09 21:54:13

Bonsoir,
je viens de réactiver le plugin Icy Modify Picture et bing ....... l'option "Ajouter des photos" disparait à nouveau du menu principal pour les les invités.
Si je desactive ce plugin, l'option "Ajouter" réapparait aussitôt,
Cela est d'ailleurs tout à fait normal puisque "Icy Modify Picture" gère aussi l'upload !
Il faut maintenant arriver à paramétrer ce module
Ce vais ouvrir un nouveau fil pour demander de l'aide à ce sujet.

Un grand merci à tous,
André

ddtddt
2012-10-26 18:32:40

Bonjour,
Il manquait des fichiers de mise à jour dans install/db
il est difficile d'éviter les erreurs de transfert.

Les problèmes de taille c'est surtout que free limite énormément la taille des photos.
ils utilisent uniquement GD pour générer les taille multiple

ghezibde
2012-10-26 08:34:19

Bonjour,

Bon avec l'aide de plg il semblerais que l'on est réussis à faire passer la mise à jour ouf ;-)

Un immense merci à toi et à l'équipe !

Donc des erreurs de transfert FTP il manquais des fichiers.
Cela a entrainé un problème sur la mise à jour de la base

cela me surprend puisque j'ai transféré deux fois à partir du zip de téléchargement et que j'ai lancé le update manuellement sur le site.
Où ai-je donc raté quelque chose et quelle précaution prendre la prochaine fois ?

Tu risque cependant quand même d'être embêté a causse de la taille des photos.

Quelle type d'embêtement de taille ?
A priori tout marche sauf le redimensionnement (j'ai réglé le redimendionnement pour les images de plus de 2100 pixels et j'ai remarqué des upload d'hier d'images de 2200 qui sont restées telles quelles).

Encore merci pour ce joyau et pour l'implication et la compétence de l'équipe !
Que du bonheur !

André

ddtddt
2012-10-24 23:12:14

Bonsoir,

Bon avec l'aide de plg il semblerais que l'on est réussis à faire passer la mise à jour ouf ;-)

Donc des erreurs de transfert FTP il manquais des fichiers.
Cela a entrainé un problème sur la mise à jour de la base

et puis c'est free ....

Mais bon tout semble fonctionner ;-)

Tu risque cependant quand même d'être embêté a causse de la taille des photos.

ddtddt
2012-10-20 09:32:24

re,

Peux tu me faire une capture d'écran des table de ta base de données

ddtddt
2012-10-20 08:43:24

ghezibde a écrit:

(je suis sous (k)ubuntu et j'administre plusieurs autres sites depuis quelques années).

Très bon choix OS ;-)

je vais encore faire des essais mais je ne comprends pas se qui bloque
J'ai essayé de désactiver des plugins et de les réactiver mais sans succès :-(

ghezibde
2012-10-20 08:34:29

Bonjour,
merci,
oui, par réinstaller pour télécharger, dezipper et transmettre par FTP.
(je suis sous (k)ubuntu et j'administre plusieurs autres sites depuis quelques années).

ddtddt
2012-10-20 08:01:08

ghezibde a écrit:

- réinstaller les deux plugins Community et Upload 1 Menu

Bonjour,

Quand tu parle de réinstaller, tu parle bien de supprimer les fichier par FTP
Re télécharger la dernière version
la décompresser avec 7-zip par exemple (pas le dézipeur de win)
et envoyer par FTP

ghezibde
2012-10-19 22:35:19

Bonsoir ddtddt,
merci du temps que tu consacres à ce problème.
J'ai retransféré tous les fichiers de community + du code général de pwigo + des autres plugins.
J'observe que cela ne semble pas résoudre le souci.
de quoi cela peut-il bien venir ?
Cordialement,
andré

ddtddt
2012-10-18 23:37:58

Bon j'ai passé un moment à chercher et rien :-(

Est ce que tu peux transférer à nouveau les fichiers de la dernière version de community

ddtddt
2012-10-18 07:22:28

Bonjour,

Je peux juste te proposer de m'envoyer un code webmaster et le liens de ta galerie par mél que je regarde

ghezibde
2012-10-17 23:03:33

j'ai essayé bcp de choses:
- restaurer les options par défaut du plugin
- tester avec l'album Community ..... après déconnxion le lien disparait
- réinstaller les deux plugins Community et Upload 1 Menu
- rendre mon album Community privé puis à nouveau public
- Déplacer les photos de l'album dans un autre album fraichement créé, supprimer l'album jusqu'ici utilisé, renommer le nouvel album

Rien n'y fait !

Je n'ai plus d'autres pistes à explorer pour l'instant.

Toute idée bienvenue,

André

ddtddt
2012-10-17 22:48:32

Bonsoir

Est ce que tu as essayé de supprimer et de recréer la permission dans extension:303 ?

ghezibde
2012-10-17 21:50:56

Bonsoir à tous les deux,
désolé mais le diagnostic pose encore problème:
- mon album Dépôt est et a toujours été Public, il est visible par les simples visiteurs.
- le problème est apparu lors de l'installation de la mise à jour, des visiteurs m'ont déjà envoyer des images par ce bien auparavant.

> Est ce que le répertoire dépôt existe bien ?
oui, et il contient des images envoyées avant l'install et non traitées à ce jour

Est ce que tu as essayé de renommer ce répertoire (mots sans caractère spécial) ?
je viens de le faire et ça ne change rien !
De toute façon, l'ajout marche et l'option apparait au menu une fois connecté.

Je ne comprends pas pourquoi je me retrouve dans cette situation sans raison évidente.

Merci d'avance pour toute aide,
André

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact