Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

mistic100
2012-09-20 16:26:05

vous pouvez essayer de remplacer IBM850, par CP852, CP437, IBM437

r@in | b0w
2012-09-20 16:22:57

Cela ne change rien. Dommage ;)

mistic100
2012-09-20 16:13:33

include/BatchDownloader.class.php, ligne 324

Code:

$zip->addFile(PHPWG_ROOT_PATH . $row['path'], $row['id'].'_'.iconv('UTF-8', 'IBM850', get_filename_wo_extension($row['file'])).'.'.get_extension($row['path']));
r@in | b0w
2012-09-20 15:50:49

Ok. En fait, j'ai ces symboles bizarres avec tous les archiveurs et oui, les photos ont des caractères spéciaux dont le copyright qui permet de définir le niveau de confidentialité des photos.

S'il n'y a rien à faire, alors c'est tant pis.

Merci quand même :)

Ps : pour la bidouille, il faut la tenter où ?

mistic100
2012-09-20 15:47:42

vos fichiers on des caractères spéciaux ? (ce n'est pas un problème dans Piwigo avec les récents changements)

le problème c'est que n'ai pas vraiment la main là dessus, ZipArchive ne supporte pas l'UTF8 (comme c'est écrit sur la page de configuration)

il y a bien des bidouilles comme iconv('UTF-8', 'IBM850') mais ça ne fonctionne pas pour tous les jeux de caractères (j'ai réussi à le faire planter avec des kanjis ou un truc du genre)

alors j'ai abandonné et je laisse tout en vrac, ça donne parfois des chars bizarre mais au moins les fichiers sont là


edit: en plus le "IBM850" à l'air variable, sur d'autres site j'ai vu du "CP852" ou "CP437"

r@in | b0w
2012-09-20 15:42:18

Là, j'ai téléchargé le contenu d'un dossier et j'ai un affichage bizarre pour certains accents et des caractères comme le copyright.

mistic100
2012-09-20 15:40:21

dans la dernière version je ne prend que le nom du fichier (pas de la photo) justement à cause des problèmes de nommage avec espaces, etc.

cela étant je ne comprend pas exactement ce que vous dites, un exemple ?

r@in | b0w
2012-09-20 15:35:21

Petit retour ici.

Je me rends compte que Batch Downloader comme Collections récupère en fait les noms des photos. Or, certains noms sont accentués et ont des caractères spéciaux.

Est-il possible de convertir les noms en UTF8 ou quelque chose dans le genre pour que, dans l'archive créée, les noms ressemblent à des noms ? :)

r@in | b0w
2012-09-14 18:30:01

Lool :)

En tout cas, après la MAJ, tout s'ouvre sans soucis. Je vais faire tester à d'autres personnes pour voir si le bogue est résolu.

mistic100
2012-09-14 18:29:15

ben surtout je sais pas ce que j'ai changé alors c'est cool !

r@in | b0w
2012-09-14 18:22:54

Juste SUPER !

Je n'ai pas toucher à la configuration, j'ai fait la MAJ des deux modules proposés et, avec 7Zip et WinZIP, l'ouverture est OK sans problèmes.

Merci pour ton suivi et félicitations pour la réactivité, as usual, j'ai envie de dire ;)

r@in | b0w
2012-09-14 18:11:55

Ok super, je vais tester de ce pas et je te dis quoi. Merci ;)

mistic100
2012-09-14 18:03:30

version 1.0.4 publiée

si les Zip sont toujours corrompus, ajoutez

Code:

$conf['batch_download_force_pclzip']=true;

dans votre config locale

r@in | b0w
2012-09-14 10:45:10

Merci mistic100, c'est ce que je comptais faire déjà ;)

Merci pour ta patience à toi :)

mistic100
2012-09-14 00:55:08

r@in | b0w a écrit:

Donc, concrètement, je fais quoi à part demander à tout le monde d'installer WinRAR ? :)

mistic100 a écrit:

Enfin je vais ajouter le support de PclZip pour ceux qui n'ont pas ZipArchive, avec un paramètre pour forcer PclZip au besoin

attendre un peu

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact