Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

leptitfredy
2012-06-17 08:54:13

Le problème a complètement disparu avec la mise à jour de Piwigo en 2.3.5, tout refonctionne normalement :)
Merci d'avoir fait ça pour les utilisateurs de 1and1, quelle réactivité !!!!
Merci à l'équipe !!

P@t
2012-06-06 12:14:32

Alors, vu que depuis quelques semaines, ImageMagick ne fonctionne plus chez 1and1, j'ai contacté leur support technique. La solution pour continuer à utiliser ImageMagick, c'est d'insérer la ligne suivante dans le fichier de configuration locale (via LocalFiles Editor):

putenv('MAGICK_THREAD_LIMIT=1');

Zaphod
2012-05-29 19:57:59

A priori, si on met un mauvais répertoire, ça reswitche automatiquement sur GD donc je pense que le répertoire utilisé par piwigo est le bon.

Ca doit bloquer à un autre niveau.

Sinon le support 1&1 m'a répondu qu'imagemagick est effectivement dispo mais que le support 1&1 ne s'en occupe pas.
J'essaierai quand même de téléphoner demain.

Zaphod
2012-05-28 21:19:02

D'après ce qui est dit sur l'admin, 6.6.0-4

ddtddt
2012-05-28 20:39:10

Zaphod a écrit:

J'ai cru que ça marchait, mais en fait si je mets ça, ça bascule automatiquement sur GD.

ok merci
c'est donc pas le bon chemin
quelle version d'ImageMagick tu as ?

Est ce que le support t'as indiqué le chemin d'installation ?

Zaphod
2012-05-28 20:17:07

J'ai cru que ça marchait, mais en fait si je mets ça, ça bascule automatiquement sur GD.

ddtddt
2012-05-28 11:49:47

Zaphod a écrit:

Je vais demander, mais je n'ai pas encore eu de réponse à ma première question ;)

Sinon pour la différence GD / ImageMagick, cf. ici :
http://fr.piwigo.org/forum/viewtopic.ph … 92#p167192

Comme je dis dans ce fil, je pense que la majorité des visiteurs ne verront pas la différence.
Et d'ailleurs, sur une seule image, la différence n'est pas forcément évidente.
En revanche, sur une page de miniatures complète, je trouve que quand tout est généré avec GD ça donne un effet désagréable, comme si tout était flou.

zaphod tu peux essayer cela en config local

$conf['ext_imagick_dir'] = '../bin/ImageMagick-6.3.7';

Gotcha
2012-05-25 20:20:17

Ha voilà, merci ddtddt :-)

ddtddt
2012-05-25 20:14:22

Gotcha a écrit:

Il y a aussi une histoire avec la Haute Définition. Avec GD il n'est pas possible de la redimensionner, je crois...

c'est pas que ce n'est pas possible c'est que Piwigo ne l'autorise pas pour ne pas perdre les données exif

Gotcha
2012-05-25 20:05:59

De plus ImageMagick permet de ne pas perdre les méta-données EXIF/IPTC. Or il me semble qu'avec GD ce n'est pas le cas.
Il y a aussi une histoire avec la Haute Définition. Avec GD il n'est pas possible de la redimensionner, je crois...

Zaphod
2012-05-25 14:36:36

Je vais demander, mais je n'ai pas encore eu de réponse à ma première question ;)

Sinon pour la différence GD / ImageMagick, cf. ici :
http://fr.piwigo.org/forum/viewtopic.ph … 92#p167192

Comme je dis dans ce fil, je pense que la majorité des visiteurs ne verront pas la différence.
Et d'ailleurs, sur une seule image, la différence n'est pas forcément évidente.
En revanche, sur une page de miniatures complète, je trouve que quand tout est généré avec GD ça donne un effet désagréable, comme si tout était flou.

ddtddt
2012-05-25 14:33:42

Est ce que tu peux essayer de demander au support de ton hébergeur dans quel répertoire est installé
imagemagick

Zaphod
2012-05-25 14:32:46

Ca n'est pas un problème de résolution.
C'est juste la qualité du redimensionnement et de la compression.

ImageMagick donne une qualité "correcte" (inférieure tout de même à ce qu'on peut obtenir avec des programmes style Lightroom, mais c'est tout à fait honorable et suffisant pour le web).

Avec GD, les images redimensionnées manquent de piqué, les couleurs sont degradées, etc...

C'est d'autant plus visible que le redimensionnement est violent.
Donc sur les miniatures, c'est génant, sur les photos taille web, moins.

sbastien7566
2012-05-25 14:24:58

J'utilise la bibliothèque GD mais où est le problème de résolution ???
Chez moi, la qualité des images est toujours la même

flop25
2012-05-25 14:13:23

Zaphod a écrit:

A priori external imagemagick est intégré en 2.3.x ?

En tous cas ça marchait il y a quelques jours, et là ça ne marche plus, donc il y a bien eu un changement quelque part chez 1&1 car piwigo n'a pas été modifié.

Clairement moi je ne veux pas me contenter de GD, quand il n'y avait pas external imagemagick je faisais les miniatures et les redim moi même avant envoi vers piwigo pour éviter la perte de qualité trop grande.

pardon autant pour moi

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2020 · Contact