Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

olliwa
2014-09-13 17:56:25

Je rebondis sur l'installation de Piwigo sur Nas Synology.

Personnellement, je viens d'installer la version 2.6 sur un Synology DS214 sans grande difficulté

je bute uniquement sur l'installation complète du plugin "piwigo-videojs"

il est ecrit qu'il faut
Ensure you have MediaInfo install, eg: '/usr/bin/mediainfo'.
Ensure you have FFmpeg install, eg: '/usr/bin/ffmpeg'.

en fait le chemin est sur le synology "/usr/syno/bin"

Gotcha  a propose une méthode simple pour "ext_imagick_dir"

j'aimerai faire pareil pour mediainfo et ffmpeg

est-ce que quelqu'un connait le nom des deux variable a modifer dans piwigo pour qu'il retrouve le chemin de mediainfo et ffmpeg

cordialement

Gotcha
2012-02-04 18:10:55

Avant de faire le ménage, il serait bon d'effectuer les opérations de maintenance.

guy44
2012-02-04 12:44:37

Merci Mascarille pour l'idée, je n'y avais pas pensé
Non il ne voit rien là non plus

donc je vais faire le ménage à la main

Mascarille
2012-02-04 08:42:00

Si tu vas dans administration > photos > gestion par lot > sans album > rafraichir
tu les vois ?
Si oui, tu peux les éliminer sans intervenir directement sur les fichiers
Cordialement

guy44
2012-02-04 00:20:55

J'ai essayé l'ajout proposé par titimoby et cela fonctionne parfaitement : plus aucun souci durant l'importation.
Par contre, j'ai noté que le message sur fond vert, qui s'affiche juste après, n'a pas les bonnes informations : il parle d'un groupe de 43 photos alors que j'en avais importé 74 mais bon, une visite de la galerie ou la gestion par lot des photos a remis les choses dans l'ordre et il voit bien 74 photos partout désormais.

J'ai commencé à mettre des tags, une description (le titre de la photo ?).
Je suis content d'avoir enfin quelque chose qui fonctionne et cela a l'air bien simple et souple. Je verrai à l'usage.

J'ai encore une question concernant mes premiers essais infructueux d'il y a quelques jours, j'ai le répertoire
piwigo/upload/2012/02/01 qui contient
index.htm  pwg_high/
et pwg_high/ contient une ribambelle de fichiers de la forme
20120201224312-c6810857.jpg  20120201224334-8f56a674.jpg  20120201224355-d66ad258.jpg  20120201225540-e2a95f18.jpg  20120201225602-5c46ed77.jpg
qui proviennent d'une importation interrompue.
Comment puis-je m'en débarrasser ? piwigo ne les vois pas depuis l'interface d'administration.

Simplement avec un "rm -f ./20120201*.jpg" ou bien certaines choses sont allées dans une base de données que je dois purger et si oui où est-elle (celle que j'ai créée) et donc phpmyadmin ?

ddtddt
2012-02-02 01:23:31

il te suffit de renommer local/config.inc.php pour que le fichier ne soit plus utiliser

guy44
2012-02-02 00:37:57

Bonsoir,

Débutant avec Piwigo, j'ai décidé de l'installer en local sur un NAS (Syno 211j) pour le prendre en main avant de le mettre en ligne.
j'ai crée mon premier album et essayé d'y mettre des photos (j'ai suivi les pages du wiki comme "mettre en ligne mes premières photos", "ajouter des photos", etc ...). Par la méthode flash : tout semble bien se dérouler mais rien de visible ensuite ; par le formulaire HTML j'obtiens l'erreur
[External ImageMagick] Corrupt image
Dans les deux cas aucune photo visible, accessible ; uniquement en me connectant au NAS et en parcourant son arborescence, je trouve un seul répertoire [/volume1/web]/piwigo/upload/2012/02/01/pwg_high, avec les fichiers des photos.

Les photos que j'envoie sont parfaitement visibles avant transfert (elles viennent de iPhoto sous Mac OS X) et ne semblent pas corrompues.

@titimoby
Est-ce que ce que vous indiquez

Code:

// If library used is external installation of ImageMagick ('ext_imagick'),
// you can define imagemagick directory.
$conf['ext_imagick_dir'] = '/usr/syno/bin';

corrige ce problème ?
Sinon, avez-vous rencontré le même message d'erreur ?
merci !


@gotcha,
j'ai installé le plugin "LocalFiles Editor" version 2.3.0, si j'ajoute le correctif précédent mais qu'il ne change rien ou pire qu'il entraîne d'autres effets regrettables, peut-on facilement revenir en arrière ?
i.e. suffit-il de supprimer "à la main" l'exemplaire du répertoire /local/include ?
merci !

Gotcha
2012-01-07 12:24:29

titimoby a écrit:

il faut modifier include/config_default.inc.php et régler pour un usage de ext_imagik.
juste en dessous, régler le chemin d'accès à imagemagick sur "/usr/syno/bin"

Bonjour,

Merci pour l'explication mais je dois vous avertir que le fichier que vous venez de modifier est très important. Il ne faut pas le modifier ! S'il est modifié, à la prochaine mise à jour de Piwigo, vos modifications seront perdues...
Il y a par contre un moyen de surcharger ce fichier (c'est à dire d'apporter vos modifications par dessus le fichier de départ) en utilisant un moyen simple et sécurisé puisqu'il s'agit d'utiliser le plugin livré par défaut "LocalFiles Editor".

Via le premier onglet, vous ajouter vos modifications (et uniquement vos modifications, pas la peine de réécrire ce qui n'est pas adatpé par vos soins).

Concrètement, dans votre cas, ajouter simplement ceci :

Code:

// If library used is external installation of ImageMagick ('ext_imagick'),
// you can define imagemagick directory.
$conf['ext_imagick_dir'] = '/usr/syno/bin';

Et voilà, vos adaptations seront bien prisent en compte et sauvegardées ;-)

titimoby
2012-01-07 12:03:30

Pour les générations futures :

il faut modifier include/config_default.inc.php et régler pour un usage de ext_imagik.
juste en dessous, régler le chemin d'accès à imagemagick sur "/usr/syno/bin"

tout fonctionne, même si l'ajout de photo est lent puisque je n'ai qu'un modeste 110J

titimoby
2012-01-04 20:33:50

J'ai également installé piwigo sur mon synology 110J.

L'interface est visible, je me connecte et je peux créer des albums.
Quand j'ajoute des photos, il fait le transfert, rafraichit la page... mais rien dans l'album...

Problème de droits de fichiers ?
Problème d'utilisateur pas encore au fait de piwigo ? ;)

Sevy
2011-12-02 19:12:51

Merci sail2far pour ta réponse dont je prends connaissance tardivement.
Dés que je peux je me lance et reviendrai faire un feed back ici

Gotcha
2011-09-24 13:19:16

Merci sail2far

sail2far
2011-09-21 15:51:24

Bonjour j ai aussi un synology le ds108j utiliser comme sauvegarde mais je l utilise pour tester en local mon site web avant publication et j ai reussi a installer piwigo dessus .
activation dans l interface de config du syno de mysql et de phpmyadmin sans specifie aucun parametre specifique (option par defaut)
telechargement des fichiers piwigo pour install manuelle sur mon pc , decompresser ,copier sur le syno dans la partie reservee pour le web dans un repertoire "piwigo",
ensuite avec firefox dans la barre d adresse l adresse_ip_du_syno/piwigo/install.php
remplir le formulaire  config base de donnes
base de donnees : mysql
utilisateur : root (par deefaut sur le syno ou celui que vous avez defini attention ne pas laisse root  cree un autre !!)
pas de mot de passe vide (par defaut mais idem utilisateur cree en un !!)

config utilisateur
identifiant admin : celui qui vous permet de gerer votre syno (celui de l admin du dsm)
mot de passe : celui de l admin du syno
adresse mail :...je vous laisse deviner

et voila un peu de patience et c est bon ca tourne
bon amusement

Mtxr
2011-08-22 15:06:38

Bonjour,
en tant qu'utilisateur de nas Synology, je me permets de commenter...
Je n'ai pas installé piwigo sur un des deux miens, mais un site sous spip qui tourne fort bien.
La seule limite étant le débit de ma conection internet ...
Un nas synology suivant par quel biais on le regarde, n'est qu'un petit ordi avec un serveur apache qui sait faire le serveur web aussi bien que d'autres... si on ne lui demande pas 36000 connections en simultané...
Un nas synology utilisé dans ce qui est sa première raison d'être est excellent dans son domaine. Même si l'on peut trouver mieux pour ce qui est de la gestion (très fine) des sauvegardes.
Donc :
un nas pour sauvegarder...
un nas pour avoir un petit truc qui ne fait aucun bruit, ne prend quasiment aucune place et qui est ouvert en permanence sur le web, et dont il sait très bien se défendre des vilains méchants éventuels.

Je recommande donc les synology (à partir du 210) pour ces deux fonctions : qu'il vaut mieux -en toute rigueur- séparer. Ils les remplissent vraiment très bien !!!

Gotcha
2011-08-11 10:20:25

Merci Eric pour cet éclairage professionnel riche d'instructions :-)

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact