Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Sylvain Nogues
2016-08-30 15:14:20

Bonjour,
Je n'ai pas trouvé le moyen d'autoriser un visiteur à mettre des tags sur les images d'un album, mais pas sur un autre qu'il a le droit de voir.
Est-ce possible ?
Merci,
Sylvain

nicolas
2011-08-19 22:49:33

cljosse a écrit:

Bonjour.
Problème avec la version 0.6.1

Procédure de test:
Local,
plugin actif : user_tags
Navigateur:, FF, IE9
Thème: différentents thème...

  Lorsque j'ouvre une image j'ai le texte Array qui s'affiche en haut de la page: voir image jointe.

Correction apportée:
dans :
***/plugins/user_tags/include/t4u_content.class.php
ligne 58:
modifier comme cela:

Code:

/* $plugin_picture_before = $template->get_template_vars('PLUGIN_PICTURE_BEFORE');
    $plugin_picture_before .= $template->parse('add_tags', true);
    $template->append('PLUGIN_PICTURE_BEFORE', $plugin_picture_before);
*/

    $template->concat('PLUGIN_PICTURE_BEFORE', $template->parse('add_tags', true));

Si cela peut aider...
A+

Cela fait effectivement disparaître le mot "Array" disgracieux mais si un autre plugin utilise ce trigger, il ne fonctionnera plus. Merci tout de même pour l'idée.

cljosse
2011-08-13 11:59:27

Bonjour.
Problème avec la version 0.6.1

Procédure de test:
Local,
plugin actif : user_tags
Navigateur:, FF, IE9
Thème: différentents thème...

  Lorsque j'ouvre une image j'ai le texte Array qui s'affiche en haut de la page: voir image jointe.

Correction apportée:
dans :
***/plugins/user_tags/include/t4u_content.class.php
ligne 58:
modifier comme cela:

Code:

/* $plugin_picture_before = $template->get_template_vars('PLUGIN_PICTURE_BEFORE');
    $plugin_picture_before .= $template->parse('add_tags', true);
    $template->append('PLUGIN_PICTURE_BEFORE', $plugin_picture_before);
*/

    $template->concat('PLUGIN_PICTURE_BEFORE', $template->parse('add_tags', true));

Si cela peut aider...
A+

nicolas
2011-07-18 22:00:29

nicozor a écrit:

Bonsoir

Le problème est effectivement corrigé en 0.6.1
Merci pour cette super réactivité!!

C'est un peu de la chance car je suis en vacances. Mais étant donné le temps qu'il fait, je suis un peu plus dans la maison qu'en vadrouille !

nicozor
2011-07-18 21:57:41

Bonsoir

Le problème est effectivement corrigé en 0.6.1
Merci pour cette super réactivité!!

nicolas
2011-07-18 13:51:41

J'ai corrigé le problème (version 0.6.1) même si la correction proposée par ddtddt me semble bizarre. Mais cela fonctionne !

nicolas
2011-07-16 20:42:34

Oui j'ai découvert le problème mais je n'ai pas compris la raison.
J'ai réussi à contourner en appelant l'url suivante:
/piwigo/admin.php?page=plugins&plugin=user_tags&pwg_token=3a69c906aff1acb0883b861bc26454ee&action=restore

Il faut évidemment changer le token par le votre, à partir d'une autre url.

Nicozor
2011-07-16 16:35:14

Bonjour

Je viens de mettre à jour l'extension en 0.6 et j’obtiens un message d'erreur sur la page d'admin de piwigo
PLUGIN ERROR: "/admin.php" is not a valid file

quand je tente d'aller sur la page d'admin du plugin j'ai le message :
Notice: Undefined index: section in /homez.420/xxxxxxxx/www/piwigo/admin/plugin.php on line 32
Invalid plugin URL

Je ne suis pas le seul dans le cas. J'ai trouvé d'autres utilisateurs avec le même probleme

nicolas
2011-07-14 16:05:30

Je viens de livrer le plugin en version 0.6.0 et désormais le plugin devrait fonctionner.

PierrotLeRouge
2011-07-13 18:25:23

Salut, j'ai le même soucis sur une version installé ce jour.
Sachant que lors de mes précédents test de piwigo, le plugin fonctionnait correctement (je viens de verifier. Version du plugin : 0.4.1, version piwigo:  une 2.0 et quelques. (le fichier upgrade le plus "récent" est upgrade_2.0.0.php dans le  rep d'install)

nicolas
2011-06-19 14:31:45

J'ai un gros doute : est-ce que le plugin fonctionne pour d'autres utilisateurs que les admin quelles que soient les versions de piwigo ou du plugin ? J'ai comme l'impression que non. Me trompe-je ?

nicolas
2011-06-19 11:10:43

Je confirme le problème. Je regarde, je corrige et je publie une nouvelle version.

ddtddt
2011-06-18 23:36:19

mrglobule a écrit:

Merci pour la réponse.
Dommage je trouvais le concept de permettre aux visiteurs de tagguer les photos assez sympa...

La version 2.23 est sortie il n'y a pas très longtemps.

Il faut juste attendre que l'auteur la rende compatible ;-)

N'hésite pas à le notifier pour lui signaler

mrglobule
2011-06-18 15:13:07

Merci pour la réponse.
Dommage je trouvais le concept de permettre aux visiteurs de tagguer les photos assez sympa...

mistic100
2011-06-18 14:41:38

le plugin n'est pas compatible 2.2.3 dont l'administration des tags a été réécrite

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact