Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Gotcha
2010-05-31 15:42:46

himbas a écrit:

Comment modifier le home_page?

http://fr.piwigo.org/doc/doku.php?id=pw … onf_locale

himbas
2010-05-31 15:17:36

Pour laurent.duretz,

Effectivement la multiplication des .htaccess me gêne.  Comment modifier le home_page?
Merci pour la réponse.

laurent.duretz
2010-05-31 15:06:03

Cela est lié à
-> la conf du serveur
-> l'intégration de linkroot dans le code

Vous avez choisi de modifier la conf serveurs à travers le .htacces

Vous auriez pu configurer le paramètre home_page dans la configuration de piwigo

himbas
2010-05-31 14:55:31

Cela fonctionne avec un .htaccess (DirectoryIndex index.php). Merci Gotcha et Nicolas pour vos conseils.

nicolas
2010-05-31 14:41:25

Est-ce un serveur dédié ? Avez-vous accès à la configuration d'apache ?
Dans un cas comme dans l'autre je vous conseille d'ajouter soit dans apache soit dans un fichier ".htaccess" les lignes suivantes :

Code:

Options -Indexes
DirectoryIndex index.php index.html

La première ligne demande à apache d'interdire de lister le contenu des répertoires
La deuxième ligne lui demande d'exécuter le fichier index.php s'il existe si une url se termine par un slash.

Gotcha
2010-05-31 14:28:53

Ok vu.
Seulement je ne suis pas assez bon pour savoir comment y remédier. Nicolas devrait être plus doué que moi avec ce problème.

Je pense deviner que c'est le serveur qui ne sait pas rediriger vers la page "index.php" par défaut lorsqu'on explore le dossier.

Je le préviens d'intervenir :-)

himbas
2010-05-31 10:35:49

Merci pour ta réponse rapide.
J'avais initialement des templates-extensions avec la version 209 mais avec 211 il s'agit de thèmes.
Je t'envoie le lien par courriel.

Gotcha
2010-05-31 10:10:33

Auriez-vous des templates-extension ?

Sinon, un lien nous permettrait de mieux observer le phénomène ;-)

himbas
2010-05-31 10:07:35

Bonjour,
Je suis novice dans l'utilisation de Piwigo je n'ai donc pas tous les prérequis. Je bute sur un problème de lien.
Le lien accueil situé dans la bloc principal m'envoie sur index of .... (répertoire où est stocké piwigo) au lieu de pointer directement sur index.php.
Pourtant ce lien fonctionne par ailleurs puisque je peux lancer l'application qui passe obligatoirement par cet index.php. Les liens categorie fonctionnent très bien.
Ce dysfonctionnement est apparu depuis la mise à jour automatique de 2.09 vers 211 (quel que soit le thème).
Merci pour vos conseils.

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact