Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

chrisncy
2011-11-11 20:04:11

Euh, non... :-( mais la mise à jour du thème stripped
J'ai oublié de préciser...

Gotcha
2011-11-11 15:07:15

La capture d'écran concerne la MAJ de Piwigo ???

chrisncy
2011-11-10 21:03:41

Bon voilà, rien de nouveau... ça "plante toujours"...
Et désormais, les messages d'erreurs sont moins explicites qu'avant
Au moins, on savait quels dossiers ou fichiers bloquaient...
Maintenant, on a le message en pièce jointe. Comme j'ai l'habitude, je remets tous les dossiers en 777 et je m'y reprends en plusieurs fois

Bon, je renonce, je ferai toujours les maj manuelles...
A bientôt !

chrisncy
2011-10-14 18:20:58

saimon a écrit:

quel est le propriétaire de tes fichiers ?

En fait cette fois ci, je n'avais pas de httpd, ni de site1182. je pense que c'est parce que c'est un site de test, et que personne n'y vient voir, donc personne ne lance des trucs bizarres qui changent les droits des dossiers...
Donc, j'ai pu changer tous les droits avec Filezilla (mais je dis peut être une grosse conn^=$ù...)

Et en général quand le propriétaire est httpd, ça bloque aussi. Il faut que je remettre "moi" en propriétaire

J'avoue que je suis paumée dans ces histoires d'écriture
Et que c'est un truc qui me pourrit la phase de mise à jour... Mais bon, tant que ya une procédure manuelle, ça va :-)

Et que je n'ai jamais ce problème avec mon blog en Wordpress... pour lequel je fais toujours les maj "auto" !

saimon
2011-10-14 17:30:17

quelques infos supplémentaires: http://forum.ovh.com/showpost.php?p=103753

Gotcha
2011-10-14 17:23:21

Merci pour ces explications :-)

saimon
2011-10-14 17:20:04

hmmm, je comprend mieux le problème ...
pour comprendre les bases: http://guides.ovh.net/DroitUnix

Lorsque le serveur créé un fichier/dossier, c'est l'utilisateur apache (le serveur), httpd ou www-data suivant les cas, qui a les droits sur ces fichiers.
Lorsqu'on uploade par ftp/filezilla c'est l'utilisateur qui uploade qui a les droits. Mais il faut qu'apache puisse lire les fichiers au minimum, voire écrire pour les mettre à jour.

Enfin tout dépend comment est configuré le serveur mais du coup coté client avec filezilla, avec juste les identifiants nnumériques, il n'y a pas grand chose d'autre à faire q'un chmod 777 quand un problème se présente (plutôt 666 pour les fichiers, qui n'ont pas besoin d'être executables).

Gotcha
2011-10-14 16:29:09

@saimon :
Sous FileZilla, les informations sur le propriétaire sont données sous une forme numérique... Je n'y connais rien et je peine à trouve les informations pour comprendre ces chiffres et ainsi pour faire changer le propriétaire à des fichiers/dossier.

Cette question de "Propriétaire des fichiers" est récurant et ce serait bien qu'un jour nous arrivions à donner une procédure pour changer le propriétaire sur des serveurs.

Merci ;-)

saimon
2011-10-14 10:19:44

quel est le propriétaire de tes fichiers ? si c'est ton utilisateur, alors ces fichiers ne pourront pas accéder aux fichiers de l'utilisateurs httpd (ceux qui sont créés / modifiés directement par le serveur).
Essaye en mettant httpd en propriétaire de tous les fichiers. Comme ça les permissions 755 pour les dossiers et 644 pour les fichiers sont suffisantes.

chrisncy
2011-10-14 08:44:17

En fait, Ils ne me disent pas grand chose
Donc, j'ai trouvé cette solution, que j'ai appliquée sur mon site de test
J'utilise Filezilla, qui permet de changer les droits de chaque dossier et fichier, avec l'option de récursivité
Je mets donc tous les fichiers en 777, après avoir mis la galerie en maintenance
et je passe la maj auto
Et cette fois ci, cela a marché...

Gotcha
2011-08-24 09:37:16

+1 avec ddtddt

ddtddt
2011-08-23 20:32:30

chrisncy a écrit:

:-)
et l'hébergeur me dit de voir avec les développeurs de Piwigo...

moi je veux bien apprendre quelques choses, peux tu lui demander ce qu'il faudrait que l'on change ?

il semblerais qu'il n'y ai pas de problème chez les autres hébergeurs mais s'il nous dit quoi changer et que cela est pertinent, nous sommes preneur ;-)

chrisncy
2011-08-23 19:58:01

:-)
et l'hébergeur me dit de voir avec les développeurs de Piwigo...

ddtddt
2011-08-23 09:12:31

Cela viens du paramétrage du serveur, seul l'hébergeur peux y changer quelques choses

chrisncy
2011-08-23 07:38:49

Eh voilà, cela n'a pas tardé
Mise à jour du thème en cliquant sur le bouton installer
et hop ! message d'erreur "write protected"

Voilà deux images écrans pour que vous voyiez la situation

Bon, pour le thème, maintenant, je sais faire... je fais en manuel, ou je vais changer les droits...

MAIS

Quand c'est une maj de Piwigo, c'est beaucoup plus stressant, car il arrive de ne plus pouvoir reprendre la main sur la maj auto. Et parfois, on n'a pas d'indication sur LE dossier ou LE fichier qui est en erreur d'écriture (c'est le cas aujourd'hui, pour le thème)

Et on doit refaire l'ensemble de la procédure manuelle. C'est pour cela que je ne tente plus jamais la MAJ auto, et que je pars systématiquement en maj manuelle

Sauf si l'un d'entre vous m'explique comment éviter ces blocages.
Merci d'avance...

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact