Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

vincent3569
2010-04-02 12:50:55

un petit up, si d'aventure vous pouvez m'aider sur ce petit plugin

VDigital m'avait une 1ère version, mais celle-ci met le bazard dans le lien "éditer" de la page image (au lieu d'aller sur la photo, je vais à l'accueil de l'admin).

vincent3569
2010-03-16 14:12:14

mon besoin :

j'ai positionné un certain nombre de fonctionnalité du menu vers le footer (connexion, personnalisation, contact).
mon but à terme : ne pas avoir de menu et uniquement une navigation par les images.

mon problème : lorsque je navigue entre les pages, le footer "se vide".
ainsi, sur la page pictures, je perds le lien connexion/deconnexion (suivant si je suis connecté ou pas), et le lien personnalisation.
je ne perds pas le lien administrer (si je suis connecté sur un compte admin).

comment faire pour que ces liens soient correctement affichés sur toutes mes pages ?

la solution : un plugin perso qui contient ce bout de code :

<?php
/*
Plugin Name: contextTransfert
Version: 0.1
Description: Permet de transférer les contexte utilisateur entre les différentes pages de la galerie
Plugin URI: http://www.piwigo.org
*/

if (!defined('PHPWG_ROOT_PATH')) die('Hacking attempt!');

add_event_handler('loc_after_page_header', 'reinit_menubar', 20);

function  reinit_menubar() {
  global $template;
  if (!defined('IN_ADMIN') )
  include_once(PHPWG_ROOT_PATH.'include/menubar.inc.php');
}
?>

ce plugin fait bien ce que j'attendais dans le footer (conservation des liens), mais repositionne à tord le contexte du lien "éditer".

tosca
2010-03-16 13:04:10

Tu nous remets le contenu exact de ton plugin, STP :-)

vincent3569
2010-03-16 13:03:01

sur un autre post, j'ai découvert par hasard un nouvel effet de bord de ce plugin post:136582

j'ai bien mon contexte correct en bas de page, mais je perds le bon fonctionnement du lien "éditer" dans la barre de menu de l'image.
au lieu de pointer vers l'image, il pointe vers l'acueil de l'admin.

une suggestion sur la modif à effectuer pour résoudre ce problème ?

vincent3569
2010-03-09 08:08:51

cette fois c'est ok, je peux naviguer vers les pages d'admin.
merci de ton aide et de ta patience

VDigital
2010-03-09 07:41:44

Il manque une parenthèse fermante (sorry).

if (!defined('IN_ADMIN') )

vincent3569
2010-03-09 00:26:21

pas mieux, bien que pas pareil ;-)

Parse error: syntax error, unexpected T_INCLUDE_ONCE in /mnt/122/free.fr/4/9/vincent.bourganel/piwigo/plugins/contextTransfert/main.inc.php on line 16

VDigital
2010-03-08 22:56:15

<?php
/*
Plugin Name: contextTransfert
Version: 0.1
Description: Permet de transférer les contexte utilisateur entre les différentes pages de la galerie
Plugin URI: http://www.piwigo.org
*/

if (!defined('PHPWG_ROOT_PATH')) die('Hacking attempt!');

add_event_handler('loc_after_page_header', 'reinit_menubar', 20);

function  reinit_menubar() {
  global $template;
  if (!defined('IN_ADMIN')
  include_once(PHPWG_ROOT_PATH.'include/menubar.inc.php');
}
?>

vincent3569
2010-03-08 22:00:29

je vais devoir modérer mes ardeurs !

Menubar
Id Auteur Nom Position Masquer

Fatal error: Cannot use object of type DisplayBlock as array in /mnt/122/free.fr/4/9/vincent.bourganel/piwigo/_data/templates_c/sg7fbl^%%93^93A^93A51EBD%%menubar.tpl.php on line 29

message d'erreur affiché lorsque j'essaie (sans succès) d'accéder aux pages d'admin de piwigo

au cas où, rappel du contenu de mon footer

[...]
    {if isset($USERNAME)}
    &nbsp;|&nbsp;<a href="{$U_PROFILE}" title="{'hint_customize'|@translate}">{$USERNAME}</a>
    {/if}

    {if isset($U_ADMIN)}
    &nbsp;|&nbsp;<a href="{$U_ADMIN}" title="{'hint_admin'|@translate}">{'admin'|@translate}</a>
    {/if}

    {if isset($U_LOGIN)}
    &nbsp;|&nbsp;<a href="{$U_LOGIN}" rel="nofollow">{'Connection'|@translate}</a>
    {/if}

    {if isset($U_LOGOUT)}
    &nbsp;|&nbsp;<a href="{$U_LOGOUT}">{'logout'|@translate}</a>
    {/if}

    {if isset($ContactFormLink)}
    &nbsp;|&nbsp;{$ContactFormLink}
    {/if}
   
    &nbsp;|&nbsp;<a href="notification.php" title="flux RSS" rel="nofollow">RSS <img src="template-extension/yoga/feed-icon.png" alt="Flux RSS"/></a>
[...]

une suggestion ?

vincent3569
2010-03-08 21:44:58

tip-top nickel-chrome !!
ça marche extactement comme je voulais (même si je comprends pas un traitre mot de ce que j'ai fait)

merci du tuyau

VDigital
2010-03-08 21:09:36

Quid de extension:144
et de l'onglet Plugin personnel?

tosca
2010-03-08 18:48:30

vincent3569 a écrit:

mais il y a la petite phrase "plugin perso (actif)" que je ne suis pas certain de comprendre : comment on active les plugin une fois que j'ai posé ce fichier sur mon serveur ?

Dans Administration > Spéciales > Plugins, tu trouves ton plugin, et tu cliques sur la petite icône qui permet de l'activer.

vincent3569
2010-03-08 18:42:42

oulàlà, voilà le moment tant redouté du plugin peso auquel je pipe rien...

après m'être plongé dans le wiki, je comprends ceci :

- je fais un fichier main.inc.php qui contient ce bout de code

<?php
/*
Plugin Name: contextTransfert
Version: 0.1
Description: Permet de transférer les contexte utilisateur entre les différentes pages de la galerie
Plugin URI: http://www.phpwebgallery.net
*/

if (!defined('PHPWG_ROOT_PATH')) die('Hacking attempt!');

add_event_handler('loc_after_page_header', 'reinit_menubar', 20);

function  reinit_menubar() {
  global $template;
  include_once(PHPWG_ROOT_PATH.'include/menubar.inc.php');
}
?>

- je pose ce fichier php sous plugin/contextTransfert

mais il y a la petite phrase "plugin perso (actif)" que je ne suis pas certain de comprendre : comment on active les plugin une fois que j'ai posé ce fichier sur mon serveur ?

VDigital
2010-03-08 16:38:47

Je n'ai pas testé mais en plugin perso (actif), ceci devrait être suffisant:

add_event_handler('loc_after_page_header', 'reinit_menubar', 20);

function  reinit_menubar() {
  global $template;
  include_once(PHPWG_ROOT_PATH.'include/menubar.inc.php');
}

vincent3569
2010-03-08 16:02:12

je vais regarder ça en détail ton post.

pour repréciser mon pb :
j'ai positionné un certain nombre de fonctionnalité du menu vers le footer (connexion, personnalisation, contact).

mon but à terme : ne pas avoir de menu et uniquement une navigation par les images.

mon problème : lorsque je navigue entre les pages, le footer "se vide".
ainsi, sur la page pictures, je perds le lien connexion/deconnexion (suivant si je suis connecté ou pas), et le lien personnalisation.
je ne perds pas le lien administrer (si je suis connecté sur un compte admin).


comme tu es identifié sur ma galerie, tu peux te connecter et visualiser ce fonctionnement.


comment faire pour que ces liens soient correctement affichés sur toutes mes pages ?

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact