Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

grodid
2009-10-03 12:07:35

Bon, c'est résolu, je m'étais un peu planté dans le paramétrage de mon pare-feu sous Vista.

Néanmoins, il m'a fallu remonter à PHP 5.2.11 (je suis passé directement de 5.2.0 à 5.2.11 sans explorer les intermédiaires ;-),
à cause d'une erreur php sur le serveur avec PHP 5.2.0 :
call to undefined function memory_get_usage() dans ws_functions.inc.php on line 964

A part cela, il me reste encore un petit glitch, tjs sur le serveur :
PHP Notice: Undefined variable: user in config_param.inc.php on line 30 (et 58)

C'est grave docteur :-) ??

Merci pour ton coup de main efficace, VDigital, et bravo pour votre travail à tous !

Gilbert.

grodid
2009-10-02 16:16:24

Bien sur, excuse-moi, je n'ai pas ete assez clair.

Je tourne bien en PHP 5.2.0, comme le montre le petit panneau indicateur de WampServer2 dans la barre des taches.

Je n'ai plus ces erreurs liees a magic_quotes_runtime, et je n'ai plus d'erreurs liees a exif, comme avant.
D'ailleurs, il n'y a plus d'erreur du tout dans aucun des 4 log files auxquelles WampServer donne acces.

Mais pLoader refuse tjs de se connecter.

Il y a surement un pb de pare-feu la-dessous, mais je ne suis pas un expert Windows.

Gilbert.

VDigital
2009-10-02 16:00:33

Je suis un peu surpris par les résultats de ton test.

http://us2.php.net/manual/fr/migration53.deprecated.php

Je crois (de mémoire) que je tourne en 5.2 chez moi (je ne suis pas chez moi dans le cas présent) et que je n'ai aucun warning de ce genre.

set_magic_quotes_runtime() est dans la liste des fonctions qui ne sont plus supportées par php6.
Il n'existe pas de liste de DEPRECATED functions en version 5 et antérieure à celle de la 5.3

(Arrêt/relance de WampServer2 pour être certain du passage en 5.2)

grodid
2009-10-02 15:37:52

OK, merci Ron, c'est bien ce que je pensais.

Entre temps, j'ai essaye la solution de VD, mais le passage en PHP 5.2.0 n'a rien change.

Gilbert.

ron
2009-10-02 15:11:52

grodid a écrit:

Ces erreurs empechent-elles la connection ?

Oui, les warnings sont retournés en même temps que le statut de connection au serveur et pLoader n'arrive pas à lire cette réponse et donc l'interprète comme une erreur.

grodid
2009-10-01 21:45:58

OK, merci, j'essaye dès que possible, et je vous tiens au courant.

Gilbert.

VDigital
2009-10-01 21:09:27

grodid a écrit:

WAMPSERVER2 et PHP5.3.0

Puisque tu es avec WampServer2 essaie d'installer et de fonctionner en php 5.2.0 et ...

grodid
2009-10-01 18:20:18

Additif au message #9, pour ne pas melanger les topics : mon pb avec pLoader subsiste
alors que j'ai refait mon installation sous Vista, et que mon serveur est distant
(plus de localhost dans l'URL du site cible par pLoader a l'ouverture).
Le message d'erreur est strictement le meme (snif).

J'ai verifie qu'un FTP (vers le port 21 de mon serveur) marchait bien (log file de FileZilla).

Mais il n'y a rien a faire pour que pLoader se connecte.

J'ai releve dans l'access log d'Apache les 3 messages suivants a chaque essai de connexion :

134.158.90.106 - grodip [30/Sep/2009:16:13:10 +0200] "POST /tpiwigo1/ws.php?format=json HTTP/1.1" 200 383
134.158.90.106 - grodip [30/Sep/2009:16:13:10 +0200] "GET /tpiwigo1/ws.php?format=json&method=pwg.categories.getList&recursive=true HTTP/1.1" 200 5201
134.158.90.106 - grodip [30/Sep/2009:16:13:10 +0200] "GET /tpiwigo1/ws.php?format=json&method=pwg.tags.getAdminList HTTP/1.1" 401 370

Beaucoup plus inquietantes, a mon avis, sont les erreurs relevees dans l'error log d'Apache pour le meme essai :

[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Deprecated:  Function set_magic_quotes_runtime() is deprecated in C:\\wamp\\www\\tpiwigo1\\include\\common.inc.php on line 31
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, boolean given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 527
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Deprecated:  Function set_magic_quotes_runtime() is deprecated in C:\\wamp\\www\\tpiwigo1\\include\\common.inc.php on line 31
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, boolean given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 527
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, array given in C:\\wamp\\www\\tpiwigo1\\include\\ws_protocols\\json_encoder.php on line 61
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, array given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, array given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, array given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, array given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, array given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, integer given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, integer given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, null given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, null given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, integer given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, integer given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, integer given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, integer given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, integer given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, integer given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 272
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, string given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 282
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Deprecated:  Function set_magic_quotes_runtime() is deprecated in C:\\wamp\\www\\tpiwigo1\\include\\common.inc.php on line 31
[Wed Sep 30 16:13:10 2009] [error] [client 134.158.90.106] PHP Warning:  get_class() expects parameter 1 to be object, boolean given in C:\\wamp\\www\\tpiwigo1\\include\\ws_core.inc.php on line 527

Ces erreurs empechent-elles la connection ?

Vos lumieres sauront-elles m'eclairer ?

Merci d'avance,   Gilbert.

grodid
2009-10-01 18:06:40

Bonjour,

Une petite precision, on ne sait jamais : ce message est affiche en haut de chaque page qd
je visite mon site installe avec WAMPSERVER2 et PHP5.3.0 :
Deprecated: Function set_magic_quotes_runtime() is deprecated in C:\wamp\www\tpiwigo1\include\common.inc.php on line 31

Cela pourrait-il etre a l'origine de mon pb avec pLoader, svp ?

Dans tous les cas, comment faire pour eviter cela ?

Merci d'avance,   Gilbert.

grodid
2009-09-29 18:29:08

Bonjour,

Je suis desole de me sentir oblige de reveiller un peu ce topic,
mais je n'arrive pas a connecter pLoader a mon serveur Web de test local (localhost).

Description cote client :
- pLoader 2.0.3a sur WinXP SP2

Cote Serveur :
- Piwigo 2.0.4 sur Win XP SP2 (le meme, of course), installe au dessus de WAMPSERVER2

Qd je lance pLoader, et que je rentre l'info (pour etre precis, le champ 'adresse du site piwigo' est : http://localhost/tpiwigo1),
j'obtiens une fenetre avec le titre 'erreur de connection a Piwigo',
et le message : 'la connection a http://localhost/tpiwigo1 a echoue'.
Le login/pwd que j'utilise dans cet essai est correctement enregistre comme administrateur.

Bien sur, mon serveur tourne correctement, et j'ai reussi a me logger dessus avec Firefox, pour y configurer un certain nb de parametres.

J'ai desinstalle moult fois pLoader pour essayer la 2.0.2c 9entre autres), comme suggere dans d'autres discussions, mais sans succes.
J'ai aussi supprime les dossiers .pLoader et par-<user> comme suggere ailleurs, meme punition.

J'ai essaye pLoader avec mon autre galerie Piwigo sur un site public, et cela marche tout comme il faut.

Tout cela me parait bien etrange. Une idee ?

Merci d'avance pour votre aide.

Gilbert.

ron
2009-08-22 09:12:43

Je me suis connecté à ta galerie avec l'identifiant que  tu m'as transmis. La version actuelle de pLoader ne peut effectivement pas se connecter à ta galerie. J'ai dû modifier un paramètre dans l'identification du user agent utilisé par pLoader afin de tromper le serveur et lui faire croire que c'est un navigateur ( Mozilla ) qui se connecte. Il doit s'agir de règles de sécurité au niveau du serveur.

J'ai pu créer une catégorie, par contre l'envoi de photos retourne une erreur 500 "file transfert failed". Je vais avoir besoin des compétences de plg pour éclaircir tout ça.

ron
2009-08-21 08:35:13

Photoslive a écrit:

cependant pour ploader, ça ne fonctionne tjs pas, j'ai réinstallé la dernière vs, nada c'est tjs le même message.

Peux tu me transmettre en MP un login/password pour que je fasse un test de connexion à ta galerie ?

Photoslive
2009-08-19 23:22:26

bien vu et merci pour le plugin auto upgrade.
Je suis donc passé en qqls secondes à piwigo 2.0.3 :-)

cependant pour ploader, ça ne fonctionne tjs pas, j'ai réinstallé la dernière vs, nada c'est tjs le même message.

Ludo

VDigital
2009-08-19 21:18:02

Photoslive a écrit:

PS : je passerai en vs en 2.0.3 un peu plus tard il faut que je lise correctement le wiki pour ne pas faire de bêtises, je n'ai pas envie de tout casser lol

extension:302

Et cela devrait t'éviter quelques questions inutiles.

Photoslive
2009-08-19 19:18:11

Salut,

Bon, j'ai réinstallé ploader 2.0.2c mais j'ai le même message, rien n'y fait.

j'ai lu sur le forum qu'une personne avait eu le même soucis que moi mais ensuite il s'est dirigé vers des catégories physiques.
C'est dommage car ploader semblait bien pratique :-(
c'est dingue que d'un coup comme ça il me mette en erreur.

y a -t-il un autre plugin moyen pour transférer ces photos comme ploader ?
si non, je vais tout recréer en catégories physiques et passer par mon ftp.

Merci de votre aide.

Ludovic

PS : je passerai en vs en 2.0.3 un peu plus tard il faut que je lise correctement le wiki pour ne pas faire de bêtises, je n'ai pas envie de tout casser lol

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact