Différences

Cette page vous donne les différences entre la révision choisie et la version actuelle de la page.

Lien vers cette vue

utiliser:apprendre:install:installation:free.fr [2018/02/15 11:45]
plg avertissement sur Free.fr
utiliser:apprendre:install:installation:free.fr [2018/11/08 16:11] (Version actuelle)
klaoun [Hébergeur Free.fr]
Ligne 1: Ligne 1:
 ====== Hébergeur Free.fr ====== ====== Hébergeur Free.fr ======
  
-<WRAP center important round 60%>(note du 15 février 2018) L'hébergeur Free.fr est attractif d'un point de vue financier, mais il est loin de constituer une solution idéale pour hébergeur votre Piwigo. Free.fr n'est donc pas un hébergement recommandé .</WRAP>+<WRAP center important round 60%>(note du 15 février 2018) L'hébergeur Free.fr est attractif d'un point de vue financier, mais il est loin de constituer une solution idéale pour "hébergeurvotre Piwigo. Free.fr n'est donc pas un hébergement recommandé.</WRAP>
  
 Le fournisseur d'accès à internet "free.fr" propose à prix hyper compétitif une solution d'hébergement. Celle-ci à le mérite d'être gratuite sauf que toutes les fonctionnalités que l'on est en droit d'attendre d'un hébergement web ne sont pas forcément présentes. Le fournisseur d'accès à internet "free.fr" propose à prix hyper compétitif une solution d'hébergement. Celle-ci à le mérite d'être gratuite sauf que toutes les fonctionnalités que l'on est en droit d'attendre d'un hébergement web ne sont pas forcément présentes.
Ligne 7: Ligne 7:
 Certaines limitations et impositions obligent les possesseurs de galerie à faire attention à certains points. Certaines limitations et impositions obligent les possesseurs de galerie à faire attention à certains points.
  
-  - Créer un dossier nommé "''<wrap em>sessions</wrap>''" à la racine de votre serveur+  - Créer un dossier nommé "''<wrap em>sessions</wrap>''" à la racine de votre serveur et créer un fichier .htaccess 
-  - Votre galerie ne doit pas directement être installé à la racine((C'est à dire à la base)) de votre hébergement. Laissez donc le répertoire ''./piwigo'' pour installer votre galerie dans un sous-répertoire chez Free+  - Utilisation du plugin [[http://fr.piwigo.org/ext/extension_view.php?eid=315|mail supervisor]] pour l'envoi des emails depuis votre galerie. Incompatible avec la version 2.9
-  - Il est important de créer une page d'accueil (HTML toute simple par exemple) à la racine de votre hébergement. Cette page ne doit contenir de renvoie automatique. +
-  - L'installation démarre en accédant à l'adresse : http://mon.site.free.fr/mon.piwigo (à adapter en fonction de votre adresse).+
   - Désactivation recommandée de l'historique de Piwigo.   - Désactivation recommandée de l'historique de Piwigo.
-  - Utilisation du plugin [[http://fr.piwigo.org/ext/extension_view.php?eid=315|mail supervisor]] pour l'envoi des emails depuis votre galerie. 
   - Ne pas utiliser la génération automatique de miniature sur un trop grand nombre de photos.\\ <wrap info>__Renvoi__ :</wrap> Plus d'informations sur "[[utiliser:apprendre:faq#pourquoi_eviter_d_utiliser_la_generation_automatique_des_vignettes|Pourquoi éviter d'utiliser la génération automatique de miniatures.]]"   - Ne pas utiliser la génération automatique de miniature sur un trop grand nombre de photos.\\ <wrap info>__Renvoi__ :</wrap> Plus d'informations sur "[[utiliser:apprendre:faq#pourquoi_eviter_d_utiliser_la_generation_automatique_des_vignettes|Pourquoi éviter d'utiliser la génération automatique de miniatures.]]"
   - Ne pas utiliser la génération des tailles multiples sur un trop grand nombre de photos (voir la raison invoquée dans le point précédent).   - Ne pas utiliser la génération des tailles multiples sur un trop grand nombre de photos (voir la raison invoquée dans le point précédent).
   - Souvenez-vous que l'utilisation de l'historique est prohibée chez Free. Vérifiez qu'il est désactivé une fois votre galerie installée.   - Souvenez-vous que l'utilisation de l'historique est prohibée chez Free. Vérifiez qu'il est désactivé une fois votre galerie installée.
 +  - Si votre piwigo est installé en racine,Il est recommandé et important de créer une page d'accueil (HTML toute simple par exemple) à la racine de votre hébergement. Cette page ne doit pas contenir de renvoi automatique.
 +  - Les mises à jour automatiques ne fonctionne pas, donc obligé de réaliser la mise à jour de Piwigo à la main via FTP... Lire [[https://fr.piwigo.org/doc/doku.php?id=utiliser:apprendre:install:installation:free.fr#mise_a_jour_manuelle|ceci]]. Par contre les Plugins peuvent se mettre à jour automatiques dans l'interface de votre piwigo.
 +  - L'installation démarre en accédant à l'adresse : http://mon.site.free.fr/mon.piwigo (à adapter en fonction de votre adresse).
 +  - Votre galerie peut être installé à la racine((C'est à dire à la base)) de votre hébergement. Recommandation : Laissez donc le répertoire ''./piwigo'' pour installer votre galerie dans un sous-répertoire chez Free.
   - En cas de problèmes, vérifier le point suivant : Chapitre : [[utiliser:apprendre:faq#les_messages_d_erreurs_depannage|En cas d'erreur]]   - En cas de problèmes, vérifier le point suivant : Chapitre : [[utiliser:apprendre:faq#les_messages_d_erreurs_depannage|En cas d'erreur]]
-  - Limitations quand aux fichiers envoyé via pLoader (et autre logiciels externes). Lire [[http://fr.piwigo.org/forum/viewtopic.php?pid=174929#p174929|ceci]] sur le forum. +  - Limitations quand aux fichiers envoyé via pLoader voir taille :2Mo pixel:2700 X 2700. Lire [[http://fr.piwigo.org/forum/viewtopic.php?pid=174929#p174929|ceci]] sur le forum.
-  - Les mises à jour automatiques ne fonctionne plus, donc obligé de réaliser la mise à jour de Piwigo & Plugins à la main via FTP... Lire [[http://fr.piwigo.org/forum/viewtopic.php?pid=184846#p184846|ceci]] sur le forum.+
   - L'installation via NetInstall ne fonctionne pas plus (voir la raison invoquée dans le point précédent).   - L'installation via NetInstall ne fonctionne pas plus (voir la raison invoquée dans le point précédent).
 +
 +===== Htaccess différent =====
 +Le tableau explique de quelle version php doit-on utiliser pour utiliser piwigo. Par exemple, si vous utilisez piwigo version 2.6, il y aura un bug si vous utiliserez php 5.1.3rc4
 +
 +**__//''Configuration du fichier htaccess''//__**
 +  -créer un fichier en extension .htaccess
 +
 +^htaccess^PHP^fichier^
 +|pas de code|4.4.3dev|
 +|<code><Files .htaccess>
 +order allow,deny
 +deny from all
 +</Files>
 +#php5 en actif
 +<IfDefine Free>
 +php 1
 +</IfDefine></code>|5.1.3rc4|<file .htaccess .htaccess>
 +<Files .htaccess>
 +order allow,deny
 +deny from all
 +</Files>
 +#php5 en actif
 +<IfDefine Free>
 +php 1
 +</IfDefine>
 +</file>|
 +|<code><Files .htaccess>
 +order allow,deny
 +deny from all
 +</Files>
 +#php5 en actif
 +<IfDefine Free>
 +php56 1
 +</IfDefine></code>|5.6.8/5.6.23/5.6.34|<file .htaccess .htaccess>
 +<Files .htaccess>
 +order allow,deny
 +deny from all
 +</Files>
 +#php5 en actif
 +<IfDefine Free>
 +php56 1
 +</IfDefine>
 +</file>|
 +|?|7.0/7.1+/7.2+|
 +
 +^Version^PHP 4.4.3dev^PHP 5.1.3rc4^PHP 5.6.8^PHP 5.6.23 ou 5.6.34^PHP 7.0^PHP 7.1+^PHP 7.2+^
 +|Piwigo 2.4.x|?|ok|ok|ok|?|?|?|
 +|Piwigo 2.5.x|?|ok|ok|?|?|?|?|
 +|Piwigo 2.6.x|?|code datetime|?|?|?|?|?|
 +|Piwigo 2.7.x|ne fonctionne pas|ne fonctionne pas|ok|?|?|?|?|
 +|Piwigo 2.8.x|?|?|ok|?|?|?|?|
 +|Piwigo 2.9.x|parse error ligne 332|?|ok|ok|?|?|?|
 +===== Nouvelle installation Piwigo version (2.8.x/2.9.x) =====
 +1.télécharger la 2.9.4 par exemple : https://piwigo.org/download/dlcounter.php?code=2.9.4
 +
 +2.dezipper dans un dossier et l'insérer sur votre site totalement par ftp via filezilla. Attention à ne pas avoir de fichier dans transferts échoués
 +
 +3.remplir les champs du formulaire
 +
 +5.cliquer sur le bouton démarrer l'installation. attendre un peu que ca finisse.
 +
 +6.voila votre galerie est prête.
 +
 +<wrap important>
 +
 +ATTENTION vous pouvez rencontrer un souci lors de téléchargement d'images, ou tout simplement vous retrouver avec un site qui n'est plus accessible.</wrap>
 +
 +Solution : changer la ligne 48 du fichier include/smarty/libs/plugins/shared.mb_str_replace.php
 +       remplacer : $parts = mb_split(preg_quote($search), $subject);
 +       par : $parts = preg_split('~preg_quote($search)~', $subject);
  
 ===== Nouvelle Installation (2.5.x) ou (2.6.x) ===== ===== Nouvelle Installation (2.5.x) ou (2.6.x) =====
Ligne 116: Ligne 186:
 </code> </code>
  
-===== Création d'un .htaccess personnalisé ===== 
-#blocage d'acces sur le fichier en protégé\\ 
-<Files .htaccess>\\ 
-order allow,deny\\ 
-deny from all\\ 
-</Files>\\ 
-#php5 en actif\\ 
-<IfDefine Free>\\ 
-php 1\\ 
-</IfDefine> 
- 
-===== dans phpmyadmin ===== 
-l'interclassement : UTF8_general_ci\\ 
-type ou moteur de stockage : Myisam\\ 
-jeu de caractere : UTF8 Unicode\\ 
-et 32 tables disponibles pour la bdd standard\\ 
- 
-===== mise à jour manuelle ===== 
- 
-la mise à jour de la version 2.5.3 et 2.6.0 ont besoin de mettre à jour la base de donnée. Il y a 4 tables : 
- 
-1 piwigo_images 
  
-2 piwigo_user_cache 
  
-3 piwigo_user_cache_categories 
  
-4 piwigo_user_infos 
  
-il y a aussi des contenus dans piwigo_config d'où les 3 thèmes dans les emails, des contenus dans piwigo_language d'où les ajouts des langues et ces versions, des contenus supprimés dans piwigo_themes (en laissant que élégant et smartpocket activé), des contenus dans piwigo_upgrade (135 à 139) 
  
 ===== Version 2.7.x ===== ===== Version 2.7.x =====
Ligne 194: Ligne 238:
 <wrap important>free n'est pas compatible par défaut avec le .htaccess php1! Voir ci dessous la soluce</wrap> <wrap important>free n'est pas compatible par défaut avec le .htaccess php1! Voir ci dessous la soluce</wrap>
  
-===== Création d'un .htaccess personnalisé ===== 
-#blocage d'acces sur le fichier en protégé\\ 
-<Files .htaccess>\\ 
-order allow,deny\\ 
-deny from all\\ 
-</Files>\\ 
-#php5 en actif\\ 
-<IfDefine Free>\\ 
-php56 1\\ 
-</IfDefine>\\ 
  
 +===== Mise à jour manuelle =====
  
-^Version^PHP 4.4.3dev^PHP 5.1.3rc4^PHP 5.6.8^PHP 5.6.23 ou 5.6.31^PHP 7.0^PHP 7.1+^ +Pour passer de la version 2.8.6 à 2.9 etc... tout comme 2.9.3 à 2.9.4 etc..., la mise à jour se fait tout simplement manuellementIl suffit simplement de lire attentivement la page  
-|Piwigo 2.5.x|?|ok|ok|?|?|?| +[[https://fr.piwigo.org/doc/doku.php?id=utiliser:apprendre:install:maj:maj_manuelle|Mise à jour manuelle]]
-|Piwigo 2.6.x|?|code datetime|?|?|?|?| +
-|Piwigo 2.7.x|ne fonctionne pas|ne fonctionne pas|ok|?|?|?| +
-|Piwigo 2.8.x|?|?|ok|?|?|?| +
-|Piwigo 2.9.x|parse error ligne 332|?|ok|?|?|?| +
- +
-===== Versions 2.8.x et 2.9.x ===== +
- +
-1.télécharger la 2.9.2 par exemple : http://piwigo.org/download/dlcounter.php?code=2.9.2 +
- +
-2.dezipper dans un dossier et l'insérer sur votre site totalement par ftp via filezilla. Attention à ne pas avoir de fichier dans transferts échoués +
- +
-3.quand c'est fini, aller sur un navigateur web d'où internet explorer, taper l'adresse url de votre galerie. +
- +
-<code php> +
-<?php +
-$conf['dblayer'] = 'mysqli'; // Type de BDD +
-$conf['db_base'] = 'identifiant'; // Nom de la base de données +
-$conf['db_user'] = 'identifiant'; // Votre identifiant de connection à votre BDD +
-$conf['db_password'] = 'xxxxxx'; // Votre mot de passe pour la connection à votre BDD +
-$conf['db_host'] = 'localhost'; // Nom d'hôte de votre BDD +
-  +
-$prefixeTable = 'piwigo_'; // Préfixe des tables +
-  +
-define('PHPWG_INSTALLED', true); +
-define('PWG_CHARSET', 'utf-8'); +
-define('DB_CHARSET', 'utf8'); +
-define('DB_COLLATE', ''); +
-  +
-?> +
-</code> +
- +
-4.remplir les champs : utilisateur : xxx (écrire le nom, par exemple si votre site est url =⇒ xxx.free.fr) +
- +
-mot de passe : MDP (écrire le mot de passe MySQL) +
- +
-nom de la base : xxx (écrire le même utilisateur et le nom de la base) +
- +
-préfixe de piwigo : def (vous pouvez toujours le modifier ce n'est pas obligatoire de le modifier) +
- +
-identifiant utilisateur : ghi (écrire un nom de connexion pour vous même donc webmaster) +
- +
-mot de passe : jkl (mot de passe pour le webmaster) +
- +
-adresse email : xxx@free.fr (adresse email du webmaster) +
- +
-5.cliquer sur le bouton démarrer l'installation. attendre un peu que ca finisse. +
- +
-6.voila votre galerie est prête. +
- +
-<wrap important> +
- +
-ATTENTION vous pouvez rencontrer un souci lors de téléchargement d'images, ou tout simplement vous retrouver avec un site qui n'est plus accessible.</wrap> +
- +
-Solution : changer la ligne 48 du fichier include/smarty/libs/plugins/shared.mb_str_replace.php +
-       remplacer $parts = mb_split(preg_quote($search), $subject); +
-       par $parts = preg_split('~preg_quote($search)~', $subject); +
- +
-==== Mise à jour manuelle ====+
  
-Pour passer de 2.8.6 à 2.9, la mise à jour se fait manuellementIl suffit simplement de lire attentivement la page  +ou alors par exemple Si vous utilisez actuellement Piwigo 2.9.x, vous pouvez télécharger l'archive [[https://piwigo.org/download/dlcounter.php?code=29xto294|Mise à jour 29xto294]] qui ne contient que les fichiers nouveaux ou modifiés. Une fois les fichiers extraits, transférez-les par FTP sur votre site par dessus votre installation 2.9.x. Votre base de données n'a pas besoin de mise à jour 
-[[http://fr.piwigo.org/basics/upgrade_manual|Mise à jour manuelle]]+===== Https/ssl ===== 
 +Bientôt... je ferai un récapitultif ici
 
Haut de page
utiliser/apprendre/install/installation/free.fr.1518691549.txt.gz · Dernière modification: 2018/02/15 11:45 par plg
 
 
github twitter facebook newsletter Faire un don Piwigo.org © 2002-2018 · Contact